aboutsummaryrefslogtreecommitdiff
path: root/devel/devtodo
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-06-09 12:38:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-06-09 12:38:27 +0000
commit64a783b3a8aa6fffc8869e266d0dc3d66681dfce (patch)
tree873e51eb78188e9f56b50a3721d3e6ca6a277caa /devel/devtodo
parent0c96f7d594fdc2915b8bdde71aea20d0793d4ce1 (diff)
downloadports-64a783b3a8aa6fffc8869e266d0dc3d66681dfce.tar.gz
ports-64a783b3a8aa6fffc8869e266d0dc3d66681dfce.zip
devtodo is a program to assist developers (or anybody who uses a
terminal) in maintaining a list of outstanding tasks in a heirarchical, prioritised, list. Additionally, it can automatically list outstanding items when you change into a directory (see example shell configurations in ${PREFIX}/share/examples/devtodo). WWW: http://www.sourceforge.net/projects/devtodo/ PR: 27659 Submitted by: petef@databits.net
Notes
Notes: svn path=/head/; revision=43702
Diffstat (limited to 'devel/devtodo')
-rw-r--r--devel/devtodo/Makefile31
-rw-r--r--devel/devtodo/distinfo1
-rw-r--r--devel/devtodo/pkg-comment1
-rw-r--r--devel/devtodo/pkg-descr10
-rw-r--r--devel/devtodo/pkg-plist11
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/devtodo/Makefile b/devel/devtodo/Makefile
new file mode 100644
index 000000000000..823372f2f8a5
--- /dev/null
+++ b/devel/devtodo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devtodo
+# Date Created: 26 May 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= devtodo
+PORTVERSION= 0.1.6.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.1.6-1
+
+MAINTAINER= petef@databits.net
+
+WRKSRC= ${WRKDIR}/devtodo-0.1.6
+
+GNU_CONFIGURE= Yes
+
+MAN1= devtodo.1
+MLINKS= devtodo.1 tda.1 devtodo.1 tdd.1 devtodo.1 tde.1 devtodo.1 tdr.1 \
+ devtodo.1 todo.1
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/devtodo
+.for file in doc/scripts.sh doc/scripts.tcsh doc/todorc.example
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/examples/devtodo
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/devtodo/distinfo b/devel/devtodo/distinfo
new file mode 100644
index 000000000000..15b376ed1dce
--- /dev/null
+++ b/devel/devtodo/distinfo
@@ -0,0 +1 @@
+MD5 (devtodo-0.1.6-1.tar.gz) = 7c96b5401cc64a3dc9a8b57083273c6f
diff --git a/devel/devtodo/pkg-comment b/devel/devtodo/pkg-comment
new file mode 100644
index 000000000000..0f702d9f4f54
--- /dev/null
+++ b/devel/devtodo/pkg-comment
@@ -0,0 +1 @@
+Tool to effectively maintain todo lists aimed at developers
diff --git a/devel/devtodo/pkg-descr b/devel/devtodo/pkg-descr
new file mode 100644
index 000000000000..3f76195707e3
--- /dev/null
+++ b/devel/devtodo/pkg-descr
@@ -0,0 +1,10 @@
+devtodo is a program to assist developers (or anybody who uses a
+terminal) in maintaining a list of outstanding tasks in a heirarchical,
+prioritised, list. Additionally, it can automatically list outstanding
+items when you change into a directory (see example shell configurations
+in ${PREFIX}/share/examples/devtodo).
+
+WWW: http://www.sourceforge.net/projects/devtodo/
+
+- Pete
+petef@databits.net
diff --git a/devel/devtodo/pkg-plist b/devel/devtodo/pkg-plist
new file mode 100644
index 000000000000..d8b6fa639874
--- /dev/null
+++ b/devel/devtodo/pkg-plist
@@ -0,0 +1,11 @@
+bin/devtodo
+bin/tda
+bin/tdd
+bin/tde
+bin/tdr
+bin/todo
+etc/todorc
+share/examples/devtodo/scripts.sh
+share/examples/devtodo/scripts.tcsh
+share/examples/devtodo/todorc.example
+@dirrm share/examples/devtodo