aboutsummaryrefslogtreecommitdiff
path: root/devel/devtodo
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-22 17:07:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-22 17:07:38 +0000
commitba136a0db35024fc98c9a681fb31f175db38a520 (patch)
treec0c3dbab620e263b6c56e349125282163ca5e2db /devel/devtodo
parent5adedbffa005a04acd367629f9e6ff76362f9206 (diff)
downloadports-ba136a0db35024fc98c9a681fb31f175db38a520.tar.gz
ports-ba136a0db35024fc98c9a681fb31f175db38a520.zip
- Fix runtime bug
PR: ports/118949 Submitted by: Jeppe Larsen <jwl@io.dk> Obtained from: http://swapoff.org/ticket/54
Notes
Notes: svn path=/head/; revision=204360
Diffstat (limited to 'devel/devtodo')
-rw-r--r--devel/devtodo/Makefile1
-rw-r--r--devel/devtodo/files/patch-util-XML.cc11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/devtodo/Makefile b/devel/devtodo/Makefile
index 53bacda859a9..b2d83e4938f0 100644
--- a/devel/devtodo/Makefile
+++ b/devel/devtodo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= devtodo
PORTVERSION= 0.1.20
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://swapoff.org/files/devtodo/
diff --git a/devel/devtodo/files/patch-util-XML.cc b/devel/devtodo/files/patch-util-XML.cc
new file mode 100644
index 000000000000..5a2d4a3ec816
--- /dev/null
+++ b/devel/devtodo/files/patch-util-XML.cc
@@ -0,0 +1,11 @@
+--- util/XML.cc.orig Mon Dec 10 22:26:55 2007
++++ util/XML.cc Mon Dec 10 22:27:07 2007
+@@ -49,7 +49,7 @@ void XML::init() {
+ // Only initialise scanners once
+ if (!initialised) {
+ // <?xml version="1.0" encoding="UTF-8" standalone="no"?>
+- xmlScan.addPattern(XmlDecl, "<\\?xml.*?>[[:space:]]*");
++ xmlScan.addPattern(XmlDecl, "<\\?xml.*\\?>[[:space:]]*");
+ xmlScan.addPattern(XmlCommentBegin, "<!--");
+ xmlScan.addPattern(XmlBegin, "<[a-zA-Z0-9_-]+"
+ "([[:space:]]+[a-zA-Z_0-9-]+=(([/a-zA-Z_0-9,.]+)|(\"[^\"]*\")|('[^']*')))"