aboutsummaryrefslogtreecommitdiff
path: root/devel/diffuse
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-12-30 12:56:39 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-12-30 12:56:39 +0000
commitb16d554638fba2bff258a46cab569237f87f141e (patch)
tree677335da7d15f7de35356a3714a5c1eb91eb7ede /devel/diffuse
parent1818674a1aa9478392e5cc1aa3844d40fdf5c352 (diff)
downloadports-b16d554638fba2bff258a46cab569237f87f141e.tar.gz
ports-b16d554638fba2bff258a46cab569237f87f141e.zip
- Trim Makefile header
- Limit python version up to 2.7 - Use a space character instead of a tab in 'pkg-descr' file - Define PORTDOCS unconditionally (regardless of DOCS option) - Remove 'COPYING' from PORTDOCS (redundant with LICENSE) - Remove NO_OPTIONS_SORT (does not matter with only four options) - Remove DOCS_DESC and use standard description - Convert 'for' loops from shell to make syntax - Resort and whitespace cleanup - Bump PORTREVISION PR: ports/174806 (based on) Submitted by: Marco Broder <marco.broeder@gmx.eu> (maintainer)
Notes
Notes: svn path=/head/; revision=309666
Diffstat (limited to 'devel/diffuse')
-rw-r--r--devel/diffuse/Makefile92
-rw-r--r--devel/diffuse/pkg-descr2
2 files changed, 38 insertions, 56 deletions
diff --git a/devel/diffuse/Makefile b/devel/diffuse/Makefile
index bd7dd2268402..61f2727dcd32 100644
--- a/devel/diffuse/Makefile
+++ b/devel/diffuse/Makefile
@@ -1,13 +1,9 @@
-# Ports collection makefile for: diffuse
-# Date created: 2009-02-22
-# Whom: Marco Broeder <marco.broeder@gmx.eu>
-#
+# Created by: Marco Broeder <marco.broeder@gmx.eu>
# $FreeBSD$
-#
PORTNAME= diffuse
PORTVERSION= 0.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= SF
@@ -19,20 +15,21 @@ LICENSE_COMB= dual
NO_BUILD= yes
-USE_PYTHON= yes
-USE_GNOME= pygtk2
USE_BZIP2= yes
-
-MAN1= diffuse.1
+USE_PYTHON= -2.7
+USE_GNOME= pygtk2
CONFLICTS= tinker-[0-9]*
-NO_OPTIONS_SORT= yes
-OPTIONS_DEFINE= MENU DATA NLS DOCS
-MENU_DESC= Enable a desktop program menu entry
+MAN1= diffuse.1
+PORTDOCS= AUTHORS ChangeLog ChangeLog_ru README README_ru
+PORTDATA= syntax
+
+OPTIONS_DEFINE= DATA DOCS MENU NLS
DATA_DESC= Enable syntax highlighting support
-DOCS_DESC= Install some documentation text files
-OPTIONS_DEFAULT= MENU DATA NLS DOCS
+MENU_DESC= Enable a desktop program menu entry
+
+OPTIONS_DEFAULT= DATA MENU
.include <bsd.port.options.mk>
@@ -43,13 +40,7 @@ PLIST_SUB+= MENU=""
PLIST_SUB+= MENU="@comment "
.endif
-.if ${PORT_OPTIONS:MDATA}
-PORTDATA= syntax
-.endif
-
-.if ${PORT_OPTIONS:MNLS} && !defined(WITHOUT_NLS)
-# Both checks required. If option is selected, but WITHOUT_NLS is set
-# in make.conf, it breaks pkg-plist.
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
TRANSLATIONS= de es it ja ko ru zh_CN
MANLANG= "" it ru
@@ -58,12 +49,8 @@ PLIST_SUB+= NLS=""
PLIST_SUB+= NLS="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= AUTHORS COPYING ChangeLog ChangeLog_ru README README_ru
-.endif
-
post-patch:
-.if ${PORT_OPTIONS:MDATA} && !defined(NOPORTDATA)
+.if ${PORT_OPTIONS:MDATA}
${REINPLACE_CMD} -e 's|../usr|${PREFIX}|g; s|/etc|${PREFIX}/etc|g' \
${WRKSRC}/src/etc/${PORTNAME}rc
.else
@@ -71,18 +58,25 @@ post-patch:
import ${PREFIX}|g; s|/etc|${PREFIX}/etc|g' \
${WRKSRC}/src/etc/${PORTNAME}rc
.endif
-
${REINPLACE_CMD} -e 's|../../etc|${PREFIX}/etc|g' \
${WRKSRC}/src/usr/bin/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/src/usr/bin/${PORTNAME} \
- ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/usr/bin/${PORTNAME} ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/src/etc/${PORTNAME}rc ${PREFIX}/etc/
${INSTALL_MAN} ${WRKSRC}/src/usr/share/man/man1/*.1 \
${MANPREFIX}/man/man1/
post-install:
+.if ${PORT_OPTIONS:MDATA}
+ ${MKDIR} ${DATADIR}/${PORTDATA}
+ (cd ${WRKSRC}/src/usr/share/${PORTNAME} && \
+ ${COPYTREE_SHARE} \* ${DATADIR})
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
.if ${PORT_OPTIONS:MMENU}
${INSTALL_DATA} ${WRKSRC}/src/usr/share/pixmaps/${PORTNAME}.png \
${PREFIX}/share/pixmaps/
@@ -90,31 +84,19 @@ post-install:
${DESKTOPDIR}
${LOCALBASE}/bin/update-desktop-database -q
.endif
-
-.if ${PORT_OPTIONS:MDATA} && !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}/syntax
- (cd ${WRKSRC}/src/usr/share/${PORTNAME} && \
- ${COPYTREE_SHARE} \* ${DATADIR})
-.endif
-
-.if ${PORT_OPTIONS:MNLS} && !defined(WITHOUT_NLS)
- for x in ${TRANSLATIONS}; do \
- ${MKDIR} ${WRKSRC}/translations/$${x}; \
- ${LOCALBASE}/bin/msgfmt -c ${WRKSRC}/translations/$${x}.po \
- -o ${WRKSRC}/translations/$${x}/${PORTNAME}.mo; \
- ${INSTALL_DATA} ${WRKSRC}/translations/$${x}/*.mo \
- ${PREFIX}/share/locale/$${x}/LC_MESSAGES/; \
- done
- for y in ${MANLANG}; do \
- ${MKDIR} ${MANPREFIX}/man/$${y}/man1; \
- ${INSTALL_MAN} ${WRKSRC}/src/usr/share/man/$${y}/man1/*.1 \
- ${MANPREFIX}/man/$${y}/man1/; \
- done
-.endif
-
-.if ${PORT_OPTIONS:MDOCS} && !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MNLS}
+.for x in ${TRANSLATIONS}
+ ${MKDIR} ${WRKSRC}/translations/${x}
+ ${LOCALBASE}/bin/msgfmt -c ${WRKSRC}/translations/${x}.po \
+ -o ${WRKSRC}/translations/${x}/${PORTNAME}.mo
+ ${INSTALL_DATA} ${WRKSRC}/translations/${x}/*.mo \
+ ${PREFIX}/share/locale/${x}/LC_MESSAGES/
+.endfor
+.for y in ${MANLANG}
+ ${MKDIR} ${MANPREFIX}/man/${y}/man1
+ ${INSTALL_MAN} ${WRKSRC}/src/usr/share/man/${y}/man1/*.1 \
+ ${MANPREFIX}/man/${y}/man1/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/devel/diffuse/pkg-descr b/devel/diffuse/pkg-descr
index b64dd2657fb4..1c9f0e9f4ef2 100644
--- a/devel/diffuse/pkg-descr
+++ b/devel/diffuse/pkg-descr
@@ -16,4 +16,4 @@ Some key features of Diffuse:
- unlimited undo
- easy keyboard navigation
-WWW: http://diffuse.sourceforge.net/
+WWW: http://diffuse.sourceforge.net/