aboutsummaryrefslogtreecommitdiff
path: root/devel/directfb
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /devel/directfb
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'devel/directfb')
-rw-r--r--devel/directfb/Makefile6
-rw-r--r--devel/directfb/files/patch-interfaces-IDirectFBImageProvider-idirectfbimageprovider_png.c28
-rw-r--r--devel/directfb/files/patch-tools-directfb-csource.c19
-rw-r--r--devel/directfb/files/patch-tools-mkdfiff.c11
-rw-r--r--devel/directfb/files/patch-tools-mkdgifft.cpp11
5 files changed, 72 insertions, 3 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index b693ca0c8f39..039569c74720 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= directfb
PORTVERSION= 1.4.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.directfb.org/downloads/Core/${DISTNAME:R}/
DISTNAME= DirectFB-${PORTVERSION}
@@ -16,7 +16,7 @@ MAINTAINER= anatoly.borodin@gmail.com
COMMENT= Graphic development lightweight API
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -27,7 +27,7 @@ OPTIONS= FREETYPE2 "Enable Freetype support" on \
UNIQUE "Enable Unique (WM Module)" off \
TESTS "Install test apps" off
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/devel/directfb/files/patch-interfaces-IDirectFBImageProvider-idirectfbimageprovider_png.c b/devel/directfb/files/patch-interfaces-IDirectFBImageProvider-idirectfbimageprovider_png.c
new file mode 100644
index 000000000000..10773d9c32a6
--- /dev/null
+++ b/devel/directfb/files/patch-interfaces-IDirectFBImageProvider-idirectfbimageprovider_png.c
@@ -0,0 +1,28 @@
+--- interfaces/IDirectFBImageProvider/idirectfbimageprovider_png.c.orig 2011-05-05 20:00:29.000000000 +0200
++++ interfaces/IDirectFBImageProvider/idirectfbimageprovider_png.c 2012-05-01 09:15:37.000000000 +0200
+@@ -33,6 +33,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <png.h>
++#include <pngpriv.h>
+ #include <string.h>
+ #include <stdarg.h>
+
+@@ -207,7 +207,7 @@
+ if (!data->png_ptr)
+ goto error;
+
+- if (setjmp( data->png_ptr->jmpbuf )) {
++ if (setjmp( png_jmpbuf(data->png_ptr))) {
+ D_ERROR( "ImageProvider/PNG: Error reading header!\n" );
+ goto error;
+ }
+@@ -292,7 +292,7 @@
+ rect = dst_data->area.wanted;
+ }
+
+- if (setjmp( data->png_ptr->jmpbuf )) {
++ if (setjmp( png_jmpbuf(data->png_ptr))) {
+ D_ERROR( "ImageProvider/PNG: Error during decoding!\n" );
+
+ if (data->stage < STAGE_IMAGE)
diff --git a/devel/directfb/files/patch-tools-directfb-csource.c b/devel/directfb/files/patch-tools-directfb-csource.c
new file mode 100644
index 000000000000..d692faea15b9
--- /dev/null
+++ b/devel/directfb/files/patch-tools-directfb-csource.c
@@ -0,0 +1,19 @@
+--- tools/directfb-csource.c.orig 2011-05-05 20:00:29.000000000 +0200
++++ tools/directfb-csource.c 2012-04-29 06:09:30.000000000 +0200
+@@ -41,6 +41,7 @@
+ #include <sys/stat.h>
+
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include <directfb.h>
+
+@@ -338,7 +339,7 @@
+ if (!png_ptr)
+ goto cleanup;
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ if (desc->preallocated[0].data) {
+ free (desc->preallocated[0].data);
+ desc->preallocated[0].data = NULL;
diff --git a/devel/directfb/files/patch-tools-mkdfiff.c b/devel/directfb/files/patch-tools-mkdfiff.c
new file mode 100644
index 000000000000..1b41d23ae728
--- /dev/null
+++ b/devel/directfb/files/patch-tools-mkdfiff.c
@@ -0,0 +1,11 @@
+--- tools/mkdfiff.c.orig 2010-10-31 09:49:49.000000000 +0100
++++ tools/mkdfiff.c 2012-04-30 06:43:17.000000000 +0200
+@@ -97,7 +97,7 @@
+ if (!png_ptr)
+ goto cleanup;
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ if (desc->preallocated[0].data) {
+ free (desc->preallocated[0].data);
+ desc->preallocated[0].data = NULL;
diff --git a/devel/directfb/files/patch-tools-mkdgifft.cpp b/devel/directfb/files/patch-tools-mkdgifft.cpp
new file mode 100644
index 000000000000..4ac8f145d6c1
--- /dev/null
+++ b/devel/directfb/files/patch-tools-mkdgifft.cpp
@@ -0,0 +1,11 @@
+--- tools/mkdgifft.cpp.orig 2011-05-05 20:00:29.000000000 +0200
++++ tools/mkdgifft.cpp 2012-05-01 08:58:04.000000000 +0200
+@@ -595,7 +595,7 @@
+ if (!png_ptr)
+ goto cleanup;
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ if (desc->preallocated[0].data) {
+ free (desc->preallocated[0].data);
+ desc->preallocated[0].data = NULL;