aboutsummaryrefslogtreecommitdiff
path: root/devel/distcc
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-26 17:20:21 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-26 17:20:21 +0000
commit82367010fcc5d41de9b94094f50ecb9c7b0995cd (patch)
treec9b26188c1174bc1141e1375ff3b1003728c804e /devel/distcc
parente33ef66d65fb351dea60a3b641d0f344a5fe8c03 (diff)
downloadports-82367010fcc5d41de9b94094f50ecb9c7b0995cd.tar.gz
ports-82367010fcc5d41de9b94094f50ecb9c7b0995cd.zip
Add new port distcc: Distribute compilation of C(++) code acrosss machines
on a network PR: ports/39879 Submitted by: Frerich Raabe <frerich.raabe@gmx.de>
Notes
Notes: svn path=/head/; revision=62026
Diffstat (limited to 'devel/distcc')
-rw-r--r--devel/distcc/Makefile30
-rw-r--r--devel/distcc/distinfo1
-rw-r--r--devel/distcc/files/patch-src::dparent.c11
-rw-r--r--devel/distcc/files/patch-src::serve.c11
-rw-r--r--devel/distcc/pkg-comment1
-rw-r--r--devel/distcc/pkg-descr19
-rw-r--r--devel/distcc/pkg-message9
-rw-r--r--devel/distcc/pkg-plist2
8 files changed, 84 insertions, 0 deletions
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
new file mode 100644
index 000000000000..5da4b0d506ae
--- /dev/null
+++ b/devel/distcc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: distcc
+# Date created: 25 June 2002
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= distcc
+PORTVERSION= 0.4
+CATEGORIES= devel
+MASTER_SITES= http://ftp.samba.org/ftp/distcc/
+
+MAINTAINER= frerich.raabe@gmx.de
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${CPPFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS}"
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/distcc ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/distccd ${PREFIX}/sbin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/distcc/distinfo b/devel/distcc/distinfo
new file mode 100644
index 000000000000..df6c0db9db19
--- /dev/null
+++ b/devel/distcc/distinfo
@@ -0,0 +1 @@
+MD5 (distcc-0.4.tar.gz) = 3b21a4bde9810eb8040b05e6924430f8
diff --git a/devel/distcc/files/patch-src::dparent.c b/devel/distcc/files/patch-src::dparent.c
new file mode 100644
index 000000000000..3d748e228ca6
--- /dev/null
+++ b/devel/distcc/files/patch-src::dparent.c
@@ -0,0 +1,11 @@
+--- src/dparent.c.orig Tue Jun 25 15:58:35 2002
++++ src/dparent.c Tue Jun 25 15:58:48 2002
+@@ -126,7 +126,7 @@
+
+ memset(&act_exited, 0, sizeof act_exited);
+ act_exited.sa_handler = dcc_child_exited;
+- act_exited.sa_flags = SA_NOCLDSTOP;
++ act_exited.sa_flags = SA_NOCLDSTOP|SA_RESTART;
+
+ if (sigaction(SIGTERM, &act_catch, NULL)
+ || sigaction(SIGHUP, &act_catch, NULL)
diff --git a/devel/distcc/files/patch-src::serve.c b/devel/distcc/files/patch-src::serve.c
new file mode 100644
index 000000000000..316585d25449
--- /dev/null
+++ b/devel/distcc/files/patch-src::serve.c
@@ -0,0 +1,11 @@
+--- src/serve.c.orig Tue Jun 25 15:42:07 2002
++++ src/serve.c Tue Jun 25 15:42:30 2002
+@@ -189,7 +189,7 @@
+ *
+ * XXX: Perhaps this should be optional so that we can compare
+ * performance each way? */
+- if (mknod(temp_i, S_IFIFO|S_IRUSR|S_IWUSR, 0) == -1) {
++ if (mkfifo(temp_i, S_IFIFO|S_IRUSR|S_IWUSR) == -1) {
+ rs_log_error("failed to make fifo %s: %s", temp_i,
+ strerror(errno));
+ goto failed;
diff --git a/devel/distcc/pkg-comment b/devel/distcc/pkg-comment
new file mode 100644
index 000000000000..3b7bf36c87d2
--- /dev/null
+++ b/devel/distcc/pkg-comment
@@ -0,0 +1 @@
+Distribute compilation of C(++) code acrosss machines on a network
diff --git a/devel/distcc/pkg-descr b/devel/distcc/pkg-descr
new file mode 100644
index 000000000000..a2f87e3fc789
--- /dev/null
+++ b/devel/distcc/pkg-descr
@@ -0,0 +1,19 @@
+distcc is a program to distribute compilation of C code across
+several machines on a network. distcc should always generate the
+same results as a local compile, is simple to install and use, and
+is often significantly faster than a local compile.
+
+Unlike other distributed build systems, distcc does not require all
+machines to share a filesystem, have synchronized clocks, or to
+have the same libraries or header files installed. Machines can be
+running different operating systems, as long as they have compatible
+binary formats or cross-compilers.
+
+distcc sends the complete preprocessed source code across the network
+for each job, so all it requires of the volunteer machines is that
+they be running the distccd daemon, and that they have an appropriate
+compiler installed.
+
+WWW: http://distcc.samba.org/
+
+- Frerich Raabe frerich.raabe@gmx.de
diff --git a/devel/distcc/pkg-message b/devel/distcc/pkg-message
new file mode 100644
index 000000000000..3761dfd29d43
--- /dev/null
+++ b/devel/distcc/pkg-message
@@ -0,0 +1,9 @@
+WARNING: distcc[d] performs NO AUTHENTICATION at all and should
+ONLY be used in trusted networks!
+
+The daemon runs on port 4200 by default. You can change that
+value by calling distccd with the -p parameter, e.g.
+`distccd -p 4711'.
+
+Note that remote daemons currently won't work if they cannot
+resolve the reverse DNS of the master machine
diff --git a/devel/distcc/pkg-plist b/devel/distcc/pkg-plist
new file mode 100644
index 000000000000..eaa77a87291d
--- /dev/null
+++ b/devel/distcc/pkg-plist
@@ -0,0 +1,2 @@
+bin/distcc
+sbin/distccd