aboutsummaryrefslogtreecommitdiff
path: root/devel/dmucs
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2008-03-31 20:44:30 +0000
committerMax Khon <fjoe@FreeBSD.org>2008-03-31 20:44:30 +0000
commit5a7ec0c5a1dd1eeb361ff88ee213024745e28dbf (patch)
treedd2594d445e7ffa4a17e9c40c140efbec4922715 /devel/dmucs
parent7cea41e00e0e37f004efede82f59930739a0d8ef (diff)
downloadports-5a7ec0c5a1dd1eeb361ff88ee213024745e28dbf.tar.gz
ports-5a7ec0c5a1dd1eeb361ff88ee213024745e28dbf.zip
New port: dmucs
DMUCS is a system that allows a group of users to share a compilation farm. Each compilation request from each user will be sent to the fastest available machine, every time. The system has these fine qualities: * Supports multiple users compiling simultaneously, and scales well to handle the new loads. * Supports multiple operating systems in the compilation farm. * Uses all processors of a multi-processor compilation host. * Makes best use of compilation hosts with widely differing CPU speeds. * Guarantees that a compilation host will not be overloaded by compilations. * Takes into account the load on a host caused by non-compilation tasks. * Supports the dynamic addition and removal of hosts to the compilation farm. * Works with distcc, which need not be altered in any way. WWW: http://dmucs.sourceforge.net/
Notes
Notes: svn path=/head/; revision=210296
Diffstat (limited to 'devel/dmucs')
-rw-r--r--devel/dmucs/Makefile22
-rw-r--r--devel/dmucs/distinfo3
-rw-r--r--devel/dmucs/files/patch-COSMIC-error.c10
-rw-r--r--devel/dmucs/pkg-descr14
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/dmucs/Makefile b/devel/dmucs/Makefile
new file mode 100644
index 000000000000..6d8d17ddb5e2
--- /dev/null
+++ b/devel/dmucs/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: dmucs
+# Date created: 26 Nov 2007
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dmucs
+PORTVERSION= 0.6.1
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= Distributed Multi-User Compilation System (for use with distcc)
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PLIST_FILES= bin/dmucs bin/gethost bin/loadavg bin/monitor bin/remhost
+
+.include <bsd.port.mk>
diff --git a/devel/dmucs/distinfo b/devel/dmucs/distinfo
new file mode 100644
index 000000000000..627ba4719449
--- /dev/null
+++ b/devel/dmucs/distinfo
@@ -0,0 +1,3 @@
+MD5 (dmucs-0.6.1.tar.bz2) = 5d6d9e13b7e778c8e2187c4bb386fd4f
+SHA256 (dmucs-0.6.1.tar.bz2) = cbcb0f866880018de36b1bbf37dc13888a3c897feac47398f38b5dafe245326e
+SIZE (dmucs-0.6.1.tar.bz2) = 399161
diff --git a/devel/dmucs/files/patch-COSMIC-error.c b/devel/dmucs/files/patch-COSMIC-error.c
new file mode 100644
index 000000000000..bf326d547ec3
--- /dev/null
+++ b/devel/dmucs/files/patch-COSMIC-error.c
@@ -0,0 +1,10 @@
+--- COSMIC/error.c.orig 2007-11-26 02:32:21.000000000 +0600
++++ COSMIC/error.c 2007-11-26 02:32:39.000000000 +0600
+@@ -1,6 +1,7 @@
+ /* error.c: this file contains an error function
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include "sockets.h"
+
diff --git a/devel/dmucs/pkg-descr b/devel/dmucs/pkg-descr
new file mode 100644
index 000000000000..8bcb87cae24c
--- /dev/null
+++ b/devel/dmucs/pkg-descr
@@ -0,0 +1,14 @@
+DMUCS is a system that allows a group of users to share a compilation farm.
+Each compilation request from each user will be sent to the fastest available
+machine, every time. The system has these fine qualities:
+* Supports multiple users compiling simultaneously, and scales well to handle
+the new loads.
+* Supports multiple operating systems in the compilation farm.
+* Uses all processors of a multi-processor compilation host.
+* Makes best use of compilation hosts with widely differing CPU speeds.
+* Guarantees that a compilation host will not be overloaded by compilations.
+* Takes into account the load on a host caused by non-compilation tasks.
+* Supports the dynamic addition and removal of hosts to the compilation farm.
+* Works with distcc, which need not be altered in any way.
+
+WWW: http://dmucs.sourceforge.net/