aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-main
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /devel/ecore-main
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
- Update enlightenment-devel and EFL libraries to the latest snapshot
- Deprecate old unsupported apps and modules (entice, devian, eveil, engage) - Split evas and ecore to separate modules to handle dependencies properly - Disable PAM in enlightenment-devel as it don't work anyway (requires root privilegies) - Add DBUS support. Thanks to: az
Notes
Notes: svn path=/head/; revision=208836
Diffstat (limited to 'devel/ecore-main')
-rw-r--r--devel/ecore-main/Makefile40
-rw-r--r--devel/ecore-main/distinfo3
-rw-r--r--devel/ecore-main/pkg-descr5
-rw-r--r--devel/ecore-main/pkg-plist8
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
new file mode 100644
index 000000000000..97cfb70b112a
--- /dev/null
+++ b/devel/ecore-main/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ecore-main
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= main
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (main library)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+.include <bsd.port.mk>
diff --git a/devel/ecore-main/distinfo b/devel/ecore-main/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-main/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-main/pkg-descr b/devel/ecore-main/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-main/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-main/pkg-plist b/devel/ecore-main/pkg-plist
new file mode 100644
index 000000000000..69033dfea741
--- /dev/null
+++ b/devel/ecore-main/pkg-plist
@@ -0,0 +1,8 @@
+include/Ecore.h
+include/Ecore_Data.h
+include/Ecore_Str.h
+lib/libecore.a
+lib/libecore.la
+lib/libecore.so
+lib/libecore.so.9
+libdata/pkgconfig/ecore.pc