aboutsummaryrefslogtreecommitdiff
path: root/devel/elfkickers
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-17 08:40:48 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-17 08:40:48 +0000
commit1ff230ebc92a3d7d33ad524630e58c434d6c739a (patch)
treebf40521a35cae8832bc21da9424b0c35cdf8c311 /devel/elfkickers
parent59fb0b4bc2a9746ff64d8af048ef00063d4bba0c (diff)
downloadports-1ff230ebc92a3d7d33ad524630e58c434d6c739a.tar.gz
ports-1ff230ebc92a3d7d33ad524630e58c434d6c739a.zip
This distribution is a collection of programs that are generally
unrelated, except in that they all deal with the ELF file format. The main purpose of these programs is to be illustrative and educational -- to help fellow programmers understand the ELF file format and something of how it works under the Linux platform. WWW: http://www.muppetlabs.com/~breadbox/software/elfkickers.html PR: ports/152299 Submitted by: Sofian Brabez <sbrabez at gmail.com>
Notes
Notes: svn path=/head/; revision=264671
Diffstat (limited to 'devel/elfkickers')
-rw-r--r--devel/elfkickers/Makefile52
-rw-r--r--devel/elfkickers/distinfo2
-rw-r--r--devel/elfkickers/pkg-descr8
3 files changed, 62 insertions, 0 deletions
diff --git a/devel/elfkickers/Makefile b/devel/elfkickers/Makefile
new file mode 100644
index 000000000000..17ad488c6a54
--- /dev/null
+++ b/devel/elfkickers/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: elfkickers
+# Date created: 2010-11-16
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elfkickers
+DISTVERSION= 2.0a
+CATEGORIES= devel sysutils
+MASTER_SITES= http://www.muppetlabs.com/~breadbox/pub/software/
+DISTNAME= ELFkickers-${DISTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Collection of programs to manipulate ELF files
+
+USE_GMAKE= yes
+
+PLIST_FILES= bin/ebfc \
+ bin/elfls \
+ bin/elftoc \
+ bin/rebind \
+ bin/sstrip
+
+PORTDOCS= COPYING Changelog README
+
+MAN1= ebfc.1 elfls.1
+
+WRKSRC= ${WRKDIR}/ELFkickers
+
+post-patch:
+ @${GREP} -lR "\/elf.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's,linux/,,g' -e 's,asm/,,g'
+
+do-build:
+.for f in ${PLIST_FILES:S,bin/,,}
+ @(cd ${WRKSRC}/$f; ${GMAKE})
+.endfor
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+.for f in ${PLIST_FILES:S,bin/,,}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}/${f} ${PREFIX}/bin
+.endfor
+.for f in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${f:S,.1,,}/${f} ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/elfkickers/distinfo b/devel/elfkickers/distinfo
new file mode 100644
index 000000000000..3b44aca1b35c
--- /dev/null
+++ b/devel/elfkickers/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ELFkickers-2.0a.tar.gz) = c196988f55fc6633d9f9f6d9ddc2ae9b4dfa1f300edf4cbbad865c06a8656df7
+SIZE (ELFkickers-2.0a.tar.gz) = 119659
diff --git a/devel/elfkickers/pkg-descr b/devel/elfkickers/pkg-descr
new file mode 100644
index 000000000000..319e3f08c22f
--- /dev/null
+++ b/devel/elfkickers/pkg-descr
@@ -0,0 +1,8 @@
+This distribution is a collection of programs that are generally
+unrelated, except in that they all deal with the ELF file format.
+
+The main purpose of these programs is to be illustrative and
+educational -- to help fellow programmers understand the ELF file
+format and something of how it works under the Linux platform.
+
+WWW: http://www.muppetlabs.com/~breadbox/software/elfkickers.html