aboutsummaryrefslogtreecommitdiff
path: root/devel/elfkickers
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2011-06-01 14:00:18 +0000
committerSofian Brabez <sbz@FreeBSD.org>2011-06-01 14:00:18 +0000
commit97959848d3a5c8a3d4951dfba85fd483b9c069d5 (patch)
treef60cb2e3827489fa51d6606f862df30db89d0e7e /devel/elfkickers
parentac5a45dfda65990a3ff089c892bf1822fefcbded (diff)
downloadports-97959848d3a5c8a3d4951dfba85fd483b9c069d5.tar.gz
ports-97959848d3a5c8a3d4951dfba85fd483b9c069d5.zip
- Update to 3.0
- Add LICENSE Approved by: miwi@ (mentor)
Notes
Notes: svn path=/head/; revision=274927
Diffstat (limited to 'devel/elfkickers')
-rw-r--r--devel/elfkickers/Makefile13
-rw-r--r--devel/elfkickers/distinfo4
-rw-r--r--devel/elfkickers/files/patch-elfrw__elfrw.h20
-rw-r--r--devel/elfkickers/files/patch-elftoc__outbase.h13
-rw-r--r--devel/elfkickers/files/patch-elftoc__pieces.c13
-rw-r--r--devel/elfkickers/files/patch-elftoc__readelf.h15
6 files changed, 71 insertions, 7 deletions
diff --git a/devel/elfkickers/Makefile b/devel/elfkickers/Makefile
index 74881c0f488b..ec591acce66b 100644
--- a/devel/elfkickers/Makefile
+++ b/devel/elfkickers/Makefile
@@ -6,27 +6,30 @@
#
PORTNAME= elfkickers
-DISTVERSION= 2.0a
+PORTVERSION= 3.0
CATEGORIES= devel sysutils
MASTER_SITES= http://www.muppetlabs.com/~breadbox/pub/software/
-DISTNAME= ELFkickers-${DISTVERSION}
+DISTNAME= ELFkickers-${PORTVERSION}
MAINTAINER= sbz@FreeBSD.org
COMMENT= Collection of programs to manipulate ELF files
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GMAKE= yes
PLIST_FILES= bin/ebfc \
bin/elfls \
bin/elftoc \
+ bin/infect \
+ bin/objres \
bin/rebind \
bin/sstrip
PORTDOCS= COPYING Changelog README
-MAN1= ebfc.1 elfls.1
-
-WRKSRC= ${WRKDIR}/ELFkickers
+MAN1= ebfc.1 elfls.1 elftoc.1 infect.1 objres.1 rebind.1 sstrip.1
post-patch:
@${GREP} -lR "\/elf.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/devel/elfkickers/distinfo b/devel/elfkickers/distinfo
index 3b44aca1b35c..97fc3f197f7c 100644
--- a/devel/elfkickers/distinfo
+++ b/devel/elfkickers/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ELFkickers-2.0a.tar.gz) = c196988f55fc6633d9f9f6d9ddc2ae9b4dfa1f300edf4cbbad865c06a8656df7
-SIZE (ELFkickers-2.0a.tar.gz) = 119659
+SHA256 (ELFkickers-3.0.tar.gz) = 8597dc38ecb1a352f86c5075608547f2c4dcd50f4ba89de70c5494cf6611c6aa
+SIZE (ELFkickers-3.0.tar.gz) = 99527
diff --git a/devel/elfkickers/files/patch-elfrw__elfrw.h b/devel/elfkickers/files/patch-elfrw__elfrw.h
new file mode 100644
index 000000000000..8c847b400178
--- /dev/null
+++ b/devel/elfkickers/files/patch-elfrw__elfrw.h
@@ -0,0 +1,20 @@
+--- ./elfrw/elfrw.h.orig 2011-05-31 01:47:08.000000000 +0200
++++ ./elfrw/elfrw.h 2011-06-01 17:13:31.000000000 +0200
+@@ -10,6 +10,17 @@
+ #include <stdio.h>
+ #include <elf.h>
+
++#ifdef __FreeBSD__
++typedef uint16_t Elf64_Section;
++
++#define PT_GNU_STACK 0x6474e551
++#define PT_GNU_RELRO 0x6474e552
++
++#define ELFCLASSNUM 3
++#define ELFDATANUM 3
++#define EV_NUM 2
++#endif
++
+ /*
+ * The initialization functions. Call one of these to set the flavor
+ * of ELF structures to translate to and from. The library can be
diff --git a/devel/elfkickers/files/patch-elftoc__outbase.h b/devel/elfkickers/files/patch-elftoc__outbase.h
new file mode 100644
index 000000000000..8afe3130a9a8
--- /dev/null
+++ b/devel/elfkickers/files/patch-elftoc__outbase.h
@@ -0,0 +1,13 @@
+--- ./elftoc/outbase.h.orig 2011-06-01 17:16:31.000000000 +0200
++++ ./elftoc/outbase.h 2011-06-01 17:14:57.000000000 +0200
+@@ -7,6 +7,10 @@
+ #ifndef _outbase_h_
+ #define _outbase_h_
+
++#ifdef __FreeBSD__
++#define NT_AUXV 6
++#endif
++
+ /* Set the current output file. Call this before calling any output
+ * functions. (The FILE* argument is given as a void* so as to not
+ * include stdio.h here.)
diff --git a/devel/elfkickers/files/patch-elftoc__pieces.c b/devel/elfkickers/files/patch-elftoc__pieces.c
new file mode 100644
index 000000000000..4c9e8542b096
--- /dev/null
+++ b/devel/elfkickers/files/patch-elftoc__pieces.c
@@ -0,0 +1,13 @@
+--- ./elftoc/pieces.c.orig 2011-05-26 03:25:14.000000000 +0200
++++ ./elftoc/pieces.c 2011-06-01 17:13:31.000000000 +0200
+@@ -16,6 +16,10 @@
+ #include "out.h"
+ #include "pieces.h"
+
++#ifdef __FreeBSD__
++typedef uint64_t Elf32_Xword;
++#endif
++
+ /* Flags used to insert warnings in the generated source code.
+ */
+ #define PW_MISALIGNED 0x0001 /* piece misaligned for original type */
diff --git a/devel/elfkickers/files/patch-elftoc__readelf.h b/devel/elfkickers/files/patch-elftoc__readelf.h
new file mode 100644
index 000000000000..75c96d43d70e
--- /dev/null
+++ b/devel/elfkickers/files/patch-elftoc__readelf.h
@@ -0,0 +1,15 @@
+--- ./elftoc/readelf.h.orig 2011-05-22 20:46:29.000000000 +0200
++++ ./elftoc/readelf.h 2011-06-01 17:13:31.000000000 +0200
+@@ -7,6 +7,12 @@
+ #ifndef _readelf_h_
+ #define _readelf_h_
+
++#ifdef __FreeBSD__
++#define ELFCLASSNUM 3
++#define ELFDATANUM 3
++#define EV_NUM 2
++#endif
++
+ /* Read all of the basic headers from the file image (namely the ELF
+ * header, the program segment header table, and the section header
+ * table). False is returned if the file could not be parsed as an ELF