aboutsummaryrefslogtreecommitdiff
path: root/devel/entity
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-28 14:03:34 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-28 14:03:34 +0000
commit4f1294058e7acf2251dd6cfb468745bd7038fa7b (patch)
tree958d3a896897396c76d565b1dd4882426186d8ef /devel/entity
parenta82e50a994f167dc21ab5d3949e6fff858d51939 (diff)
downloadports-4f1294058e7acf2251dd6cfb468745bd7038fa7b.tar.gz
ports-4f1294058e7acf2251dd6cfb468745bd7038fa7b.zip
Add new port of entity 0.6.6, an XML-based tool for RAD.
PR: 20061 Submitted by: Jesse McConnell <jesse@cylant.com>
Notes
Notes: svn path=/head/; revision=34355
Diffstat (limited to 'devel/entity')
-rw-r--r--devel/entity/Makefile32
-rw-r--r--devel/entity/distinfo1
-rw-r--r--devel/entity/files/patch-entity_Makefile_in11
-rw-r--r--devel/entity/files/patch-gregex_src_Makefile_in13
-rw-r--r--devel/entity/pkg-comment1
-rw-r--r--devel/entity/pkg-descr24
-rw-r--r--devel/entity/pkg-plist46
7 files changed, 128 insertions, 0 deletions
diff --git a/devel/entity/Makefile b/devel/entity/Makefile
new file mode 100644
index 000000000000..ce4536c65c6a
--- /dev/null
+++ b/devel/entity/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: entity
+# Date created: 15 June 2000
+# Whom: Jesse McConnell <jesse@cylant.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= entity
+PORTVERSION= 0.6.6
+CATEGORIES= devel
+MASTER_SITES= http://entity.evilplan.org/Download/files/all-versions/
+
+MAINTAINER= jesse@cylant.com
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+PREFIX= ${LOCALBASE}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-tcl=no \
+ --enable-python=no
+USE_GMAKE= yes
+USE_GTK= yes
+INSTALLS_SHLIB= yes
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib/entity/clib ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/share/entity
+ cd ${WRKSRC}/apps && \
+ pax -r -w `ls | ${GREP} -v Makefile` ${PREFIX}/share/entity
+
+.include <bsd.port.mk>
diff --git a/devel/entity/distinfo b/devel/entity/distinfo
new file mode 100644
index 000000000000..18b1518ab61a
--- /dev/null
+++ b/devel/entity/distinfo
@@ -0,0 +1 @@
+MD5 (entity-0.6.6.tar.gz) = 391c4acc3681844ae987919b3459c37a
diff --git a/devel/entity/files/patch-entity_Makefile_in b/devel/entity/files/patch-entity_Makefile_in
new file mode 100644
index 000000000000..bee04e2e2204
--- /dev/null
+++ b/devel/entity/files/patch-entity_Makefile_in
@@ -0,0 +1,11 @@
+--- entity/Makefile.in.orig Thu Jun 22 22:15:42 2000
++++ entity/Makefile.in Sat Oct 28 06:26:21 2000
+@@ -109,7 +109,7 @@
+ entity_LDADD = $(top_builddir)/expat-1.1/libexpat.a $(top_builddir)/g-extentions/libgextend.a $(top_builddir)/renderers/entitylang/libentitylang.a $(top_builddir)/renderers/generic/librendgeneric.a $(top_builddir)/gregex/src/.libs/libgregex.a @RENDERER_LDFLAGS@ $(PCRE_LIBS) $(GLIB_LIBS)
+
+
+-entity_LDFLAGS = -export-dynamic
++entity_LDFLAGS = -export-dynamic -lreadline
+
+ entity_SOURCES = baby-entity.c baby-entity.h ebuffer.c ebuffer.h econfig.c econfig.h edebug.c edebug.h elements.c elements.h enode.h entity.h enode-attribs.c enode-attribs.h enode-base.c enode-base.h enode-call.c enode-call.h enode-data.c enode-data.h enode-delete.c enode-delete.h enode-event.c enode-event.h enode-kv.c enode-kv.h enode-search.c enode-search.h enode-treewalk.c enode-treewalk.h enode-xml.c enode-xml.h entity.c entity.h entity-exec-class.c entity-exec-class.h erend.c erend.h eutils.c eutils.h mainloop.c mainloop.h modulegen.c modulegen.h renderers.c renderers.h xml-parser.c xml-parser.h
+
diff --git a/devel/entity/files/patch-gregex_src_Makefile_in b/devel/entity/files/patch-gregex_src_Makefile_in
new file mode 100644
index 000000000000..129919c038e8
--- /dev/null
+++ b/devel/entity/files/patch-gregex_src_Makefile_in
@@ -0,0 +1,13 @@
+--- gregex/src/Makefile.in.orig Thu Jun 22 22:15:40 2000
++++ gregex/src/Makefile.in Sat Oct 28 06:24:45 2000
+@@ -159,8 +159,8 @@
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+- echo "$(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p"; \
+- $(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p; \
++ echo "$(LIBTOOL) --mode=install $(INSTALL_DATA) $$p $(DESTDIR)$(libdir)/$$p"; \
++ $(LIBTOOL) --mode=install $(INSTALL_DATA) $$p $(DESTDIR)$(libdir)/$$p; \
+ else :; fi; \
+ done
+
diff --git a/devel/entity/pkg-comment b/devel/entity/pkg-comment
new file mode 100644
index 000000000000..0cf8fc4a9f8a
--- /dev/null
+++ b/devel/entity/pkg-comment
@@ -0,0 +1 @@
+XML-based RAD
diff --git a/devel/entity/pkg-descr b/devel/entity/pkg-descr
new file mode 100644
index 000000000000..fc7908dd6494
--- /dev/null
+++ b/devel/entity/pkg-descr
@@ -0,0 +1,24 @@
+Entity is an application framework built around XML. The core of Entity is
+actually an engine that allows you to create objects out of XML by supplying
+methods for creation, attribute-setting, and destruction of XML nodes in a
+tree.
+
+This design allows you to create tags in XML which can be used to represent
+pretty much any object. We have used this to create a set of tags for the GTK+
+toolkit, allowing you to create graphical applications using XML, and an
+embedded scripting language.
+
+Any scripting language supported by Entity can be used to change the XML tree
+during runtime, and the changes are immediately reflected in the rendered
+representation of the XML. Using XML for the user interface, data storage, and
+code of an application allows you to easily implement configuration, saving,
+and undo.
+
+The interface for creating UIs and programming in Entity is quite intuitive and
+allows for rapid application development. Entity currently supports Perl,
+Python, and C for doing runtime XML creation and modification.
+
+WWW: http://entity.evilplan.org
+
+- filbert
+jesse@cylant.com
diff --git a/devel/entity/pkg-plist b/devel/entity/pkg-plist
new file mode 100644
index 000000000000..8fd7568ae0e7
--- /dev/null
+++ b/devel/entity/pkg-plist
@@ -0,0 +1,46 @@
+bin/gregex-config
+bin/entity
+include/gregex.h
+lib/entity/clib/librendcoregtk.so
+lib/entity/clib/librendcoregtk.la
+lib/entity/clib/librendextragtk.so
+lib/entity/clib/librendextragtk.la
+@exec /sbin/ldconfig -m %D/lib/entity/clib
+@unexec /sbin/ldconfig -R
+lib/entity/Entity.pl
+lib/entity/E-init.pl
+lib/entity/ENode.pl
+lib/entity/config/rendnet.conf
+lib/entity/config/rendcoregtk.conf
+lib/entity/config/rendextragtk.conf
+lib/entity/elib/Net/http.e
+lib/entity/elib/Net/patterns
+lib/entity/elib/Net/poptest.e
+lib/entity/elib/Net/smtp.e
+lib/entity/elib/Net/socketaccept.e
+lib/entity/elib/Net/socketconn.e
+lib/entity/elib/Net/sockettest.e
+lib/entity/elib/Net/url-pop-code.e
+lib/entity/elib/Net/url-renderer.e
+lib/entity/elib/Net/url-smtp-code.e
+lib/entity/elib/Net/url-socket-code.e
+lib/entity/elib/Net/urltest.e
+lib/entity/elib/Net/pop-control-app
+lib/libgregex.so.0
+lib/libgregex.so
+lib/libgregex.la
+lib/libgregex.a
+share/entity/bugme.e
+share/entity/bugme.todo
+share/entity/freaky-coo.e
+share/entity/stemwinder.e
+share/entity/stemwinder.pl
+share/entity/tagrefgen.e
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R
+@dirrm share/entity
+@dirrm lib/entity/clib
+@dirrm lib/entity/config
+@dirrm lib/entity/elib/Net
+@dirrm lib/entity/elib
+@dirrm lib/entity