aboutsummaryrefslogtreecommitdiff
path: root/devel/eric4
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2011-01-28 06:56:25 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2011-01-28 06:56:25 +0000
commit451ce47be6209d139253affe104545de8435729d (patch)
tree17cf917fbc5ba49e5319ae044a26d07954a9b8f4 /devel/eric4
parentc480cd7ebfe89ad952bdbd2357a3a7e2fabab2f1 (diff)
downloadports-451ce47be6209d139253affe104545de8435729d.tar.gz
ports-451ce47be6209d139253affe104545de8435729d.zip
. create a desktop file;
. symlink icon to a (FreeBSD-)standard place; . update desktop and mime database for ports and packages; . bump PORTREVISION. Feature safe: yes
Notes
Notes: svn path=/head/; revision=268316
Diffstat (limited to 'devel/eric4')
-rw-r--r--devel/eric4/Makefile9
-rw-r--r--devel/eric4/files/eric4.desktop.in10
-rw-r--r--devel/eric4/pkg-plist7
3 files changed, 26 insertions, 0 deletions
diff --git a/devel/eric4/Makefile b/devel/eric4/Makefile
index eef9a63a65ea..af4af60f88b2 100644
--- a/devel/eric4/Makefile
+++ b/devel/eric4/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION?= 1
CATEGORIES= devel python
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -20,6 +21,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
INSTALL_CMD= install.py -c -f eric4config.freebsd
PLIST_FILES=
+SUB_FILES= eric4.desktop
do-configure:
${SED} -e 's,PYTHON_SITELIBDIR,${PYTHON_SITELIBDIR},' \
@@ -29,4 +31,11 @@ do-configure:
-e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
< ${FILESDIR}/config > ${WRKSRC}/eric4config.freebsd
+post-install:
+ ${INSTALL} -d ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/eric4.desktop ${PREFIX}/share/applications/
+ ${LN} ${PYTHON_SITELIBDIR}/eric4/icons/default/eric.png ${PREFIX}/share/pixmaps/
+ -update-desktop-database
+ -update-mime-database ${PREFIX}/share/mime
+
.include "${.CURDIR}/../../devel/eric4/Makefile.inc"
diff --git a/devel/eric4/files/eric4.desktop.in b/devel/eric4/files/eric4.desktop.in
new file mode 100644
index 000000000000..533879551cff
--- /dev/null
+++ b/devel/eric4/files/eric4.desktop.in
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Eric IDE
+GenericName=Python and Ruby IDE
+Comment=Full featured Python and Ruby editor and IDE based on Qt4
+Type=Application
+Exec=eric4
+Icon=eric
+MimeType=application/x-python;application/x-eric;
+Categories=Development;TextEditor;Qt;Application;
+Terminal=false
diff --git a/devel/eric4/pkg-plist b/devel/eric4/pkg-plist
index cee47e1c3558..853bed4a3275 100644
--- a/devel/eric4/pkg-plist
+++ b/devel/eric4/pkg-plist
@@ -2928,6 +2928,8 @@ bin/eric4-trpreviewer
bin/eric4-uipreviewer
bin/eric4-unittest
bin/eric4-webbrowser
+share/applications/eric4.desktop
+share/pixmaps/eric.png
share/qt4/qsci/api/python/eric4.api
share/qt4/qsci/api/python/zope-2.10.7.api
share/qt4/qsci/api/python/zope-2.11.2.api
@@ -2935,6 +2937,7 @@ share/qt4/qsci/api/python/zope-3.3.1.api
share/qt4/qsci/api/ruby/Ruby-1.8.7.api
share/qt4/qsci/api/ruby/eric4.api
@dirrmtry share/qt4/qsci/api/ruby
+@dirrmtry share/applications
@dirrmtry %%PYTHON_SITELIBDIR%%/eric4/i18n
@dirrm %%PYTHON_SITELIBDIR%%/eric4plugins
@dirrm %%PYTHON_SITELIBDIR%%/eric4/pixmaps
@@ -3034,3 +3037,7 @@ share/qt4/qsci/api/ruby/eric4.api
@dirrm %%DOCSDIR%%/Source
@dirrm %%DOCSDIR%%/Help
@dirrm %%DOCSDIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime