aboutsummaryrefslogtreecommitdiff
path: root/devel/esdl
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2003-01-02 19:57:54 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2003-01-02 19:57:54 +0000
commit9b1e41be4d4c6b2f9a3221ac3c6519eeb9653e90 (patch)
tree6c385f96267f21a5a06207e43d944fbd66bb2655 /devel/esdl
parente4305cc79f56d41ab9dcf28862f5b31b1c17e165 (diff)
downloadports-9b1e41be4d4c6b2f9a3221ac3c6519eeb9653e90.tar.gz
ports-9b1e41be4d4c6b2f9a3221ac3c6519eeb9653e90.zip
Add esdl, a library for accessing SDL and OpenGL through Erlang.
Notes
Notes: svn path=/head/; revision=72292
Diffstat (limited to 'devel/esdl')
-rw-r--r--devel/esdl/Makefile46
-rw-r--r--devel/esdl/distinfo1
-rw-r--r--devel/esdl/files/patch-c__src_Makefile27
-rw-r--r--devel/esdl/files/patch-c__src_esdl.h17
-rw-r--r--devel/esdl/files/patch-c__src_esdl__conv.h17
-rw-r--r--devel/esdl/files/patch-c__src_esdl__events.c17
-rw-r--r--devel/esdl/files/patch-c__src_esdl__main.c17
-rw-r--r--devel/esdl/files/patch-c__src_esdl__stream.c17
-rw-r--r--devel/esdl/files/patch-c__src_esdl__video.c17
-rw-r--r--devel/esdl/pkg-comment1
-rw-r--r--devel/esdl/pkg-descr3
-rw-r--r--devel/esdl/pkg-plist61
12 files changed, 241 insertions, 0 deletions
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
new file mode 100644
index 000000000000..afc2753e91ca
--- /dev/null
+++ b/devel/esdl/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: esdl
+# Date Created: 2 January 2003
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= esdl
+PORTVERSION= 0.91.1129
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_THEMES}
+MASTER_SITE_SUBDIR= esdl
+DISTNAME= esdl-${PORTVERSION}.src
+
+MAINTAINER= olgeni@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GMAKE= yes
+
+ESDL_PATH= ${PREFIX}/lib/erlang/lib/esdl-${PORTVERSION}
+
+do-build:
+ @cd ${WRKSRC}/c_src && ${GMAKE}
+ @cd ${WRKSRC}/test && ${GMAKE}
+
+do-install:
+ @${MKDIR} ${ESDL_PATH}
+ @${MKDIR} ${ESDL_PATH}/doc
+ @${MKDIR} ${ESDL_PATH}/ebin
+ @${MKDIR} ${ESDL_PATH}/include
+ @${MKDIR} ${ESDL_PATH}/priv
+ @${MKDIR} ${ESDL_PATH}/src
+ @${FIND} ${ESDL_PATH} -type d | ${XARGS} ${CHMOD} 755
+
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${ESDL_PATH}/doc
+ @${INSTALL_DATA} ${WRKSRC}/ebin/* ${ESDL_PATH}/ebin
+ @${INSTALL_DATA} ${WRKSRC}/include/* ${ESDL_PATH}/include
+ @${INSTALL_DATA} ${WRKSRC}/priv/sdl_driver.so ${ESDL_PATH}/priv
+ @${INSTALL_PROGRAM} ${WRKSRC}/priv/sdlwrapper ${ESDL_PATH}/priv
+ @${INSTALL_DATA} ${WRKSRC}/src/* ${ESDL_PATH}/src
+
+ @${CP} -r ${WRKSRC}/priv ${ESDL_PATH}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${ESDL_PATH}
+
+.include <bsd.port.mk>
diff --git a/devel/esdl/distinfo b/devel/esdl/distinfo
new file mode 100644
index 000000000000..1a08477a9a65
--- /dev/null
+++ b/devel/esdl/distinfo
@@ -0,0 +1 @@
+MD5 (esdl-0.91.1129.src.tar.gz) = 1418b02a6d770e361f517c9d1981eb56
diff --git a/devel/esdl/files/patch-c__src_Makefile b/devel/esdl/files/patch-c__src_Makefile
new file mode 100644
index 000000000000..b8bd6fef9b74
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_Makefile
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- c_src/Makefile.orig Mon Dec 9 23:11:08 2002
++++ c_src/Makefile Mon Dec 9 23:11:10 2002
+@@ -5,7 +5,7 @@
+ # $Id: Makefile,v 1.3 2002/09/07 06:02:36 bjorng Exp $
+ #
+
+-OGLDIR = /usr
++OGLDIR = /usr/X11R6
+
+ # Uncomment these if your opengl header is located in another directory than
+ # the usual $(OGLDIR)/include/GL/gl.h
+@@ -15,10 +15,10 @@
+ GL_LIBS = -L$(OGLDIR)/lib -lGL -lGLU
+ GL_INCS = -I$(OGLDIR)/include/$(GL_INCLUDE_DIR)
+
+-SDL_LIBS = $(shell sdl-config --libs)
++SDL_LIBS = $(shell sdl11-config --libs)
+ LIBS = $(GL_LIBS) $(SDL_LIBS) -lm
+
+-SDLINCS = $(shell sdl-config --cflags)
++SDLINCS = $(shell sdl11-config --cflags)
+
+ CFLAGS = -g -O2 -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
+ $(USE_GL_INCLUDE_DIR) -DSHM -DPTHREADS $(GL_INCS) $(SDLINCS)
diff --git a/devel/esdl/files/patch-c__src_esdl.h b/devel/esdl/files/patch-c__src_esdl.h
new file mode 100644
index 000000000000..fb03d23ad30e
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl.h
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl.h.orig Mon Dec 9 23:10:14 2002
++++ c_src/esdl.h Mon Dec 9 23:10:27 2002
+@@ -17,7 +17,11 @@
+ #include <windows.h> /* needed by Windows' gl.h etc */
+ #include <SDL.h>
+ #else
++#ifdef __FreeBSD__
++#include <SDL.h>
++#else
+ #include <SDL/SDL.h>
++#endif
+ #endif
+
+
diff --git a/devel/esdl/files/patch-c__src_esdl__conv.h b/devel/esdl/files/patch-c__src_esdl__conv.h
new file mode 100644
index 000000000000..6579994aacc2
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl__conv.h
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl_conv.h.orig Mon Dec 9 23:11:33 2002
++++ c_src/esdl_conv.h Mon Dec 9 23:12:05 2002
+@@ -23,7 +23,11 @@
+ #ifdef WIN32
+ #include <SDL_byteorder.h>
+ #else
++#ifdef __FreeBSD__
++#include <SDL_byteorder.h>
++#else
+ #include <SDL/SDL_byteorder.h>
++#endif
+ #endif
+
+ float readFloat(char *);
diff --git a/devel/esdl/files/patch-c__src_esdl__events.c b/devel/esdl/files/patch-c__src_esdl__events.c
new file mode 100644
index 000000000000..38e276fee6ff
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl__events.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl_events.c.orig Mon Dec 9 23:13:11 2002
++++ c_src/esdl_events.c Mon Dec 9 23:13:35 2002
+@@ -14,7 +14,11 @@
+ #ifdef WIN32
+ #include <SDL_events.h>
+ #else
++#ifdef __FreeBSD__
++#include <SDL_events.h>
++#else
+ #include <SDL/SDL_events.h>
++#endif
+ #endif
+
+ /* Foward decls */
diff --git a/devel/esdl/files/patch-c__src_esdl__main.c b/devel/esdl/files/patch-c__src_esdl__main.c
new file mode 100644
index 000000000000..81d844c64e63
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl__main.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl_main.c.orig Mon Dec 9 23:13:48 2002
++++ c_src/esdl_main.c Mon Dec 9 23:14:21 2002
+@@ -30,7 +30,11 @@
+ #else
+ #include <unistd.h>
+ #include <errno.h>
++#ifdef __FreeBSD__
++#include <SDL_mutex.h>
++#else
+ #include <SDL/SDL_mutex.h>
++#endif
+ #endif
+
+ #include "esdl.h"
diff --git a/devel/esdl/files/patch-c__src_esdl__stream.c b/devel/esdl/files/patch-c__src_esdl__stream.c
new file mode 100644
index 000000000000..c9aa8ad4d62b
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl__stream.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl_stream.c.orig Mon Dec 9 23:14:32 2002
++++ c_src/esdl_stream.c Mon Dec 9 23:15:11 2002
+@@ -22,7 +22,11 @@
+ #else
+ #include <unistd.h>
+ #include <errno.h>
++#ifdef __FreeBSD__
++#include <SDL_mutex.h>
++#else
+ #include <SDL/SDL_mutex.h>
++#endif
+ #endif
+
+
diff --git a/devel/esdl/files/patch-c__src_esdl__video.c b/devel/esdl/files/patch-c__src_esdl__video.c
new file mode 100644
index 000000000000..89a4e03f25f3
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_esdl__video.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- c_src/esdl_video.c.orig Mon Dec 9 23:12:18 2002
++++ c_src/esdl_video.c Mon Dec 9 23:13:01 2002
+@@ -18,7 +18,11 @@
+ #ifdef WIN32
+ #include <SDL_syswm.h>
+ #else
++#ifdef __FreeBSD__
++#include <SDL_syswm.h>
++#else
+ #include <SDL/SDL_syswm.h>
++#endif
+ #endif
+
+ int es_setVideoMode(sdl_data *sd, int len, char * buff)
diff --git a/devel/esdl/pkg-comment b/devel/esdl/pkg-comment
new file mode 100644
index 000000000000..7a58cdaa2212
--- /dev/null
+++ b/devel/esdl/pkg-comment
@@ -0,0 +1 @@
+A library for accessing SDL and OpenGL through Erlang
diff --git a/devel/esdl/pkg-descr b/devel/esdl/pkg-descr
new file mode 100644
index 000000000000..0f1731e35089
--- /dev/null
+++ b/devel/esdl/pkg-descr
@@ -0,0 +1,3 @@
+Esdl is library for accessing SDL and OpenGL through Erlang.
+
+WWW: http://esdl.sourceforge.net
diff --git a/devel/esdl/pkg-plist b/devel/esdl/pkg-plist
new file mode 100644
index 000000000000..5752c047ac1a
--- /dev/null
+++ b/devel/esdl/pkg-plist
@@ -0,0 +1,61 @@
+lib/erlang/lib/esdl-0.91.1129/doc/Makefile
+lib/erlang/lib/esdl-0.91.1129/doc/gl.html
+lib/erlang/lib/esdl-0.91.1129/doc/glu.html
+lib/erlang/lib/esdl-0.91.1129/doc/index.html
+lib/erlang/lib/esdl-0.91.1129/doc/makedoc.erl
+lib/erlang/lib/esdl-0.91.1129/doc/sdl.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_active.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_audio.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_events.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_joystick.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_keyboard.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_mouse.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_util.html
+lib/erlang/lib/esdl-0.91.1129/doc/sdl_video.html
+lib/erlang/lib/esdl-0.91.1129/ebin/gl.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/glu.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_active.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_audio.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_events.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_joystick.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_keyboard.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_mouse.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_util.beam
+lib/erlang/lib/esdl-0.91.1129/ebin/sdl_video.beam
+lib/erlang/lib/esdl-0.91.1129/include/gl.hrl
+lib/erlang/lib/esdl-0.91.1129/include/glu.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_active.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_audio.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_events.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_joystick.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_keyboard.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_mouse.hrl
+lib/erlang/lib/esdl-0.91.1129/include/sdl_video.hrl
+lib/erlang/lib/esdl-0.91.1129/priv/sdl_driver.so
+lib/erlang/lib/esdl-0.91.1129/priv/sdlwrapper
+lib/erlang/lib/esdl-0.91.1129/src/Makefile
+lib/erlang/lib/esdl-0.91.1129/src/Makefile.win32
+lib/erlang/lib/esdl-0.91.1129/src/esdl.hrl
+lib/erlang/lib/esdl-0.91.1129/src/gl.erl
+lib/erlang/lib/esdl-0.91.1129/src/gl_funcs.hrl
+lib/erlang/lib/esdl-0.91.1129/src/glu.erl
+lib/erlang/lib/esdl-0.91.1129/src/glu_funcs.hrl
+lib/erlang/lib/esdl-0.91.1129/src/sdl.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_active.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_audio.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_events.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_joystick.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_keyboard.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_mouse.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_util.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_util.hrl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_video.erl
+lib/erlang/lib/esdl-0.91.1129/src/sdl_video_funcs.hrl
+@dirrm lib/erlang/lib/esdl-0.91.1129/src
+@dirrm lib/erlang/lib/esdl-0.91.1129/priv
+@dirrm lib/erlang/lib/esdl-0.91.1129/include
+@dirrm lib/erlang/lib/esdl-0.91.1129/ebin
+@dirrm lib/erlang/lib/esdl-0.91.1129/doc
+@dirrm lib/erlang/lib/esdl-0.91.1129