aboutsummaryrefslogtreecommitdiff
path: root/devel/eventxx
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-06-10 12:14:20 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-06-10 12:14:20 +0000
commit242585e73081f38318f08a7e5fe5ad7613062d83 (patch)
tree3319c0ebeb785bce10b9f73083cb880f5ff50e20 /devel/eventxx
parent45410a5a867e197098ab91164899f5eb2f257210 (diff)
downloadports-242585e73081f38318f08a7e5fe5ad7613062d83.tar.gz
ports-242585e73081f38318f08a7e5fe5ad7613062d83.zip
- Unbreak - make fetchable again
- Take maintainship - Install examples, according to PORTEXAMPLES
Notes
Notes: svn path=/head/; revision=214617
Diffstat (limited to 'devel/eventxx')
-rw-r--r--devel/eventxx/Makefile21
-rw-r--r--devel/eventxx/distinfo6
-rw-r--r--devel/eventxx/pkg-plist13
3 files changed, 32 insertions, 8 deletions
diff --git a/devel/eventxx/Makefile b/devel/eventxx/Makefile
index b663d47b0782..e33ed4a71ed2 100644
--- a/devel/eventxx/Makefile
+++ b/devel/eventxx/Makefile
@@ -8,22 +8,33 @@
PORTNAME= eventxx
PORTVERSION= 1.0
-PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= http://www.llucax.com.ar/~luca/eventxx/releases/
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.FreeBSD.org/~gahr/distfiles/
+MASTER_SITE_SUBDIR= gahr
+DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A C++ wrapper for libevent
LIB_DEPENDS= event-1.3e:${PORTSDIR}/devel/libevent
-BROKEN= does not fetch
+WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-PLIST_FILES= include/eventxx
+post-extract:
+ ${REINPLACE_CMD} -e 's|-I..|-I.. -I${LOCALBASE}/include -L${LOCALBASE}/lib|g' \
+ ${WRKSRC}/test/Makefile
do-install:
@${INSTALL_DATA} ${WRKSRC}/eventxx ${PREFIX}/include
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${INSTALL} -d ${EXAMPLESDIR}
+ (cd ${WRKSRC}/test && ${COPYTREE_SHARE} \*.cpp ${EXAMPLESDIR})
+ ${INSTALL_DATA} ${WRKSRC}/test/Makefile ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/eventxx/distinfo b/devel/eventxx/distinfo
index 1863d9917c5a..8b60f5b85100 100644
--- a/devel/eventxx/distinfo
+++ b/devel/eventxx/distinfo
@@ -1,3 +1,3 @@
-MD5 (eventxx-1.0.tar.gz) = 269313aa8c3956dec62a3f2180e7ca5d
-SHA256 (eventxx-1.0.tar.gz) = a4cfc756e395e333f38201a5c30005736d46df3154d9edda2da9263f5d15546e
-SIZE (eventxx-1.0.tar.gz) = 27587
+MD5 (eventxx.tar.gz) = 5c9538088b1cf79821b9ce4bbb1a8a10
+SHA256 (eventxx.tar.gz) = 88e9d6db242ed63c203aac14e04c453f2ac04f2c2e2d4a1304e34bdf5e9bb6b4
+SIZE (eventxx.tar.gz) = 27534
diff --git a/devel/eventxx/pkg-plist b/devel/eventxx/pkg-plist
new file mode 100644
index 000000000000..b93af82aaecb
--- /dev/null
+++ b/devel/eventxx/pkg-plist
@@ -0,0 +1,13 @@
+include/eventxx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bench.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c-way.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/functor-way.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mixed-way.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/prio-test.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-eof.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-time.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-weof.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trivial.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wrapped-functor-way.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%