aboutsummaryrefslogtreecommitdiff
path: root/devel/evolution-gconf-tools
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:53:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:53:22 +0000
commit2418b2c0094baef73318e0f59c7322c24beeec26 (patch)
treeb3435b34427c487447a4c04e39e3c22353d58fc4 /devel/evolution-gconf-tools
parentf42a2a8074a7c116eba281f2ad7e42af6f34685b (diff)
downloadports-2418b2c0094baef73318e0f59c7322c24beeec26.tar.gz
ports-2418b2c0094baef73318e0f59c7322c24beeec26.zip
aAdd evolution-gconf-tools, a set of Python scripts to make it easier to work
with Evolution's configuration information. WWW: http://live.gnome.org/Evolution_2fGConfTools Submitted by: ahze
Notes
Notes: svn path=/head/; revision=147292
Diffstat (limited to 'devel/evolution-gconf-tools')
-rw-r--r--devel/evolution-gconf-tools/Makefile29
-rw-r--r--devel/evolution-gconf-tools/distinfo2
-rw-r--r--devel/evolution-gconf-tools/pkg-descr4
-rw-r--r--devel/evolution-gconf-tools/pkg-plist26
4 files changed, 61 insertions, 0 deletions
diff --git a/devel/evolution-gconf-tools/Makefile b/devel/evolution-gconf-tools/Makefile
new file mode 100644
index 000000000000..c7c4b6d92f24
--- /dev/null
+++ b/devel/evolution-gconf-tools/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: evolution-gconf-tools
+# Date created: 2005-07-22
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/evolution-gconf-tools/Makefile,v 1.2 2005/10/14 20:39:56 adamw Exp $
+#
+
+PORTNAME= evolution-gconf-tools
+PORTVERSION= 0.1.6
+CATEGORIES= devel
+MASTER_SITES= http://people.redhat.com/dmalcolm/evolution-gconf-tools/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Scripts to make it easier to work with Evolution's configuration
+
+RUN_DEPENDS= evolution:${PORTSDIR}/mail/evolution
+
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${SH}|' \
+ ${WRKSRC}/lib/*
+
+.include <bsd.port.mk>
diff --git a/devel/evolution-gconf-tools/distinfo b/devel/evolution-gconf-tools/distinfo
new file mode 100644
index 000000000000..0f89e94252e2
--- /dev/null
+++ b/devel/evolution-gconf-tools/distinfo
@@ -0,0 +1,2 @@
+MD5 (evolution-gconf-tools-0.1.6.tar.gz) = 6fcb3b48896c318fa6fc1354443ed0a4
+SIZE (evolution-gconf-tools-0.1.6.tar.gz) = 72303
diff --git a/devel/evolution-gconf-tools/pkg-descr b/devel/evolution-gconf-tools/pkg-descr
new file mode 100644
index 000000000000..70fbe071dd7e
--- /dev/null
+++ b/devel/evolution-gconf-tools/pkg-descr
@@ -0,0 +1,4 @@
+Python scripts to make it easier to work with Evolution's
+configuration information
+
+WWW: http://live.gnome.org/Evolution_2fGConfTools
diff --git a/devel/evolution-gconf-tools/pkg-plist b/devel/evolution-gconf-tools/pkg-plist
new file mode 100644
index 000000000000..c44281f01b63
--- /dev/null
+++ b/devel/evolution-gconf-tools/pkg-plist
@@ -0,0 +1,26 @@
+bin/evolution-gconf-filter-exchange
+bin/evolution-gconf-log
+bin/evolution-gconf-personalize
+bin/evolution-gconf-setup-user
+etc/gconf/evolution-gconf-tools/configuration
+etc/gconf/evolution-gconf-tools/prototype-data.xml
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/accountlogger.py
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/accountlogger.pyc
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/accountlogger.pyo
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/common.py
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/common.pyc
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/common.pyo
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/exchangeserverfilter.py
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/exchangeserverfilter.pyc
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/exchangeserverfilter.pyo
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/gconfvisitor.py
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/gconfvisitor.pyc
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/gconfvisitor.pyo
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/personalizevisitor.py
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/personalizevisitor.pyc
+%%PYTHON_SITELIBDIR%%/evolutiongconftools/personalizevisitor.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/evolutiongconftools
+@dirrm %%PYTHON_SITELIBDIR%%/evolution-gconf-tools
+@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%PYTHON_LIBDIR%% 2>/dev/null || true
+@dirrm etc/gconf/evolution-gconf-tools