aboutsummaryrefslogtreecommitdiff
path: root/devel/fhist/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-22 00:23:55 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-22 00:23:55 +0000
commit3c06539c098ae3c77173cd8db1063a0f7c798018 (patch)
tree2a3afeed6598304ee2c9c3f21de95d90757423ed /devel/fhist/Makefile
parente3c3b5d6f2f13764713ee7ceaa8f5ff72bdbb9a0 (diff)
downloadports-3c06539c098ae3c77173cd8db1063a0f7c798018.tar.gz
ports-3c06539c098ae3c77173cd8db1063a0f7c798018.zip
- Bump PORTREVISION
devel/fhist: - Add stage support - Convert LIB_DEPENDS to new syntax
Notes
Notes: svn path=/head/; revision=337170
Diffstat (limited to 'devel/fhist/Makefile')
-rw-r--r--devel/fhist/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/fhist/Makefile b/devel/fhist/Makefile
index 8a55061b189a..dc7918bbfecb 100644
--- a/devel/fhist/Makefile
+++ b/devel/fhist/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fhist
PORTVERSION= 1.21
DISTVERSIONSUFFIX= .D001
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -13,7 +13,7 @@ COMMENT= Utilities to maintain file history, do file comparisons, and merges
LICENSE= GPLv3
-LIB_DEPENDS= explain:${PORTSDIR}/devel/libexplain
+LIB_DEPENDS= libexplain.so:${PORTSDIR}/devel/libexplain
OPTIONS_DEFINE= NLS
@@ -28,10 +28,10 @@ MAKE_JOBS_UNSAFE=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= fcomp.1 fhist.1 fmerge.1
-PLIST_FILES= bin/fcomp bin/fhist bin/fmerge
+PLIST_FILES= bin/fcomp bin/fhist bin/fmerge \
+ man/man1/fcomp.1.gz man/man1/fhist.1.gz \
+ man/man1/fmerge.1.gz
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -53,12 +53,12 @@ post-build:
do-install:
.for file in fcomp fhist fmerge
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/lib/en/man1/${file}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/lib/en/man1/${file}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MNLS}
- @${MKDIR} ${PREFIX}/share/locale/en/LC_MESSAGES
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/en/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/lib/en/LC_MESSAGES/${file}.mo \
- ${PREFIX}/share/locale/en/LC_MESSAGES
+ ${STAGEDIR}${PREFIX}/share/locale/en/LC_MESSAGES
.endif
.endfor