aboutsummaryrefslogtreecommitdiff
path: root/devel/fhist
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2000-01-05 11:00:05 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2000-01-05 11:00:05 +0000
commitd3a5d6236312241932a7fae59576900436fbd918 (patch)
tree409d1587faf9b3b9254a092d7f9eedd5cae73328 /devel/fhist
parent8f9bd2a1695bea4a0a2c51eef831421c09d935c1 (diff)
downloadports-d3a5d6236312241932a7fae59576900436fbd918.tar.gz
ports-d3a5d6236312241932a7fae59576900436fbd918.zip
Upgrade to v1.6.
Notes
Notes: svn path=/head/; revision=24434
Diffstat (limited to 'devel/fhist')
-rw-r--r--devel/fhist/Makefile22
-rw-r--r--devel/fhist/distinfo2
-rw-r--r--devel/fhist/files/patch-aa81
-rw-r--r--devel/fhist/files/patch-ab65
-rw-r--r--devel/fhist/pkg-descr3
5 files changed, 102 insertions, 71 deletions
diff --git a/devel/fhist/Makefile b/devel/fhist/Makefile
index 8bb682e3bcc5..c1041bf3b782 100644
--- a/devel/fhist/Makefile
+++ b/devel/fhist/Makefile
@@ -1,29 +1,35 @@
# New ports collection makefile for: fhist
-# Version required: 1.1
-# Date created: Apr 23 1998
-# Whom: <koshy@india.hp.com>
+# Version required: 1.6
+# Date created: Jan 05 2000
+# Whom: <jkoshy@freebsd.org>
#
# $FreeBSD$
#
-DISTNAME= fhist.1.1
-PKGNAME= fhist-1.1
+DISTNAME= fhist-1.6
CATEGORIES= devel
-MASTER_SITES= ftp://archie.au/unix/Aegis/ \
- http://www.canb.auug.org.au/~millerp/ \
+MASTER_SITES= http://www.canb.auug.org.au/~millerp/ \
ftp://ftp.agso.gov.au/pub/Aegis/ \
ftp://ftp.u-aizu.ac.jp/pub/misc/tools/Aegis/ \
http://gd.tuwien.ac.at/softeng/Aegis/
-MAINTAINER= koshy@india.hp.com
+MAINTAINER= jkoshy@freebsd.org
MAN1= fcomp.1 fhist.1 fmerge.1
+ALL_TARGET= binaries
+INSTALL_TARGET= install-bin
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --includedir=${PREFIX}/include
+
+post-extract:
+ cd ${WRKSRC}/lib/en/man1 && ${LN} -s ${WRKSRC}/etc/*.so .
post-install:
.for file in fhist fcomp fmerge
strip ${PREFIX}/bin/${file}
+ (cd ${WRKSRC}/lib/en/man1; soelim ${file}.1 > tmp; \
+ ${INSTALL_MAN} tmp ${PREFIX}/man/man1/${file}.1)
.endfor
.include <bsd.port.mk>
diff --git a/devel/fhist/distinfo b/devel/fhist/distinfo
index 1ee6421265bb..45e0bbe9a64d 100644
--- a/devel/fhist/distinfo
+++ b/devel/fhist/distinfo
@@ -1 +1 @@
-MD5 (fhist.1.1.tar.gz) = 4ff344982859003078e853f387a5493b
+MD5 (fhist-1.6.tar.gz) = 1faf34b83d6d35ecf4bd53637f69933f
diff --git a/devel/fhist/files/patch-aa b/devel/fhist/files/patch-aa
index 975c0aac823c..637e9b0cc544 100644
--- a/devel/fhist/files/patch-aa
+++ b/devel/fhist/files/patch-aa
@@ -1,24 +1,57 @@
---- common/compare.c-- Fri Oct 7 18:05:04 1994
-+++ common/compare.c Thu Apr 23 12:53:41 1998
-@@ -326,10 +326,10 @@
- }
-
-
--static int isblank _((char *s));
-+static int isblank_ _((char *s));
-
- static int
--isblank(s)
-+isblank_(s)
- char *s;
- {
- while (*s)
-@@ -387,7 +387,7 @@
- ((linenumber % READBLABINTERVAL) == 0)
- )
- error("[%ld lines]", linenumber);
-- if (fc.blankflag && isblank(cp))
-+ if (fc.blankflag && isblank_(cp))
- continue;
- if (linecount >= linesavail)
- {
+--- Makefile.in-- Wed Jan 5 21:12:04 2000
++++ Makefile.in Wed Jan 5 21:13:41 2000
+@@ -715,46 +715,46 @@
+ $(INSTALL_DATA) lib/en/building.txt $@
+
+ $(datadir)/en/man1/fcomp.1: lib/en/man1/fcomp.1 lib/en/man1/.datadir
+- $(SOELIM) -Ilib/en/man1 -Ietc lib/en/man1/fcomp.1 > tmp
++ $(SOELIM) lib/en/man1/fcomp.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(mandir)/man1/fcomp.1: lib/$(MANLANG)/man1/fcomp.1 lib/en/man1/.mandir
+- $(SOELIM) -Ilib/$(MANLANG)/man1 -Ietc lib/$(MANLANG)/man1/fcomp.1 > tmp
++ $(SOELIM) lib/$(MANLANG)/man1/fcomp.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(datadir)/en/man1/fhist.1: lib/en/man1/fhist.1 lib/en/man1/.datadir
+- $(SOELIM) -Ilib/en/man1 -Ietc lib/en/man1/fhist.1 > tmp
++ $(SOELIM) lib/en/man1/fhist.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(mandir)/man1/fhist.1: lib/$(MANLANG)/man1/fhist.1 lib/en/man1/.mandir
+- $(SOELIM) -Ilib/$(MANLANG)/man1 -Ietc lib/$(MANLANG)/man1/fhist.1 > tmp
++ $(SOELIM) lib/$(MANLANG)/man1/fhist.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(datadir)/en/man1/fhist_lic.1: lib/en/man1/fhist_lic.1 \
+ lib/en/man1/.datadir
+- $(SOELIM) -Ilib/en/man1 -Ietc lib/en/man1/fhist_lic.1 > tmp
++ $(SOELIM) lib/en/man1/fhist_lic.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(mandir)/man1/fhist_lic.1: lib/$(MANLANG)/man1/fhist_lic.1 \
+ lib/en/man1/.mandir
+- $(SOELIM) -Ilib/$(MANLANG)/man1 -Ietc \
++ $(SOELIM) \
+ lib/$(MANLANG)/man1/fhist_lic.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(datadir)/en/man1/fmerge.1: lib/en/man1/fmerge.1 lib/en/man1/.datadir
+- $(SOELIM) -Ilib/en/man1 -Ietc lib/en/man1/fmerge.1 > tmp
++ $(SOELIM) lib/en/man1/fmerge.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
+
+ $(mandir)/man1/fmerge.1: lib/$(MANLANG)/man1/fmerge.1 \
+ lib/en/man1/.mandir
+- $(SOELIM) -Ilib/$(MANLANG)/man1 -Ietc \
++ $(SOELIM) \
+ lib/$(MANLANG)/man1/fmerge.1 > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm -f tmp
diff --git a/devel/fhist/files/patch-ab b/devel/fhist/files/patch-ab
index 522763b11f0d..633d23b7405e 100644
--- a/devel/fhist/files/patch-ab
+++ b/devel/fhist/files/patch-ab
@@ -1,38 +1,31 @@
---- fhist/breaks.c~ Fri Oct 7 18:05:04 1994
-+++ fhist/breaks.c Wed Apr 29 09:25:29 1998
-@@ -23,13 +23,34 @@
- * MANIFEST: Unix-specific routines to implement special actions.
- */
-
-+#ifdef HAVE_SYS_PARAM_H
-+#include <sys/param.h>
-+#endif
-+
- #include <signal.h>
-
- #include <breaks.h>
-
--#if defined(sun) || defined(__sun__)
-+#if defined(sun) || defined(__sun__)
- #define sighold(n)
- #define sigrelse(n)
-+#elif (defined(BSD) && (BSD > 199306))
-+/* POSIX handling, assumed present from 4.4 days */
-+/* Will this be valid for {Open,Net}BSD too? */
-+#define sighold(n) \
-+ do { \
-+ sigset_t set; \
-+ (void) sigemptyset(&set); \
-+ (void) sigaddset(&set, (n)); \
-+ (void) sigprocmask(SIG_BLOCK, &set, (void *)0); \
-+ } while(0)
-+#define sigrelse(n) \
-+ do { \
-+ sigset_t set; \
-+ (void) sigemptyset(&set); \
-+ (void) sigaddset(&set, (n)); \
-+ (void) sigprocmask(SIG_UNBLOCK, &set, (void *)0); \
-+ } while (0)
- #endif
+--- configure-- Wed Jan 5 21:46:38 2000
++++ configure Wed Jan 5 21:46:42 2000
+@@ -1425,28 +1425,6 @@
+ done
+-if test -n "$SOELIM"; then
+-echo $ac_n "checking that $SOELIM understands the -I option""... $ac_c" 1>&6
+-echo "configure:1431: checking that $SOELIM understands the -I option" >&5
+-echo ".so version.so" > conftest.in 2>&5
+-$SOELIM -Ietc -Ibl/etc -Iblbl/etc conftest.in > conftest.out 2>&5
+-if grep 1998 conftest.out 1>&5 2>&5; then
+- echo "$ac_t""yes" 1>&6
+-else
+- echo "$ac_t""no" 1>&6
+- echo "$ac_t""" 1>&6
+- echo "$ac_t"" The FHist documentation set and manual pages" 1>&6
+- echo "$ac_t"" will be formatted and installed installed if" 1>&6
+- echo "$ac_t"" you first install GNU Groff with the patch found" 1>&6
+- echo "$ac_t"" at http://www.canb.auug.org.au/~millerp/ and then" 1>&6
+- echo "$ac_t"" re-run this ./configure script. Remember to" 1>&6
+- echo "$ac_t"" use \`\`rm config.cache'' before you do." 1>&6
+- echo "$ac_t""" 1>&6
+- SOELIM=
+-fi
+-rm -rf conftest*
+-fi
+-
+ echo $ac_n "checking for TIOCGWINSZ""... $ac_c" 1>&6
+ echo "configure:1452: checking for TIOCGWINSZ" >&5
+ if test "$cross_compiling" = yes; then
diff --git a/devel/fhist/pkg-descr b/devel/fhist/pkg-descr
index 2809bcf668de..819d710a27e4 100644
--- a/devel/fhist/pkg-descr
+++ b/devel/fhist/pkg-descr
@@ -14,5 +14,4 @@ See also: ``A File Comparison Program, Webb Miller and Eugene W.
Myers'', Software Practice and Experience, Volume 15, No. 11,
November 1985.
-- Koshy
- <jkoshy@acm.org>
+- Joseph Koshy <jkoshy@freebsd.org>