aboutsummaryrefslogtreecommitdiff
path: root/devel/flexjson/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-20 12:18:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-20 12:18:32 +0000
commit43e4f23ceac49d6cd57ec50425782ca9365b577d (patch)
tree302dd8bf1eb24e2697c32c13a848f19d093d0ad8 /devel/flexjson/Makefile
parent4d0c4cd69fe3e3b7a25449f3d683a110c9720e16 (diff)
downloadports-43e4f23ceac49d6cd57ec50425782ca9365b577d.tar.gz
ports-43e4f23ceac49d6cd57ec50425782ca9365b577d.zip
FlexJSON is a lightweight library to serialize objects out in Javascript Object
Notation (JSON). The library serializes only immediately available fields by default, although it's fairly easy to add additional data such as collections through code or annotations. WWW: http://flexjson.sourceforge.net/ PR: ports/111934 Submitted by: Nemo Liu <nemoliu at gmail.com>
Notes
Notes: svn path=/head/; revision=190438
Diffstat (limited to 'devel/flexjson/Makefile')
-rw-r--r--devel/flexjson/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/devel/flexjson/Makefile b/devel/flexjson/Makefile
new file mode 100644
index 000000000000..edd6ef6405fa
--- /dev/null
+++ b/devel/flexjson/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: FlexJson
+# Date created: 20 Apr 2006
+# Whom: Nemo Liu <nemoliu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flexjson
+PORTVERSION= 1.0
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= nemoliu@gmail.com
+COMMENT= A lightweight Java library to write JSON
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+USE_ZIP= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= LICENSE-2.0.txt docs
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}/docs/
+ @cd ${WRKDIR}/docs \
+ && ${INSTALL_DATA} example_object_model.jpg ${DOCSDIR}/docs/. \
+ && ${INSTALL_DATA} index.html ${DOCSDIR}/docs/.
+ @${INSTALL_DATA} ${WRKDIR}/LICENSE-2.0.txt ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>