aboutsummaryrefslogtreecommitdiff
path: root/devel/flick
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-01-11 05:17:44 +0000
committerSteve Price <steve@FreeBSD.org>1999-01-11 05:17:44 +0000
commit7c65647fc760ff100b3ec263056e309ecc620140 (patch)
treee0c714d9745e324e5d65f73b551743304e1becd2 /devel/flick
parent36500cd90004c28ad44aea9b054158c145934335 (diff)
downloadports-7c65647fc760ff100b3ec263056e309ecc620140.tar.gz
ports-7c65647fc760ff100b3ec263056e309ecc620140.zip
Initial import of flick version 1.1.
The Flexible IDL Compiler Kit. PR: 6153 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=15997
Diffstat (limited to 'devel/flick')
-rw-r--r--devel/flick/Makefile29
-rw-r--r--devel/flick/distinfo1
-rw-r--r--devel/flick/pkg-comment1
-rw-r--r--devel/flick/pkg-descr31
-rw-r--r--devel/flick/pkg-plist45
5 files changed, 107 insertions, 0 deletions
diff --git a/devel/flick/Makefile b/devel/flick/Makefile
new file mode 100644
index 000000000000..ae73002e40d9
--- /dev/null
+++ b/devel/flick/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: flick
+# Version required: 1.1
+# Date created: 21 Mar 1998
+# Whom: giffunip@asme.org
+#
+# $Id$
+#
+
+DISTNAME= flick-src-1.1
+PKGNAME= flick-1.1
+CATEGORIES= devel
+MASTER_SITES= ftp://flux.cs.utah.edu/flux/flick/
+
+MAINTAINER= ports@FreeBSD.ORG
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/flick
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${PREFIX}/share/doc/flick
+ ${INSTALL_DATA} ${WRKSRC}/doc/usersguide/*.ps ${PREFIX}/share/doc/flick
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/flick/distinfo b/devel/flick/distinfo
new file mode 100644
index 000000000000..e84bc07da08a
--- /dev/null
+++ b/devel/flick/distinfo
@@ -0,0 +1 @@
+MD5 (flick-src-1.1.tar.gz) = 48362e02fdca8de2e90c2d5815d38365
diff --git a/devel/flick/pkg-comment b/devel/flick/pkg-comment
new file mode 100644
index 000000000000..c341f258a8bd
--- /dev/null
+++ b/devel/flick/pkg-comment
@@ -0,0 +1 @@
+The Flexible IDL Compiler Kit
diff --git a/devel/flick/pkg-descr b/devel/flick/pkg-descr
new file mode 100644
index 000000000000..5702ed9c265c
--- /dev/null
+++ b/devel/flick/pkg-descr
@@ -0,0 +1,31 @@
+Flick is an interface definition language (IDL) compiler ("stub generator")
+supporting remote procedure call (RPC) and remote method invocation (RMI) for
+client/server or distributed object systems. What sets it apart from other IDL
+compilers is that it is highly optimizing while also supporting several IDLs,
+message formats, and transport mechanisms. Flick currently has front ends for
+the CORBA, Sun ONC RPC, and Mach MIG IDLs, and middle and back ends that support
+CORBA IIOP, ONC/TCP, MIG-style Mach messages, and Fluke IPC (see below). Flick
+produces stubs in the C language. A substantial user's manual is provided.
+
+Flick is designed to be a "kit": the user picks the IDL, language mapping, and
+transport components that are required for any particular system. Our goal is
+to make it straightforward to add new components to the kit to process new
+IDLs, language mappings, and transports. (Collaborators welcome!) Flick's
+framework can also be used to support interface annotation. Full source for
+the Flick compiler is distributed under the terms of the GNU General Public
+License; source for the Flick runtime is distributed under a BSD-style license.
+
+Flick-generated marshal and unmarshal code generally runs between 2 and 17
+times as fast as code produced by other IDL compilers, commercial and free. On
+stock hardware and operating systems, Flick-generated stubs can increase
+end-to-end client/server throughput by factors between 1.2 and 3.7 or more.
+
+Our paper describing these results was presented at PLDI'97, the major compiler
+conference, in June (see http://www.cs.bu.edu/pub/pldi97/). The paper is
+included as part of the Flick distribution, and is separately available at
+ftp://mancos.cs.utah.edu/papers/flick-pldi-97-abs.html.
+
+ URL: http://www.cs.utah.edu/projects/flux/flick/
+
+Jay Lepreau, lepreau@cs.utah.edu
+University of Utah Computer Science Dept.
diff --git a/devel/flick/pkg-plist b/devel/flick/pkg-plist
new file mode 100644
index 000000000000..b862a9020beb
--- /dev/null
+++ b/devel/flick/pkg-plist
@@ -0,0 +1,45 @@
+bin/flick-aoid
+bin/flick-c-fe-mig
+bin/flick-c-pbe-fluke
+bin/flick-c-pbe-iiop
+bin/flick-c-pbe-mach3mig
+bin/flick-c-pbe-sun
+bin/flick-c-pbe-trapeze
+bin/flick-c-pfe-corba
+bin/flick-c-pfe-fluke
+bin/flick-c-pfe-sun
+bin/flick-c-presd
+bin/flick-fe-newcorba
+bin/flick-fe-sun
+include/flick/encode/all.h
+include/flick/encode/cdr.h
+include/flick/encode/endian.h
+include/flick/encode/mach3mig.h
+include/flick/encode/xdr.h
+include/flick/link/ORB.h
+include/flick/link/all.h
+include/flick/link/iiop.h
+include/flick/link/mach3mig.h
+include/flick/link/suntcp.h
+include/flick/link/trapeze.h
+include/flick/pres/all.h
+include/flick/pres/corba.h
+include/flick/pres/mig.h
+include/flick/pres/mom.h
+include/flick/pres/sun.h
+lib/libflick-aoi.a
+lib/libflick-c-pbe.a
+lib/libflick-c-pfe-corba.a
+lib/libflick-c-pfe.a
+lib/libflick-cast.a
+lib/libflick-compiler.a
+lib/libflick-mint.a
+lib/libflick-pres_c.a
+share/doc/flick/flick-pldi97.ps
+share/doc/flick/headers.ps
+share/doc/flick/user.ps
+@dirrm include/flick/encode
+@dirrm include/flick/link
+@dirrm include/flick/pres
+@dirrm include/flick
+@dirrm share/doc/flick