aboutsummaryrefslogtreecommitdiff
path: root/devel/flyspray
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-28 19:56:31 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-28 19:56:31 +0000
commit3f009cb2157ee1d6253011e197fc4885198310ad (patch)
treeefb1f2471e5bb8f24e7d6d215a19b195c489fd1c /devel/flyspray
parent95e07bbb9118bb87695e9f4d59475eeab8e8277f (diff)
downloadports-3f009cb2157ee1d6253011e197fc4885198310ad.tar.gz
ports-3f009cb2157ee1d6253011e197fc4885198310ad.zip
Add flyspray 0.9.4,
a simple, easy-to-use web based bug tracking system. PR: 56082 Submitted by: Nick Hilliard <nick@foobar.org>
Notes
Notes: svn path=/head/; revision=87924
Diffstat (limited to 'devel/flyspray')
-rw-r--r--devel/flyspray/Makefile53
-rw-r--r--devel/flyspray/distinfo1
-rw-r--r--devel/flyspray/pkg-deinstall16
-rw-r--r--devel/flyspray/pkg-descr11
-rw-r--r--devel/flyspray/pkg-message39
-rw-r--r--devel/flyspray/pkg-plist133
6 files changed, 253 insertions, 0 deletions
diff --git a/devel/flyspray/Makefile b/devel/flyspray/Makefile
new file mode 100644
index 000000000000..1846ab90a327
--- /dev/null
+++ b/devel/flyspray/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: flyspray
+# Date created: 2003.08.28
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flyspray
+PORTVERSION= 0.9.4
+CATEGORIES= devel
+MASTER_SITES= http://flyspray.rocks.cc/
+
+MAINTAINER= nick@foobar.org
+COMMENT= A simple, easy-to-use web based bug tracking system
+
+.if defined(WITH_APACHE2)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
+.else
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+.endif
+
+NO_BUILD= yes
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+DOC_FILES= AUTHORS BUGS CHANGELOG COPYING INSTALL README TODO UPGRADING flyspray-${PORTVERSION}.sql
+
+do-fetch: ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+ ${FETCH_CMD} ${FETCH_BEFORE_ARGS} ${MASTER_SITES}/?file=${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}
+ ${CHMOD} 755 ${PREFIX}/share/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/config.inc.php ${PREFIX}/share/${PORTNAME}/config.inc.php-dist
+ cd ${WRKSRC} && \
+ tar cf - favicon.ico functions.inc.php functions.js header.php index.php lang scripts themes | \
+ (cd ${PREFIX}/share/${PORTNAME} && tar -xf -)
+ ${LN} -s /var/db/${PORTNAME}/attachments ${PREFIX}/share/${PORTNAME}/attachments
+ ${MKDIR} /var/db/${PORTNAME}/attachments
+ ${CHMOD} 750 /var/db/${PORTNAME}/attachments
+ ${CHOWN} www:www /var/db/${PORTNAME}/attachments
+
+post-install: install-doc
+ @${CAT} ${PKGMESSAGE}
+
+install-doc:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/flyspray/distinfo b/devel/flyspray/distinfo
new file mode 100644
index 000000000000..1e4904e043f5
--- /dev/null
+++ b/devel/flyspray/distinfo
@@ -0,0 +1 @@
+MD5 (flyspray-0.9.4.tar.gz) = c42e69dc6f3fac707ec9ddf900e7f62b
diff --git a/devel/flyspray/pkg-deinstall b/devel/flyspray/pkg-deinstall
new file mode 100644
index 000000000000..aa09c6759022
--- /dev/null
+++ b/devel/flyspray/pkg-deinstall
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+case $2 in
+DEINSTALL)
+ echo "--"
+ echo "The Flyspray program has been deleted but the bug tracking database has"
+ echo "not been touched. To delete all the bug tracking information, execute the"
+ echo "following commands:"
+ echo ""
+ echo "# rm -rf /var/db/flyspray"
+ echo "# mysqladmin -u root -p drop flyspray"
+ echo ""
+ echo "Thanks for using Flyspray!"
+ echo "--"
+;;
+esac
diff --git a/devel/flyspray/pkg-descr b/devel/flyspray/pkg-descr
new file mode 100644
index 000000000000..ed7815d751e1
--- /dev/null
+++ b/devel/flyspray/pkg-descr
@@ -0,0 +1,11 @@
+Need a bug tracking system for your programming project? Having trouble
+finding something that suits your needs? Tried installing Bugzilla, but
+found it too complex?
+
+Flyspray is an easy to use bug tracking system for those who don't require
+all the complexities of something like Bugzilla.
+
+Initially developed for the Psi project, Flyspray is now available for
+everyone to download and use for their own projects.
+
+WWW: http://flyspray.rocks.cc/
diff --git a/devel/flyspray/pkg-message b/devel/flyspray/pkg-message
new file mode 100644
index 000000000000..0d2b8736f7af
--- /dev/null
+++ b/devel/flyspray/pkg-message
@@ -0,0 +1,39 @@
+##
+
+Configuration Instructions for Flyspray
+=======================================
+
+1) Create a mysql database for Flyspray to use. Here is one way to
+do that, from the command line, entering your mysql root password when
+prompted:
+
+# mysqladmin -u root -p create flyspray
+
+2) Import the Flyspray database tables into your new empty
+database. Here is the command line method; be sure to enter your mysql root
+password when prompted:
+
+# mysql -u root -p flyspray < flyspray-version.sql
+
+3) Copy the config.inc.php-dist file to config.inc.php and edit it to suit
+your database setup. Examples are provided in the file.
+
+4) Insert the following configuration command into your httpd.conf:
+
+ Alias "/flyspray/" "/usr/local/share/flyspray/"
+
+5) Point your browser to http://yourserver.com/flyspray/ and you should
+see Flyspray! Login as 'super', with the password 'super'.
+
+6) Create youself a new user, place them into the Admin group.
+
+7) CHANGE THE PASSWORD FOR THE super/super ACCOUNT by clicking the
+'Change Password' link near the top of the page. You might like to disable
+the account entirely, or it will appear in the list of members to be assigned
+tasks.
+
+8) Close the sample task, and begin adding your own.
+
+9) Report any bugs you find back to http://flyspray.rocks.cc/bts/
+
+##
diff --git a/devel/flyspray/pkg-plist b/devel/flyspray/pkg-plist
new file mode 100644
index 000000000000..c1473a6e09be
--- /dev/null
+++ b/devel/flyspray/pkg-plist
@@ -0,0 +1,133 @@
+share/flyspray/attachments
+share/flyspray/config.inc.php-dist
+share/flyspray/favicon.ico
+share/flyspray/functions.inc.php
+share/flyspray/functions.js
+share/flyspray/header.php
+share/flyspray/index.php
+share/flyspray/lang/de/admin.php
+share/flyspray/lang/de/authenticate.php
+share/flyspray/lang/de/chpass.php
+share/flyspray/lang/de/details.php
+share/flyspray/lang/de/functions.inc.php
+share/flyspray/lang/de/index.php
+share/flyspray/lang/de/loginbox.php
+share/flyspray/lang/de/main.php
+share/flyspray/lang/de/modify.php
+share/flyspray/lang/de/newgroup.php
+share/flyspray/lang/de/newtask.php
+share/flyspray/lang/de/newuser.php
+share/flyspray/lang/de/register.php
+share/flyspray/lang/de/severity.php
+share/flyspray/lang/de/status.php
+share/flyspray/lang/en/admin.php
+share/flyspray/lang/en/authenticate.php
+share/flyspray/lang/en/chpass.php
+share/flyspray/lang/en/details.php
+share/flyspray/lang/en/functions.inc.php
+share/flyspray/lang/en/index.php
+share/flyspray/lang/en/loginbox.php
+share/flyspray/lang/en/main.php
+share/flyspray/lang/en/modify.php
+share/flyspray/lang/en/newgroup.php
+share/flyspray/lang/en/newtask.php
+share/flyspray/lang/en/newuser.php
+share/flyspray/lang/en/register.php
+share/flyspray/lang/en/severity.php
+share/flyspray/lang/en/status.php
+share/flyspray/lang/fr/admin.php
+share/flyspray/lang/fr/authenticate.php
+share/flyspray/lang/fr/chpass.php
+share/flyspray/lang/fr/details.php
+share/flyspray/lang/fr/functions.inc.php
+share/flyspray/lang/fr/index.php
+share/flyspray/lang/fr/loginbox.php
+share/flyspray/lang/fr/main.php
+share/flyspray/lang/fr/modify.php
+share/flyspray/lang/fr/newgroup.php
+share/flyspray/lang/fr/newtask.php
+share/flyspray/lang/fr/newuser.php
+share/flyspray/lang/fr/register.php
+share/flyspray/lang/fr/severity.php
+share/flyspray/lang/fr/status.php
+share/flyspray/lang/nl/admin.php
+share/flyspray/lang/nl/authenticate.php
+share/flyspray/lang/nl/chpass.php
+share/flyspray/lang/nl/details.php
+share/flyspray/lang/nl/functions.inc.php
+share/flyspray/lang/nl/index.php
+share/flyspray/lang/nl/loginbox.php
+share/flyspray/lang/nl/main.php
+share/flyspray/lang/nl/modify.php
+share/flyspray/lang/nl/newgroup.php
+share/flyspray/lang/nl/newtask.php
+share/flyspray/lang/nl/newuser.php
+share/flyspray/lang/nl/register.php
+share/flyspray/lang/nl/severity.php
+share/flyspray/lang/nl/status.php
+share/flyspray/scripts/admin.php
+share/flyspray/scripts/authenticate.php
+share/flyspray/scripts/chpass.php
+share/flyspray/scripts/details.php
+share/flyspray/scripts/index.php
+share/flyspray/scripts/loginbox.php
+share/flyspray/scripts/modify.php
+share/flyspray/scripts/newgroup.php
+share/flyspray/scripts/newtask.php
+share/flyspray/scripts/newuser.php
+share/flyspray/scripts/register.php
+share/flyspray/themes/Bluey/button.png
+share/flyspray/themes/Bluey/index.html
+share/flyspray/themes/Bluey/percent-0.png
+share/flyspray/themes/Bluey/percent-10.png
+share/flyspray/themes/Bluey/percent-100.png
+share/flyspray/themes/Bluey/percent-20.png
+share/flyspray/themes/Bluey/percent-30.png
+share/flyspray/themes/Bluey/percent-40.png
+share/flyspray/themes/Bluey/percent-50.png
+share/flyspray/themes/Bluey/percent-60.png
+share/flyspray/themes/Bluey/percent-70.png
+share/flyspray/themes/Bluey/percent-80.png
+share/flyspray/themes/Bluey/percent-90.png
+share/flyspray/themes/Bluey/tab-active.png
+share/flyspray/themes/Bluey/tab-notactive.png
+share/flyspray/themes/Bluey/theme.css
+share/flyspray/themes/Bluey/title.png
+share/flyspray/themes/Woodgrain/button.png
+share/flyspray/themes/Woodgrain/index.html
+share/flyspray/themes/Woodgrain/page-bg.png
+share/flyspray/themes/Woodgrain/page-fg.png
+share/flyspray/themes/Woodgrain/percent-0.png
+share/flyspray/themes/Woodgrain/percent-10.png
+share/flyspray/themes/Woodgrain/percent-100.png
+share/flyspray/themes/Woodgrain/percent-20.png
+share/flyspray/themes/Woodgrain/percent-30.png
+share/flyspray/themes/Woodgrain/percent-40.png
+share/flyspray/themes/Woodgrain/percent-50.png
+share/flyspray/themes/Woodgrain/percent-60.png
+share/flyspray/themes/Woodgrain/percent-70.png
+share/flyspray/themes/Woodgrain/percent-80.png
+share/flyspray/themes/Woodgrain/percent-90.png
+share/flyspray/themes/Woodgrain/theme.css
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
+%%PORTDOCS%%%%DOCSDIR%%/flyspray-0.9.4.sql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/flyspray/lang/en
+@dirrm share/flyspray/lang/de
+@dirrm share/flyspray/lang/fr
+@dirrm share/flyspray/lang/nl
+@dirrm share/flyspray/lang
+@dirrm share/flyspray/themes/Bluey
+@dirrm share/flyspray/themes/Woodgrain
+@dirrm share/flyspray/themes
+@dirrm share/flyspray/scripts
+@dirrm share/flyspray
+@unexec rmdir /var/db/flyspray/attachments 2>/dev/null || true
+@unexec rmdir /var/db/flyspray 2>/dev/null || true