aboutsummaryrefslogtreecommitdiff
path: root/devel/flyspray
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-09-05 14:53:58 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-09-05 14:53:58 +0000
commitaddebf1f7b9d05ae8cee124a0c147fc31729779b (patch)
tree50f373a677b6855466532cbc15b54f10615d2615 /devel/flyspray
parent044628c13e3d0bee9b21a2de70c29549dcd40798 (diff)
downloadports-addebf1f7b9d05ae8cee124a0c147fc31729779b.tar.gz
ports-addebf1f7b9d05ae8cee124a0c147fc31729779b.zip
- Be more friendly for package
- Bump PORTREVISION to build new package PR: ports/115862 Submitted by: Nick Hilliard <nick at foobar.org> (maintainer)
Notes
Notes: svn path=/head/; revision=198847
Diffstat (limited to 'devel/flyspray')
-rw-r--r--devel/flyspray/Makefile29
-rw-r--r--devel/flyspray/files/README.FreeBSD9
-rw-r--r--devel/flyspray/files/pkg-install.in13
-rw-r--r--devel/flyspray/pkg-deinstall2
-rw-r--r--devel/flyspray/pkg-plist2
5 files changed, 38 insertions, 17 deletions
diff --git a/devel/flyspray/Makefile b/devel/flyspray/Makefile
index 46be96e269d5..5942e2fb3210 100644
--- a/devel/flyspray/Makefile
+++ b/devel/flyspray/Makefile
@@ -7,7 +7,8 @@
PORTNAME= flyspray
PORTVERSION= 0.9.9.2
-CATEGORIES= devel
+PORTREVISION= 1
+CATEGORIES= devel www
MASTER_SITES= http://www.flyspray.org/
MAINTAINER= nick@foobar.org
@@ -35,12 +36,19 @@ DOC_FILES= AUTHORS.txt BUGS.txt CHANGELOG.txt INSTALL.txt \
licences/NuvolaIcons.licence.txt \
licences/jsCalendar.licence.txt
-FLYSPRAY_FILES= cache docs/licences/gnu_lgpl.html \
- favicon.ico feed.php header.php htaccess.dist includes \
- index.php javascript lang plugins robots.txt schedule.php \
- scripts setup templates themes
+FLYSPRAY_FILES= cache docs/licences/gnu_lgpl.html favicon.ico \
+ flyspray.conf.php-dist feed.php header.php htaccess.dist \
+ includes index.php javascript lang plugins robots.txt \
+ schedule.php scripts setup templates themes
-SUB_FILES= pkg-message
+SUB_FILES+= pkg-message pkg-install
+SUB_LIST+= FLYSPRAYDIR="${FLYSPRAYDIR}" \
+ ATTACHMENTDIR="${ATTACHMENTDIR}" \
+ MKDIR="${MKDIR}" \
+ CHOWN="${CHOWN}" \
+ CHMOD="${CHMOD}" \
+ WWWGRP="${WWWGRP}" \
+ WWWOWN="${WWWOWN}"
.include <bsd.port.pre.mk>
@@ -56,19 +64,16 @@ post-patch:
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} '{}' ';'
do-install:
- @${MKDIR} ${FLYSPRAYDIR}
+ ${MKDIR} ${FLYSPRAYDIR}
${CHMOD} 755 ${FLYSPRAYDIR}
- ${TOUCH} ${FLYSPRAYDIR}/flyspray.conf.php
+ ${CP} ${WRKSRC}/setup/upgrade/${PORTVERSION}/flyspray.conf.php ${WRKSRC}/flyspray.conf.php-dist
cd ${WRKSRC} && \
${TAR} cf - ${FLYSPRAY_FILES} | \
(cd ${FLYSPRAYDIR} && ${TAR} -xf -)
${LN} -s ${ATTACHMENTDIR} ${FLYSPRAYDIR}/attachments
${LN} -s ${PREFIX}/share/adodb ${FLYSPRAYDIR}
- @${MKDIR} ${ATTACHMENTDIR}
- ${CHMOD} 750 ${ATTACHMENTDIR}
- ${CHOWN} ${WWWOWN}:${WWWGRP} ${ATTACHMENTDIR}
${CHOWN} ${WWWOWN}:${WWWGRP} ${FLYSPRAYDIR}/cache
- ${CHOWN} ${WWWOWN}:${WWWGRP} ${FLYSPRAYDIR}/flyspray.conf.php
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
post-install: install-doc
@${CAT} ${PKGMESSAGE}
diff --git a/devel/flyspray/files/README.FreeBSD b/devel/flyspray/files/README.FreeBSD
index 8168c0c0c3c9..c452a45296bc 100644
--- a/devel/flyspray/files/README.FreeBSD
+++ b/devel/flyspray/files/README.FreeBSD
@@ -20,8 +20,13 @@ Configuration Instructions for Flyspray
Allow from all
</Directory>
-3) Point your browser to http://yourserver.example.com/flyspray/ and you should
- see the Flyspray installer.
+3) If this is a new Flyspray installation, install the default configuration
+ file and edit to taste:
+
+# cp %%FLYSPRAYDIR%%/flyspray.conf.php-dist %%FLYSPRAYDIR%%/flyspray.conf.php
+
+ Then point your browser to http://yourserver.example.com/flyspray/ and
+ you should see the Flyspray installer.
4) Once the setup procedure has been completed, you must remove the "setup"
directory:
diff --git a/devel/flyspray/files/pkg-install.in b/devel/flyspray/files/pkg-install.in
new file mode 100644
index 000000000000..fb15171e2daa
--- /dev/null
+++ b/devel/flyspray/files/pkg-install.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+case $2 in
+ POST-INSTALL)
+ if [ ! -d %%ATTACHMENTDIR%% ]; then
+ %%MKDIR%% %%ATTACHMENTDIR%%
+ fi
+ %%CHMOD%% 750 %%ATTACHMENTDIR%%
+ %%CHOWN%% %%WWWOWN%%:%%WWWGRP%% %%ATTACHMENTDIR%%
+ ;;
+esac
diff --git a/devel/flyspray/pkg-deinstall b/devel/flyspray/pkg-deinstall
index efc9df869660..aa09c6759022 100644
--- a/devel/flyspray/pkg-deinstall
+++ b/devel/flyspray/pkg-deinstall
@@ -2,8 +2,6 @@
case $2 in
DEINSTALL)
-# /bin/rm -f ${PKG_PREFIX}/share/flyspray/flyspray.conf.php
-# /bin/rmdir ${PKG_PREFIX}/share/flyspray/
echo "--"
echo "The Flyspray program has been deleted but the bug tracking database has"
echo "not been touched. To delete all the bug tracking information, execute the"
diff --git a/devel/flyspray/pkg-plist b/devel/flyspray/pkg-plist
index 045b8e00d692..681f5d2e90f9 100644
--- a/devel/flyspray/pkg-plist
+++ b/devel/flyspray/pkg-plist
@@ -6,7 +6,7 @@
%%DATADIR%%/feed.php
%%DATADIR%%/header.php
%%DATADIR%%/htaccess.dist
-%%DATADIR%%/flyspray.conf.php
+%%DATADIR%%/flyspray.conf.php-dist
%%DATADIR%%/includes/.htaccess
%%DATADIR%%/includes/class.backend.php
%%DATADIR%%/includes/class.database.php