aboutsummaryrefslogtreecommitdiff
path: root/devel/fpc-gdbint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-22 01:57:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-22 01:57:23 +0000
commit259b93dea5de67450431a66a8442910186754d47 (patch)
tree89fa337a46e8fbab4196492c36de4e6dfed943f4 /devel/fpc-gdbint
parent95c01a7ffade817ad93dcb886be5145b4c87294f (diff)
downloadports-259b93dea5de67450431a66a8442910186754d47.tar.gz
ports-259b93dea5de67450431a66a8442910186754d47.zip
* Clean up the Makefile
* Configure to use modified GDB built in devel/fpc-gdb PR: 62571 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=101650
Diffstat (limited to 'devel/fpc-gdbint')
-rw-r--r--devel/fpc-gdbint/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/devel/fpc-gdbint/Makefile b/devel/fpc-gdbint/Makefile
index e185f694f9af..44221a44628a 100644
--- a/devel/fpc-gdbint/Makefile
+++ b/devel/fpc-gdbint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdbint
PORTVERSION= 1.0.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
@@ -26,13 +26,11 @@ COMMENT= Free Pascal unit providing interface to gdb
.include <bsd.port.pre.mk>
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-.endif
+BUILD_DEPENDS+= ppc386:${PORTSDIR}/lang/fpc \
+ gdbfpc:${PORTSDIR}/devel/fpc-gdb
+RUN_DEPENDS+= ${BUILD_DEPENDS}
.if ${OSVERSION} < 470000
-EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+EXTRACT_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
TAR= ${LOCALBASE}/bin/gtar
.endif
USE_GMAKE= yes
@@ -46,6 +44,7 @@ MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
INSTALL_BINDIR=${PREFIX}/bin \
GCCLIBDIR=/usr/lib \
+ GDBLIBDIR=${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd/gdbint/libgdb \
RELEASE=1
do-extract:
@@ -67,11 +66,13 @@ post-patch:
"Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
do-build:
- cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint && \
- ${GMAKE} ${MAKE_ENV} all
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint \
+ all
do-install:
- cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint && \
- ${GMAKE} ${MAKE_ENV} install
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint \
+ install
.include <bsd.port.post.mk>