aboutsummaryrefslogtreecommitdiff
path: root/devel/freelibiberty/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-25 00:02:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-25 00:02:17 +0000
commit1c2da9a09ce2fa76d7a5a502c397d1c7c55da28c (patch)
tree2e728e9d435c9f7f4930fd5c3bf8627b349a0f4a /devel/freelibiberty/Makefile
parent37e17c147ae3a83f756190f4b4b0c0f37243208f (diff)
downloadports-1c2da9a09ce2fa76d7a5a502c397d1c7c55da28c.tar.gz
ports-1c2da9a09ce2fa76d7a5a502c397d1c7c55da28c.zip
o Remove CONFLICTS with libgnugetopt port by installing header files
in another location. This is required to get ddd port to build under most FreeBSD port installations o Bump PORTREVISION Approved by: marcus (portmgr), maintainer (emergency override during freeze)
Notes
Notes: svn path=/head/; revision=107806
Diffstat (limited to 'devel/freelibiberty/Makefile')
-rw-r--r--devel/freelibiberty/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/freelibiberty/Makefile b/devel/freelibiberty/Makefile
index 2a05dc239aec..9a5ad75b9bd9 100644
--- a/devel/freelibiberty/Makefile
+++ b/devel/freelibiberty/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freelibiberty
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.vocito.com/downloads/software/libiberty/ \
ftp://ftp.vocito.com/pub/vocito.com/software/libiberty/
@@ -15,15 +16,14 @@ DISTNAME= libiberty-${PORTVERSION}
MAINTAINER= ports@vocito.com
COMMENT= A freely-redistributable libiberty clone
-CONFLICTS= libgnugetopt-*
-
INSTALLS_SHLIB= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libiberty.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/libiberty.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libiberty.so.1 ${PREFIX}/lib/libiberty.so
- ${INSTALL_DATA} ${WRKSRC}/libiberty.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/getopt.h ${PREFIX}/include
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/libiberty.h ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/getopt.h ${PREFIX}/include/${PORTNAME}
.include <bsd.port.mk>