aboutsummaryrefslogtreecommitdiff
path: root/devel/fuel
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-15 10:49:20 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-15 10:49:20 +0000
commit22aa52ba0426510934381a184355452cb76601a2 (patch)
tree71324fded1992b77ad90b716622247048dd81490 /devel/fuel
parent81d3bc93d10503ee88c6fdc9ef519432f2734907 (diff)
downloadports-22aa52ba0426510934381a184355452cb76601a2.tar.gz
ports-22aa52ba0426510934381a184355452cb76601a2.zip
Add new port devel/fuel:
Fuel is a cross-platform GUI front-end to the excellent fossil SCM tool, implemented in Qt. WWW: https://code.google.com/p/fuel-scm/ PR: ports/167871 Submitted by: Hakisho Nukama <nukama at gmail.com>
Notes
Notes: svn path=/head/; revision=296656
Diffstat (limited to 'devel/fuel')
-rw-r--r--devel/fuel/Makefile35
-rw-r--r--devel/fuel/distinfo2
-rw-r--r--devel/fuel/pkg-descr4
3 files changed, 41 insertions, 0 deletions
diff --git a/devel/fuel/Makefile b/devel/fuel/Makefile
new file mode 100644
index 000000000000..0af8385b9905
--- /dev/null
+++ b/devel/fuel/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fuel
+# Date created: 2012-04-26
+# Whom: Hakisho Nukama <nukama@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fuel
+DISTVERSION= 0.9.6
+CATEGORIES= devel
+MASTER_SITES= https://fuel-scm.googlecode.com/files/
+
+MAINTAINER= nukama@gmail.com
+COMMENT= A GUI front-end to fossil SCM tool
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${LOCALBASE}/bin/fossil:${PORTSDIR}/devel/fossil
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui \
+ qmake_build moc_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+
+HAS_CONFIGURE= yes
+
+PLIST_FILES+= bin/Fuel
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Fuel ${PREFIX}/bin/Fuel
+
+.include <bsd.port.mk>
diff --git a/devel/fuel/distinfo b/devel/fuel/distinfo
new file mode 100644
index 000000000000..e3df6dca5b93
--- /dev/null
+++ b/devel/fuel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fuel-0.9.6.tar.gz) = 83b7e1f327f5c411d5f9f758fd74e9de274618fe601dea8128561186548381e2
+SIZE (fuel-0.9.6.tar.gz) = 3958347
diff --git a/devel/fuel/pkg-descr b/devel/fuel/pkg-descr
new file mode 100644
index 000000000000..ca9e383b8350
--- /dev/null
+++ b/devel/fuel/pkg-descr
@@ -0,0 +1,4 @@
+Fuel is a cross-platform GUI front-end to the excellent fossil SCM tool,
+implemented in Qt.
+
+WWW: https://code.google.com/p/fuel-scm/