aboutsummaryrefslogtreecommitdiff
path: root/devel/g-wrap
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-03-04 06:53:01 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-03-04 06:53:01 +0000
commitb71d31dc4804bfe1c7ebb6c91d4d8b89e65294af (patch)
tree7e5ddc3bd593f39beb891dea674575f23cc3591a /devel/g-wrap
parent36bec2a20efb935af8bfe7eb28c520063f55a096 (diff)
downloadports-b71d31dc4804bfe1c7ebb6c91d4d8b89e65294af.tar.gz
ports-b71d31dc4804bfe1c7ebb6c91d4d8b89e65294af.zip
- Fix the build on amd64.
- Fix the srfi extensions installation if they are already exist, install them anyway since there are no conflict in ports tree. Example, using portupgrade while upgrade and it will finding g-wrap exists then not install files as g-wrap will be uninstall when the build is done. - Bump the PORTREVISION to make sure the users to have srfi extensions back in their systems. Reported by: several, Peter Jeremy <peterjeremy@optushome.com.au> Tested by: Peter Jeremy <peterjeremy@optushome.com.au>
Notes
Notes: svn path=/head/; revision=186473
Diffstat (limited to 'devel/g-wrap')
-rw-r--r--devel/g-wrap/Makefile19
-rw-r--r--devel/g-wrap/files/patch-configure55
2 files changed, 69 insertions, 5 deletions
diff --git a/devel/g-wrap/Makefile b/devel/g-wrap/Makefile
index feffd828e19d..605ce9df4880 100644
--- a/devel/g-wrap/Makefile
+++ b/devel/g-wrap/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# Ports collection makefile for: g-wrap
# Date created: Jun 29, 2000
# Whom: Matthew Condell (mcondell@alum.mit.edu)
@@ -9,7 +8,7 @@
PORTNAME= g-wrap
PORTVERSION= 1.9.6
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel scheme
MASTER_SITES= SAVANNAH
@@ -29,9 +28,19 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= --build=x86_64-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
+.else
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|g ; \
+ s|SRFI_34=yes|SRFI_34=no|g ; s|SRFI_35=yes|SRFI_35=no|g' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|(GUILE_CFLAGS) $$(LIBFFI_CFLAGS)|(LIBFFI_CFLAGS) $$(GUILE_CFLAGS)|g'
@@ -45,4 +54,4 @@ post-install:
${PREFIX}/include/g-wrap/ffi
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/g-wrap/files/patch-configure b/devel/g-wrap/files/patch-configure
new file mode 100644
index 000000000000..533ef97a9c06
--- /dev/null
+++ b/devel/g-wrap/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig Thu Mar 1 11:20:23 2007
++++ configure Thu Mar 1 11:23:45 2007
+@@ -3860,6 +3860,52 @@
+ rm -rf conftest*
+ ;;
+
++x86_64-*freebsd*|ppc*-*freebsd*|powerpc*-*freebsd*|s390*-*freebsd*|sparc*-*freebsd*)
++ # Find out which ABI we are using.
++ echo 'int i;' > conftest.$ac_ext
++ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; then
++ case "`/usr/bin/file conftest.o`" in
++ *32-bit*)
++ case $host in
++ x86_64-*freebsd*)
++ LD="${LD-ld} -m elf_i386_fbsd"
++ ;;
++ ppc64-*freebsd*|powerpc64-*freebsd*)
++ LD="${LD-ld} -m elf32ppc_fbsd"
++ ;;
++ s390x-*freebsd*)
++ LD="${LD-ld} -m elf_s390"
++ ;;
++ sparc64-*freebsd*)
++ LD="${LD-ld} -m elf32_sparc"
++ ;;
++ esac
++ ;;
++ *64-bit*)
++ case $host in
++ x86_64-*freebsd*)
++ LD="${LD-ld} -m elf_x86_64_fbsd"
++ ;;
++ ppc*-*freebsd*|powerpc*-*freebsd*)
++ LD="${LD-ld} -m elf64ppc"
++ ;;
++ s390*-*freebsd*)
++ LD="${LD-ld} -m elf64_s390"
++ ;;
++ sparc*-*freebsd*)
++ LD="${LD-ld} -m elf64_sparc_fbsd"
++ ;;
++ esac
++ ;;
++ esac
++ fi
++ rm -rf conftest*
++ ;;
++
+ x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*|s390*-*linux*|sparc*-*linux*)
+ # Find out which ABI we are using.
+ echo 'int i;' > conftest.$ac_ext