aboutsummaryrefslogtreecommitdiff
path: root/devel/gauche-sdl/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-02 16:56:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-02 16:56:35 +0000
commit782788ada7325bdc66508973d54afc117a1b447e (patch)
tree0ed58136f68af106340a0b1f44c8d4423c37af9e /devel/gauche-sdl/Makefile
parent13dccf91cd14b6dba6fadb999f271898bc8cd421 (diff)
downloadports-782788ada7325bdc66508973d54afc117a1b447e.tar.gz
ports-782788ada7325bdc66508973d54afc117a1b447e.zip
Add gauche-sdl, SDL bindings for the gauche scheme environment
PR: ports/62892 Submitted by: Erik Greenwald <erik@smluc.org>
Notes
Notes: svn path=/head/; revision=102745
Diffstat (limited to 'devel/gauche-sdl/Makefile')
-rw-r--r--devel/gauche-sdl/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/gauche-sdl/Makefile b/devel/gauche-sdl/Makefile
new file mode 100644
index 000000000000..d1d391061d58
--- /dev/null
+++ b/devel/gauche-sdl/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gauche
+# Date created: 9 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gauche-sdl
+PORTVERSION= 0.5.1
+CATEGORIES= devel scheme
+MASTER_SITES= http://www.michaelvess.com/text/code/
+DISTNAME= ${PORTFAKENAME}-${PORTVERSION}
+
+MAINTAINER= erik@smluc.org
+COMMENT= Scheme script interpreter with multibyte character handling
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+
+PLIST_SUB= GAUCHE_VERSION="`gauche-config -V`"\
+ TARGET="${CONFIGURE_TARGET}"
+WRKSRC= ${WRKDIR}/${PORTFAKENAME}
+PORTFAKENAME= Gauche-sdl
+USE_SDL= image mixer sdl ttf
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+.for DIR in . image mixer ttf
+ ${REINPLACE_CMD} \
+ -e "s|^CFLAGS .*|& `${SDL_CONFIG} --cflags`|"\
+ -e "s|-lSDL|`${SDL_CONFIG} --libs`|"\
+ ${WRKSRC}/src/${DIR}/Makefile.in
+.endfor
+ ${REINPLACE_CMD} \
+ -e "s|SDL/SDL|SDL|g"\
+ -e "s|%%SDL_CFLAGS%%|`${SDL_CONFIG} --cflags`|"\
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>