aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-12 02:03:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-12 02:03:38 +0000
commit8d1b2a90ccf642a2784c97fc3202afc478fbc23f (patch)
treee458326472028363391f7321597c285763a5e141 /devel/gconf2
parent3c46ee80e09d412db511fbe3102e78f32d1d1e0c (diff)
downloadports-8d1b2a90ccf642a2784c97fc3202afc478fbc23f.tar.gz
ports-8d1b2a90ccf642a2784c97fc3202afc478fbc23f.zip
Fix GConf on bigendian platforms (e.g. sparc64). Thanks to
Koop Mast <kwm@rainbow-runner.nl> for providing access to the hardware needed for debugging and testing.
Notes
Notes: svn path=/head/; revision=111320
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile1
-rw-r--r--devel/gconf2/files/patch-backends_markup-tree.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 589207ceb74b..f6b71fcd727e 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gconf2
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/GConf/2.6
diff --git a/devel/gconf2/files/patch-backends_markup-tree.c b/devel/gconf2/files/patch-backends_markup-tree.c
new file mode 100644
index 000000000000..7cf4bf192703
--- /dev/null
+++ b/devel/gconf2/files/patch-backends_markup-tree.c
@@ -0,0 +1,11 @@
+--- backends/markup-tree.c.orig Fri Jun 11 22:01:00 2004
++++ backends/markup-tree.c Fri Jun 11 22:01:12 2004
+@@ -3070,7 +3070,7 @@
+ ParseInfo info;
+ char *filename;
+ char *text;
+- int length;
++ gsize length;
+
+ filename = markup_dir_build_path (root, TRUE, parse_subtree);
+