aboutsummaryrefslogtreecommitdiff
path: root/devel/gdcm/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-01-18 08:32:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-01-18 08:32:13 +0000
commit8ec88c6141a75cea15eafe0f24f761a991017488 (patch)
treef14b63e091ac443d53f6149b867bcc9bdae237b1 /devel/gdcm/Makefile
parent3a1c1eb01100db94022f479855eff5df069e3483 (diff)
downloadports-8ec88c6141a75cea15eafe0f24f761a991017488.tar.gz
ports-8ec88c6141a75cea15eafe0f24f761a991017488.zip
- Use system expat2, zlib and openjpeg
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=289403
Diffstat (limited to 'devel/gdcm/Makefile')
-rw-r--r--devel/gdcm/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index 8d641bff38a3..cfdd5d9c07c2 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -6,14 +6,15 @@
PORTNAME= gdcm
PORTVERSION= ${GDCM_MAJ}.${GDCM_MIN}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF/gdcm/gdcm%202.x/GDCM%20${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Grassroots DICOM library
-LIB_DEPENDS= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+LIB_DEPENDS= openjpeg.2:${PORTSDIR}/graphics/openjpeg \
+ expat.6:${PORTSDIR}/textproc/expat2
OPTIONS= VTK "Build the VTK bindings" off
@@ -22,8 +23,12 @@ USE_CMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= ${PREFIX}/lib \
${PREFIX}/lib/gdcm-${GDCM_MAJ}
+CFLAGS+= -I${LOCALBASE}/include
CMAKE_ARGS+= -DGDCM_PDF_DOCUMENTATION:BOOL=NO \
- -DGDCM_USE_SYSTEM_OPENSSL:BOOL=YES
+ -DGDCM_USE_SYSTEM_OPENSSL:BOOL=YES \
+ -DGDCM_USE_SYSTEM_EXPAT:BOOL=YES \
+ -DGDCM_USE_SYSTEM_OPENJPEG:BOOL=YES \
+ -DGDCM_USE_SYSTEM_ZLIB:BOOL=YES
.include <bsd.port.options.mk>