aboutsummaryrefslogtreecommitdiff
path: root/devel/gdcm
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-07-07 07:18:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-07-07 07:18:19 +0000
commit064d381b73b6f8d291300e43d2f114aceaab7aac (patch)
treef106604069032b3ecc89b3bbcc4865c7212fa504 /devel/gdcm
parentd3dddab16273e64a8de2e9de8adacb10dadc3baf (diff)
downloadports-064d381b73b6f8d291300e43d2f114aceaab7aac.tar.gz
ports-064d381b73b6f8d291300e43d2f114aceaab7aac.zip
- fix runtime path of DATADIR in source code
- bump PORTREVISION
Notes
Notes: svn path=/head/; revision=277214
Diffstat (limited to 'devel/gdcm')
-rw-r--r--devel/gdcm/Makefile2
-rw-r--r--devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index d670185b5df5..b55de107142d 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gdcm
PORTVERSION= ${GDCM_MAJ}.${GDCM_MIN}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/gdcm/gdcm%202.x/GDCM%20${PORTVERSION}
diff --git a/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx b/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx
new file mode 100644
index 000000000000..eccf73102831
--- /dev/null
+++ b/devel/gdcm/files/patch-Source-DataDictionary_gdcmGlobal.cxx
@@ -0,0 +1,11 @@
+--- Source/DataDictionary/gdcmGlobal.cxx.orig 2011-07-07 09:11:27.000000000 +0200
++++ Source/DataDictionary/gdcmGlobal.cxx 2011-07-07 09:11:56.000000000 +0200
+@@ -45,7 +45,7 @@
+ void LoadDefaultPaths()
+ {
+ assert( RessourcePaths.empty() );
+- const char filename2[] = GDCM_CMAKE_INSTALL_PREFIX "/" GDCM_INSTALL_DATA_DIR "/XML/";
++ const char filename2[] = GDCM_INSTALL_DATA_DIR "/XML/";
+ RessourcePaths.push_back( filename2 );
+ const char *curprocfn = System::GetCurrentProcessFileName();
+ if( curprocfn )