aboutsummaryrefslogtreecommitdiff
path: root/devel/gengetopt
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-10-28 02:48:45 +0000
committerWill Andrews <will@FreeBSD.org>2000-10-28 02:48:45 +0000
commitffefb338d5f04dfe46ea5fea8063ae2991d1be36 (patch)
treebcc0206d47770b40bc1584ba01dd8e931d965369 /devel/gengetopt
parent2619a7ad33a94345a44af2a127e4c82fe369235d (diff)
downloadports-ffefb338d5f04dfe46ea5fea8063ae2991d1be36.tar.gz
ports-ffefb338d5f04dfe46ea5fea8063ae2991d1be36.zip
Add gengetopt 2.1, a program that will generate a C function that uses
getopt_long function to parse the command line options, validate them and fill a struct. PR: 21922 Submitted by: Cyrille Lefevre <clefevre@citeweb.net>
Notes
Notes: svn path=/head/; revision=34334
Diffstat (limited to 'devel/gengetopt')
-rw-r--r--devel/gengetopt/Makefile20
-rw-r--r--devel/gengetopt/distinfo1
-rw-r--r--devel/gengetopt/pkg-comment1
-rw-r--r--devel/gengetopt/pkg-descr13
-rw-r--r--devel/gengetopt/pkg-plist26
5 files changed, 61 insertions, 0 deletions
diff --git a/devel/gengetopt/Makefile b/devel/gengetopt/Makefile
new file mode 100644
index 000000000000..914030717bb4
--- /dev/null
+++ b/devel/gengetopt/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: gengetopt
+# Date created: 12 October 2000
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gengetopt
+PORTVERSION= 2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= gengetopt
+
+MAINTAINER= ports@freebsd.org
+
+GNU_CONFIGURE= yes
+
+MAN1= gengetopt.1
+
+.include <bsd.port.mk>
diff --git a/devel/gengetopt/distinfo b/devel/gengetopt/distinfo
new file mode 100644
index 000000000000..962bfe2ff8f6
--- /dev/null
+++ b/devel/gengetopt/distinfo
@@ -0,0 +1 @@
+MD5 (gengetopt-2.1.tar.gz) = 6281f425c0f24536bdbe340450481ec2
diff --git a/devel/gengetopt/pkg-comment b/devel/gengetopt/pkg-comment
new file mode 100644
index 000000000000..76b1cf7d2587
--- /dev/null
+++ b/devel/gengetopt/pkg-comment
@@ -0,0 +1 @@
+The GNU Gengetopt generates a C function which parses command line arguments.
diff --git a/devel/gengetopt/pkg-descr b/devel/gengetopt/pkg-descr
new file mode 100644
index 000000000000..6c698b226423
--- /dev/null
+++ b/devel/gengetopt/pkg-descr
@@ -0,0 +1,13 @@
+This program generate a C function that uses getopt_long function to parse
+the command line options, validate them and fill a struct.
+
+Thus your program can now handle options such as:
+
+myprog --input foo.c -o foo.o --no-tabs -i 100 *.class
+
+And both long options (those that start with --) and short options (start
+with - and consist of only one character) can be handled. For standards
+about short and long options you may want to take a look at the GNU Coding
+Standards.
+
+WWW: http://www.gnu.org/software/gengetopt/gengetopt.html
diff --git a/devel/gengetopt/pkg-plist b/devel/gengetopt/pkg-plist
new file mode 100644
index 000000000000..1a1e8e4970d0
--- /dev/null
+++ b/devel/gengetopt/pkg-plist
@@ -0,0 +1,26 @@
+bin/gengetopt
+share/doc/gengetopt/examples/sample1.ggo
+share/doc/gengetopt/examples/sample2.ggo
+share/doc/gengetopt/examples/main1.cc
+share/doc/gengetopt/examples/main2.c
+share/doc/gengetopt/examples/cmdline1.c
+share/doc/gengetopt/examples/cmdline1.h
+share/doc/gengetopt/examples/cmdline2.c
+share/doc/gengetopt/examples/cmdline2.h
+share/doc/gengetopt/gengetopt.html
+share/doc/gengetopt/cmdline1.c.html
+share/doc/gengetopt/man_getopt.html
+share/doc/gengetopt/no_getopt_long.txt
+share/doc/gengetopt/ChangeLog
+share/doc/gengetopt/COPYING
+share/doc/gengetopt/NEWS
+share/doc/gengetopt/THANKS
+share/doc/gengetopt/INSTALL
+share/doc/gengetopt/README
+share/doc/gengetopt/LICENSE
+share/gengetopt/getopt.h
+share/gengetopt/getopt.c
+share/gengetopt/getopt1.c
+@dirrm share/doc/gengetopt/examples
+@dirrm share/doc/gengetopt
+@dirrm share/gengetopt