aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2016-12-01 15:24:06 +0000
committerRenato Botelho <garga@FreeBSD.org>2016-12-01 15:24:06 +0000
commit58db8235a298235844f568af1feb00afde50aded (patch)
treed8e3439af600efc3423d0f92e17733f44b1d4875 /devel/git
parent3e4e8900d7c49e7b9221569d606bc650e72716c2 (diff)
downloadports-58db8235a298235844f568af1feb00afde50aded.tar.gz
ports-58db8235a298235844f568af1feb00afde50aded.zip
- Fix build with PERL and non-default LOCALBASE [1]
- Fix build with DEVELOPER=yes [2] - Do not install ZSH completion [3] - ZSH installs a better version itself - Fix PLIST - Bump PORTREVISION PR: 213494 [1] 214009 [2] 214870 [3] (based on) Submitted by: John Hein <z7dr6ut7gs@snkmail.com> [1] [3] Michael Zuo <muh.muhten@gmail.com> Sponsored by: Rubicon Communications (Netgate)
Notes
Notes: svn path=/head/; revision=427505
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile14
-rw-r--r--devel/git/pkg-plist7
2 files changed, 5 insertions, 16 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 5e9a9a34dead..6cc25548dfa7 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
DISTVERSION= 2.11.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -27,6 +28,7 @@ GNU_CONFIGURE= yes
USES= gmake shebangfix ssl tar:xz
CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS+= DEVELOPER_CFLAGS=
MAKE_ENV+= V=1
USE_RC_SUBR= git_daemon
SHEBANG_FILES= *.perl */*.perl */*/*.perl */*.pl */*/*.pl */*/*/*.pl \
@@ -56,7 +58,7 @@ NLS_USES= gettext
NLS_MAKE_ARGS_OFF= NO_GETTEXT=yes
PERL_USES= perl5
-PERL_MAKE_ENV= PERL_PATH=${PERL}
+PERL_CONFIGURE_WITH= perl=${PERL}
PERL_BUILD_DEPENDS= p5-Error>=0:lang/p5-Error
PERL_RUN_DEPENDS= p5-Error>=0:lang/p5-Error
PERL_MAKE_ARGS_OFF= NO_PERL=1
@@ -198,21 +200,15 @@ post-install-CONTRIB-on:
${MAKE_CMD} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} install install-doc
# Symlink the completions from the contrib directory to where they
# will be useful
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d \
- ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
@${LN} -s ../../share/git-core/contrib/completion/git-completion.bash \
${STAGEDIR}${PREFIX}/etc/bash_completion.d/git.sh
- @${LN} -s ../../../share/git-core/contrib/completion/git-completion.zsh \
- ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_git
post-install-CONTRIB-off:
# Install the contrib completions anyway
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d \
- ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
@${INSTALL_SCRIPT} ${WRKSRC}/contrib/completion/git-completion.bash \
${STAGEDIR}${PREFIX}/etc/bash_completion.d/git.sh
- @${INSTALL_SCRIPT} ${WRKSRC}/contrib/completion/git-completion.zsh \
- ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_git
post-install-P4-on:
${INSTALL_SCRIPT} ${WRKSRC}/git-p4.py ${STAGEDIR}${PREFIX}/bin/
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 88655aacfc33..3caa2f60eefc 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -83,8 +83,6 @@ libexec/git-core/git-grep
libexec/git-core/git-hash-object
libexec/git-core/git-help
libexec/git-core/git-http-backend
-%%CURL%%libexec/git-core/git-http-fetch
-%%CURL%%libexec/git-core/git-http-push
libexec/git-core/git-imap-send
libexec/git-core/git-index-pack
libexec/git-core/git-init
@@ -137,10 +135,6 @@ libexec/git-core/git-relink
libexec/git-core/git-remote
libexec/git-core/git-remote-ext
libexec/git-core/git-remote-fd
-%%CURL%%libexec/git-core/git-remote-ftp
-%%CURL%%libexec/git-core/git-remote-ftps
-%%CURL%%libexec/git-core/git-remote-http
-%%CURL%%libexec/git-core/git-remote-https
libexec/git-core/git-remote-testsvn
libexec/git-core/git-repack
libexec/git-core/git-replace
@@ -1455,5 +1449,4 @@ share/git-core/templates/info/exclude
%%NLS%%share/locale/sv/LC_MESSAGES/git.mo
%%NLS%%share/locale/vi/LC_MESSAGES/git.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/git.mo
-share/zsh/site-functions/_git
@dir share/git-core/templates/branches