aboutsummaryrefslogtreecommitdiff
path: root/devel/global
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-09-02 09:39:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-09-02 09:39:57 +0000
commitd17387a9971b4e9a771768fc0e37d416071044e6 (patch)
treee5b3492c8ff432078c3607ca8cd667d2961aed75 /devel/global
parent14605107bd54ab780d951f0fcf5a953db57a220f (diff)
downloadports-d17387a9971b4e9a771768fc0e37d416071044e6.tar.gz
ports-d17387a9971b4e9a771768fc0e37d416071044e6.zip
Update to 4.8
PR: 71277 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=117910
Diffstat (limited to 'devel/global')
-rw-r--r--devel/global/Makefile7
-rw-r--r--devel/global/distinfo4
-rw-r--r--devel/global/files/patch-aa19
-rw-r--r--devel/global/files/patch-htags::htags.c-fix-d27
-rw-r--r--devel/global/pkg-plist10
5 files changed, 44 insertions, 23 deletions
diff --git a/devel/global/Makefile b/devel/global/Makefile
index 43ad6d2d4a8c..4f0cc92641d4 100644
--- a/devel/global/Makefile
+++ b/devel/global/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= global
-PORTVERSION= 4.6.1
+PORTVERSION= 4.8
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,13 +16,16 @@ COMMENT= A source code tag system
GNU_CONFIGURE= yes
USE_PERL5= yes
+USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= gctags.1 global.1 gozilla.1 gtags.1 htags.1
INFO= global
+post-patch:
+ ${REINPLACE_CMD} -E 's,^(gtags_DATA = )AUTHORS .* THANKS( \\$$),\1\2,' ${WRKSRC}/Makefile.in
+
post-install:
- install-info ${PREFIX}/info/global.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/global
.for file in AUTHORS COPYING ChangeLog FAQ INSTALL LICENSE NEWS README \
diff --git a/devel/global/distinfo b/devel/global/distinfo
index 39e9529236b5..beb30c27d1d8 100644
--- a/devel/global/distinfo
+++ b/devel/global/distinfo
@@ -1,2 +1,2 @@
-MD5 (global-4.6.1.tar.gz) = 6430ca736a74a734b10201d28fe0a64a
-SIZE (global-4.6.1.tar.gz) = 504379
+MD5 (global-4.8.tar.gz) = 1c1c80f3bd6bd8eea16124fa0a8006bf
+SIZE (global-4.8.tar.gz) = 591811
diff --git a/devel/global/files/patch-aa b/devel/global/files/patch-aa
index 94997fde18a5..e69de29bb2d1 100644
--- a/devel/global/files/patch-aa
+++ b/devel/global/files/patch-aa
@@ -1,19 +0,0 @@
---- doc/Makefile.in.orig Fri Oct 3 11:16:01 2003
-+++ doc/Makefile.in Mon Oct 20 13:53:50 2003
-@@ -358,15 +358,7 @@
- done; \
- done
- @$(POST_INSTALL)
-- @if (install-info --version && \
-- install-info --version | grep -i -v debian) >/dev/null 2>&1; then \
-- list='$(INFO_DEPS)'; \
-- for file in $$list; do \
-- relfile=`echo "$$file" | sed 's|^.*/||'`; \
-- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile";\
-- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$relfile || :;\
-- done; \
-- else : ; fi
-+
- install-man:
-
- installcheck-am:
diff --git a/devel/global/files/patch-htags::htags.c-fix-d b/devel/global/files/patch-htags::htags.c-fix-d
new file mode 100644
index 000000000000..2dd66ef8fa79
--- /dev/null
+++ b/devel/global/files/patch-htags::htags.c-fix-d
@@ -0,0 +1,27 @@
+--- htags/htags.c 2004/09/01 14:44:33 1.14
++++ htags/htags.c 2004/09/01 21:58:28 1.15
+@@ -61,7 +61,6 @@
+ char *save_config;
+ char *save_argv;
+
+-char rootpath[MAXPATHLEN];
+ char cwdpath[MAXPATHLEN];
+ char dbpath[MAXPATHLEN];
+ char distpath[MAXPATHLEN];
+@@ -1481,11 +1480,14 @@
+ strbuf_close(sb);
+ }
+ /*
+- * get root, cwd and dbpath.
++ * get dbpath.
+ */
+- getdbpath(cwdpath, rootpath, dbpath, 0);
++ if (!getcwd(cwdpath, sizeof(cwdpath)))
++ die("cannot get current directory.");
+ if (arg_dbpath[0])
+ strlimcpy(dbpath, arg_dbpath, sizeof(dbpath));
++ else
++ strlimcpy(dbpath, cwdpath, sizeof(cwdpath));
+
+ if (cflag && !usable("gzip")) {
+ warning("'gzip' command not found. -c option ignored.");
diff --git a/devel/global/pkg-plist b/devel/global/pkg-plist
index d759e5da5610..a11e1f8b96f2 100644
--- a/devel/global/pkg-plist
+++ b/devel/global/pkg-plist
@@ -3,6 +3,7 @@ bin/global
bin/gozilla
bin/gtags
bin/htags
+bin/htags.pl
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
@@ -12,4 +13,13 @@ bin/htags
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/THANKS
+share/gtags/globash.rc
+share/gtags/gtags.conf
+share/gtags/gtags.el
+share/gtags/gtags.pl
+share/gtags/gtags.vim
+share/gtags/nvi-1.79-gtags.diff
+share/gtags/bless.sh.tmpl
+share/gtags/global.cgi.tmpl
+@dirrm share/gtags
%%PORTDOCS%%@dirrm %%DOCSDIR%%