aboutsummaryrefslogtreecommitdiff
path: root/devel/gmake
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-03 07:51:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-03 07:51:20 +0000
commit6dbb691ed2c33b68872d270751f0e87ef0da351b (patch)
treea9c5705f6ee25dfceb5f7090369fed34437d7084 /devel/gmake
parenta700e0c2b58e6597c87cc5e2ad81a6151ab39fe6 (diff)
downloadports-6dbb691ed2c33b68872d270751f0e87ef0da351b.tar.gz
ports-6dbb691ed2c33b68872d270751f0e87ef0da351b.zip
Use options helpers to reduce inclusions of bsd.port.options.mk
Remove useless check on USE_GMAKE
Notes
Notes: svn path=/head/; revision=342391
Diffstat (limited to 'devel/gmake')
-rw-r--r--devel/gmake/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index 5b604b84c859..4886da4f1ed1 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -22,26 +22,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-prefix=g
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG} \
+ --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_ENABLE= nls
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext iconv
-CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
- --with-libintl-prefix=${LOCALBASE}
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
INFO= make
-.ifdef USE_GMAKE
-.error You have `USE_GMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/no-print-dir/s/@itemx/@item/' \
${WRKSRC}/doc/make.texi