aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-common
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-12 22:28:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-12 22:28:22 +0000
commit4c493f2ca2136b5fa2034127165f29152f33532c (patch)
treefea1cf139a6f966b8e85c38b75b5d30423ccdce2 /devel/gnome-common
parent73e11e25e799f303558bb7f7ff5ccbb4e89832f1 (diff)
downloadports-4c493f2ca2136b5fa2034127165f29152f33532c.tar.gz
ports-4c493f2ca2136b5fa2034127165f29152f33532c.zip
Add gnomecommon, a collection common GNOME 2.0 automake macros.
Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=57643
Diffstat (limited to 'devel/gnome-common')
-rw-r--r--devel/gnome-common/Makefile24
-rw-r--r--devel/gnome-common/distinfo1
-rw-r--r--devel/gnome-common/pkg-comment1
-rw-r--r--devel/gnome-common/pkg-descr4
-rw-r--r--devel/gnome-common/pkg-plist42
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/gnome-common/Makefile b/devel/gnome-common/Makefile
new file mode 100644
index 000000000000..fb44b1cdd27c
--- /dev/null
+++ b/devel/gnome-common/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gnomecommon
+# Date created: 04 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomecommon
+PORTVERSION= 1.2.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DISTNAME= gnome-common-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/devel/gnome-common/distinfo b/devel/gnome-common/distinfo
new file mode 100644
index 000000000000..eb637c49fc75
--- /dev/null
+++ b/devel/gnome-common/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gnome-common-1.2.4.tar.bz2) = 4b430c6443860e01e4bd89cadf82649b
diff --git a/devel/gnome-common/pkg-comment b/devel/gnome-common/pkg-comment
new file mode 100644
index 000000000000..6dc7d88bd628
--- /dev/null
+++ b/devel/gnome-common/pkg-comment
@@ -0,0 +1 @@
+Common automake macros for GNOME and GOME 2.0
diff --git a/devel/gnome-common/pkg-descr b/devel/gnome-common/pkg-descr
new file mode 100644
index 000000000000..4cf03f1e9171
--- /dev/null
+++ b/devel/gnome-common/pkg-descr
@@ -0,0 +1,4 @@
+This is a collection of automake macros used for developing new GNOME
+or GNOME 2.0 applications.
+
+WWW: http://www.gnome.org/
diff --git a/devel/gnome-common/pkg-plist b/devel/gnome-common/pkg-plist
new file mode 100644
index 000000000000..f0c5c64dcc94
--- /dev/null
+++ b/devel/gnome-common/pkg-plist
@@ -0,0 +1,42 @@
+bin/gnome-autogen.sh
+share/aclocal/gnome-macros/aclocal-include.m4
+share/aclocal/gnome-macros/autogen.sh
+share/aclocal/gnome-macros/compiler-flags.m4
+share/aclocal/gnome-macros/curses.m4
+share/aclocal/gnome-macros/gnome-bonobo-check.m4
+share/aclocal/gnome-macros/gnome-common.m4
+share/aclocal/gnome-macros/gnome-fileutils.m4
+share/aclocal/gnome-macros/gnome-gettext.m4
+share/aclocal/gnome-macros/gnome-ghttp-check.m4
+share/aclocal/gnome-macros/gnome-gnorba-check.m4
+share/aclocal/gnome-macros/gnome-guile-checks.m4
+share/aclocal/gnome-macros/gnome-libgtop-check.m4
+share/aclocal/gnome-macros/gnome-macros.dep
+share/aclocal/gnome-macros/gnome-objc-checks.m4
+share/aclocal/gnome-macros/gnome-orbit-check.m4
+share/aclocal/gnome-macros/gnome-print-check.m4
+share/aclocal/gnome-macros/gnome-pthread-check.m4
+share/aclocal/gnome-macros/gnome-support.m4
+share/aclocal/gnome-macros/gnome-undelfs.m4
+share/aclocal/gnome-macros/gnome-vfs.m4
+share/aclocal/gnome-macros/gnome-x-checks.m4
+share/aclocal/gnome-macros/gnome-xml-check.m4
+share/aclocal/gnome-macros/gnome.m4
+share/aclocal/gnome-macros/gperf-check.m4
+share/aclocal/gnome-macros/linger.m4
+share/aclocal/gnome-macros/need-declaration.m4
+share/aclocal/gnome2-macros/autogen.sh
+share/aclocal/gnome2-macros/check-utmp.m4
+share/aclocal/gnome2-macros/compiler-flags.m4
+share/aclocal/gnome2-macros/curses.m4
+share/aclocal/gnome2-macros/gnome-common.m4
+share/aclocal/gnome2-macros/gnome-cxx-check.m4
+share/aclocal/gnome2-macros/gnome-gettext.m4
+share/aclocal/gnome2-macros/gnome-pkgconfig.m4
+share/aclocal/gnome2-macros/gnome-platform.m4
+share/aclocal/gnome2-macros/gnome-pthread-check.m4
+share/aclocal/gnome2-macros/gnome-x-checks.m4
+share/aclocal/gnome2-macros/gnome2-macros.dep
+share/aclocal/gnome2-macros/linger.m4
+@dirrm share/aclocal/gnome2-macros
+@dirrm share/aclocal/gnome-macros