aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /devel/gnome-vfs
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Presenting GNOME 2.16.1 for FreeBSD. This release represents a massive
amount of work by the FreeBSD GNOME Team and our testers. On top of the usual GNOME update, we have taken this opportunity to move GNOME from X11BASE to LOCALBASE. This means roughly 600 ports NOT part of the GNOME Desktop also need to be changed. The bulk of the move was carried out by ahze, mezz, and pav, but it would not have been possible without cooperation from the FreeBSD KDE team who worked with us to make sure GNOME and KDE can still coexist happily. We would also like to send a shout out to kris and pointyhat for putting up with multiple test runs until we got something that was solid. Back to GNOME 2.16. This release brings a huge amount of new functionality to FreeBSD. The standard release notes can be read at http://www.gnome.org/start/2.16/ . But on top of what you will read there, jylefort and marcus have completed work on a port of HAL to FreeBSD. This will allow FreeBSD to take advantage of closer hardware interaction such as auto-mounting CD-ROMs, USB drives, and music players; auto-playing audio CDs; and managing laptop power consumption. But where would this all be without our loyal testers and contributors? Therefore, the FreeBSD GNOME team would like to thank the following users: Phillip Neumann <pneumann@gmail.com> tmclaugh mux Yuri Pankov <yuri.pankov@gmail.com> chinsan Thomas <freebsdlists@bsdunix.ch> Brian Gruber <knightbg@yahoo.com> Franz Klammer <klammer@webonaut.com> Dominique Goncalves <dominique.goncalves@gmail.com> Pascal Hofstee <caelian@gmail.com> Yasuda Keisuke <kysd@po.harenet.ne.jp> backyard <backyard1454-bsd@yahoo.com> Andris Raugulis <endrju@null.lv> <endrju@null.lv> Eric L. Chen <d9364104@mail.nchu.edu.tw> Pawel Worach <pawel.worach@gmail.com> QuiRK on #freebsd-gnome Shane Bell <decept0@gmail.com> luigi sajd on #freebsd-gnome sat Chris Coleman <chrisc@vmunix.com> kaeru on #freebsd-gnome crsd_ via irc.freenode.org/#FreeBSD-GNOME Joel Diaz <joeldiaz@mac.com> Enjoy! Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175253
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile27
-rw-r--r--devel/gnome-vfs/distinfo6
-rw-r--r--devel/gnome-vfs/files/patch-Makefile.in8
-rw-r--r--devel/gnome-vfs/files/patch-configure26
-rw-r--r--devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in6
-rw-r--r--devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in6
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c35
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-monitor.c131
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-volume-ops.c10
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c2
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h17
-rw-r--r--devel/gnome-vfs/files/patch-modules_file-method-acl.c11
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in8
-rw-r--r--devel/gnome-vfs/pkg-install.in8
-rw-r--r--devel/gnome-vfs/pkg-plist60
15 files changed, 169 insertions, 192 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index dd49c88511eb..7e5ce1c881f2 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -3,11 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/gnome-vfs/Makefile,v 1.160 2006/10/07 15:04:44 marcus Exp $
#
PORTNAME= gnome-vfs
-PORTVERSION= 2.14.2
-PORTREVISION?= 3
+PORTVERSION= 2.16.1
+PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -17,6 +18,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Virtual File System
+LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
+
USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
@@ -25,15 +28,18 @@ RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomemimedata gconf2 \
libbonobo ltverhack referencehack
USE_AUTOTOOLS= libtool:15
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-openssl \
--disable-gnutls \
- --disable-howl
+ --disable-howl \
+ --enable-hal \
+ --with-hal-mount=/sbin/mount \
+ --with-hal-umount=/sbin/umount
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -76,11 +82,16 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|/usr/X11R6|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/libgnomevfs/xdgmime.c
- @${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/libgnomevfs/xdgmime.c \
+ ${WRKSRC}/libgnomevfs/gnome-vfs-hal-mounts.c
+ @${REINPLACE_CMD} -e 's|-lacl||g' \
+ ${WRKSRC}/configure
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
- @${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
pre-configure:
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index c4d97b903183..6552ad8718cd 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-vfs-2.14.2.tar.bz2) = b657e31974d6981adf9b2c4db981f62c
-SHA256 (gnome2/gnome-vfs-2.14.2.tar.bz2) = 15da9d174d2373826a6921c8af2aac18aa64c6d93ac201903c9fb432e142bba7
-SIZE (gnome2/gnome-vfs-2.14.2.tar.bz2) = 1816194
+MD5 (gnome2/gnome-vfs-2.16.1.tar.bz2) = 2d9f7b01496ecc227015bc7a08fb798f
+SHA256 (gnome2/gnome-vfs-2.16.1.tar.bz2) = 8e6aaa1fb1fcf682484b27bbdf4335234752868ef3bc84ea1102a6ebf0d89067
+SIZE (gnome2/gnome-vfs-2.16.1.tar.bz2) = 1893290
diff --git a/devel/gnome-vfs/files/patch-Makefile.in b/devel/gnome-vfs/files/patch-Makefile.in
index 8c0d2a13160c..7213df2fa7e0 100644
--- a/devel/gnome-vfs/files/patch-Makefile.in
+++ b/devel/gnome-vfs/files/patch-Makefile.in
@@ -1,10 +1,10 @@
---- Makefile.in.orig Tue Nov 30 02:05:26 2004
-+++ Makefile.in Tue Nov 30 02:05:34 2004
-@@ -230,7 +230,6 @@
+--- Makefile.in.orig Tue Jul 11 09:30:02 2006
++++ Makefile.in Tue Jul 11 09:30:32 2006
+@@ -352,7 +352,6 @@
devel-docs \
doc \
programs \
- test \
- monikers \
po
+ EXTRA_DIST = \
diff --git a/devel/gnome-vfs/files/patch-configure b/devel/gnome-vfs/files/patch-configure
index 8835cb06b0c1..1bef1ebaca77 100644
--- a/devel/gnome-vfs/files/patch-configure
+++ b/devel/gnome-vfs/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed May 17 11:33:28 2006
-+++ configure Wed May 17 21:44:26 2006
-@@ -23540,6 +23540,8 @@
+--- configure.orig Tue Jul 11 09:30:54 2006
++++ configure Tue Jul 11 09:31:51 2006
+@@ -23202,6 +23202,8 @@
if eval "test \"\${$as_ac_var+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -9,7 +9,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -23622,6 +23624,7 @@
+@@ -23283,6 +23285,7 @@
fi
rm -f conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
@@ -17,7 +17,7 @@
fi
echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
-@@ -23629,6 +23632,7 @@
+@@ -23290,6 +23293,7 @@
cat >>confdefs.h <<_ACEOF
#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
_ACEOF
@@ -25,7 +25,7 @@
have_ngettext=yes
else
echo "$as_me:$LINENO: checking for ngettext in -lintl" >&5
-@@ -25026,7 +25030,7 @@
+@@ -24669,7 +24673,7 @@
@@ -34,7 +34,7 @@
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -33396,7 +33400,7 @@
+@@ -32940,7 +32944,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -43,7 +43,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -33694,7 +33698,7 @@
+@@ -33236,7 +33240,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -52,7 +52,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -37536,6 +37540,9 @@
+@@ -38765,6 +38769,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@@ -62,7 +62,7 @@
#include <sys/statfs.h>
#include <sys/fstyp.h>
_ACEOF
-@@ -37577,6 +37584,9 @@
+@@ -38806,6 +38813,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@@ -72,9 +72,9 @@
#include <sys/statfs.h>
#include <sys/vmount.h>
_ACEOF
-@@ -39016,6 +39026,7 @@
- s,@ORBIT_IDL@,$ORBIT_IDL,;t t
- s,@BONOBO_IDLDIR@,$BONOBO_IDLDIR,;t t
+@@ -40026,6 +40036,7 @@
+ s,@TEST_CFLAGS@,$TEST_CFLAGS,;t t
+ s,@TEST_LIBS@,$TEST_LIBS,;t t
s,@WARN_CFLAGS@,$WARN_CFLAGS,;t t
+s,@PTHREAD_LIB@,$BSD_PTHREAD_LIBS,;t t
s,@GETTEXT_PACKAGE@,$GETTEXT_PACKAGE,;t t
diff --git a/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in b/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
index 088433c51a28..eb0f4592025e 100644
--- a/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
+++ b/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
@@ -1,9 +1,9 @@
---- gnome-vfs-2.0.pc.in.orig Wed Sep 14 05:30:25 2005
-+++ gnome-vfs-2.0.pc.in Mon Oct 3 12:00:02 2005
+--- gnome-vfs-2.0.pc.in.orig Tue Jul 11 07:31:58 2006
++++ gnome-vfs-2.0.pc.in Tue Jul 11 09:33:47 2006
@@ -8,5 +8,5 @@
Description: The GNOME virtual file-system libraries
Version: @VERSION@
- Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
+ Requires: gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
-Libs: -L${libdir} -lgnomevfs-2
+Libs: -L${libdir} -lgnomevfs-2 @PTHREAD_LIB@
Cflags: -I${includedir}/gnome-vfs-2.0 -I${libdir}/gnome-vfs-2.0/include
diff --git a/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in b/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
index c3f0d2c30ea2..168fba882ca8 100644
--- a/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
+++ b/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
@@ -1,9 +1,9 @@
---- gnome-vfs-module-2.0.pc.in.orig Wed Sep 14 05:30:25 2005
-+++ gnome-vfs-module-2.0.pc.in Mon Oct 3 12:01:04 2005
+--- gnome-vfs-module-2.0.pc.in.orig Tue Jul 11 07:31:58 2006
++++ gnome-vfs-module-2.0.pc.in Tue Jul 11 09:34:36 2006
@@ -8,5 +8,5 @@
Description: The GNOME virtual file-system module include info
Version: @VERSION@
- Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
+ Requires: gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
-Libs: -L${libdir} -lgnomevfs-2
+Libs: -L${libdir} -lgnomevfs-2 @PTHREAD_LIB@
Cflags: -I${includedir}/gnome-vfs-2.0 -I${includedir}/gnome-vfs-module-2.0 -I${libdir}/gnome-vfs-2.0/include
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
index 05dd579ba16d..5260a0f3ec76 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-hal-mounts.c
@@ -1,5 +1,5 @@
---- libgnomevfs/gnome-vfs-hal-mounts.c.orig Sun May 7 01:07:27 2006
-+++ libgnomevfs/gnome-vfs-hal-mounts.c Sun May 7 01:07:42 2006
+--- libgnomevfs/gnome-vfs-hal-mounts.c.orig Mon Aug 7 04:16:27 2006
++++ libgnomevfs/gnome-vfs-hal-mounts.c Sun Sep 17 17:39:48 2006
@@ -32,7 +32,9 @@
#include <stdlib.h>
#include <string.h>
@@ -10,3 +10,34 @@
#include <sys/types.h>
#include <unistd.h>
#include <limits.h>
+@@ -627,20 +629,30 @@ _hal_volume_policy_check (GnomeVFSVolume
+ "/",
+ "/bin",
+ "/boot",
++ "/compat/linux/proc",
++ "/compat/linux/sys",
+ "/dev",
+ "/etc",
+ "/home",
+ "/lib",
+ "/lib64",
++ "/libexec",
+ "/media",
+ "/mnt",
+ "/opt",
++ "/rescue",
+ "/root",
+ "/sbin",
+ "/srv",
+ "/tmp",
+ "/usr",
++ "/usr/local",
++ "/usr/obj",
++ "/usr/ports",
++ "/usr/src",
++ "/usr/X11R6",
+ "/var",
++ "/var/tmp",
+ "/proc",
+ "/sbin",
+ NULL
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-monitor.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-monitor.c
deleted file mode 100644
index 11d73973b413..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-monitor.c
+++ /dev/null
@@ -1,131 +0,0 @@
---- libgnomevfs/gnome-vfs-monitor.c.orig Fri May 12 20:46:39 2006
-+++ libgnomevfs/gnome-vfs-monitor.c Fri May 12 22:29:57 2006
-@@ -48,9 +48,6 @@
-
- GList *pending_callbacks; /* protected by handle_hash */
- guint pending_timeout; /* protected by handle_hash */
-- guint timeout_count; /* count up each time pending_timeout is changed
-- to avoid timeout remove race.
-- protected by handle_hash */
- };
-
- struct GnomeVFSMonitorCallbackData {
-@@ -69,6 +66,9 @@
- static GHashTable *handle_hash = NULL;
- G_LOCK_DEFINE_STATIC (handle_hash);
-
-+static gint actually_dispatch_callback (gpointer data);
-+static guint32 get_min_delay (GList *list, gint32 now);
-+
- static void
- init_hash_table (void)
- {
-@@ -202,17 +202,25 @@
- return result;
- }
-
-+static void
-+install_timeout (GnomeVFSMonitorHandle *monitor_handle, time_t now)
-+{
-+ guint32 delay;
-
--typedef struct {
-- guint timeout_count;
-- GnomeVFSMonitorHandle *monitor_handle;
--} DispatchData;
-+ if (monitor_handle->pending_timeout)
-+ g_source_remove (monitor_handle->pending_timeout);
-+
-+ delay = get_min_delay (monitor_handle->pending_callbacks, now);
-+ if (delay == 0)
-+ monitor_handle->pending_timeout = g_idle_add (actually_dispatch_callback, monitor_handle);
-+ else
-+ monitor_handle->pending_timeout = g_timeout_add (delay * 1000, actually_dispatch_callback, monitor_handle);
-+}
-
- static gint
- actually_dispatch_callback (gpointer data)
- {
-- DispatchData *ddata = data;
-- GnomeVFSMonitorHandle *monitor_handle = ddata->monitor_handle;
-+ GnomeVFSMonitorHandle *monitor_handle = data;
- GnomeVFSMonitorCallbackData *callback_data;
- gchar *uri;
- GList *l, *next;
-@@ -228,13 +236,6 @@
-
- G_LOCK (handle_hash);
-
-- /* Don't clear pending_timeout if we started another timeout
-- * (and removed this)
-- */
-- if (monitor_handle->timeout_count == ddata->timeout_count) {
-- monitor_handle->pending_timeout = 0;
-- }
--
- if (!monitor_handle->cancelled) {
- /* Find all callbacks that needs to be dispatched */
- dispatch = NULL;
-@@ -305,13 +306,17 @@
-
- }
-
-- /* if we were waiting for this callback to be dispatched to free
-- * this monitor, then do it now.
-- */
-- if (monitor_handle->cancelled &&
-- no_live_callbacks (monitor_handle)) {
-- destroy_monitor_handle (monitor_handle);
-- }
-+ if (no_live_callbacks (monitor_handle)) {
-+ /* if we were waiting for this callback to be dispatched
-+ * to free this monitor, then do it now.
-+ */
-+ if (monitor_handle->cancelled)
-+ destroy_monitor_handle (monitor_handle);
-+ else
-+ monitor_handle->pending_timeout = 0;
-+ } else
-+ /* pending callbacks left, install another timeout */
-+ install_timeout (monitor_handle, now);
-
- G_UNLOCK (handle_hash);
-
-@@ -375,9 +380,7 @@
- GnomeVFSMonitorHandle *monitor_handle;
- char *uri;
- time_t now;
-- guint32 delay;
- GList *l;
-- DispatchData *ddata;
-
- g_return_if_fail (info_uri != NULL);
-
-@@ -435,26 +438,7 @@
- monitor_handle->pending_callbacks =
- g_list_append(monitor_handle->pending_callbacks, callback_data);
-
-- delay = get_min_delay (monitor_handle->pending_callbacks, now);
--
-- if (monitor_handle->pending_timeout) {
-- g_source_remove (monitor_handle->pending_timeout);
-- }
--
-- ddata = g_new (DispatchData, 1);
-- ddata->monitor_handle = monitor_handle;
-- ddata->timeout_count = ++monitor_handle->timeout_count;
--
-- if (delay == 0) {
-- monitor_handle->pending_timeout = g_idle_add_full (G_PRIORITY_DEFAULT_IDLE,
-- actually_dispatch_callback,
-- ddata, (GDestroyNotify)g_free);
-- } else {
-- monitor_handle->pending_timeout = g_timeout_add_full (G_PRIORITY_DEFAULT,
-- delay * 1000,
-- actually_dispatch_callback,
-- ddata, (GDestroyNotify)g_free);
-- }
-+ install_timeout (monitor_handle, now);
- }
-
- g_free (uri);
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-volume-ops.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-volume-ops.c
deleted file mode 100644
index dc1259ac425f..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-volume-ops.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libgnomevfs/gnome-vfs-volume-ops.c.orig Wed Dec 14 22:20:23 2005
-+++ libgnomevfs/gnome-vfs-volume-ops.c Wed Dec 14 22:20:43 2005
-@@ -25,6 +25,7 @@
-
- #include <sys/types.h>
- #include <errno.h>
-+#include <signal.h>
- #include <string.h>
- #include <stdlib.h>
- #include <glib.h>
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
index 37cc69f1ea3b..7119f852fa75 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
@@ -5,7 +5,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "%%LOCALBASE%%/share/gnome/:%%X11BASE%%/share/gnome/:%%LOCALBASE%%/share/:%%X11BASE%%/share/:/usr/share/";
ptr = xdg_data_dirs;
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h
new file mode 100644
index 000000000000..218578c258b7
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.h
@@ -0,0 +1,17 @@
+--- libgnomevfs/xdgmime.h.orig Sat Oct 7 10:42:32 2006
++++ libgnomevfs/xdgmime.h Sat Oct 7 11:01:57 2006
+@@ -52,11 +52,14 @@ typedef void (*XdgMimeDestroy) (void *u
+ #define xdg_mime_get_mime_type_from_file_name XDG_ENTRY(get_mime_type_from_file_name)
+ #define xdg_mime_is_valid_mime_type XDG_ENTRY(is_valid_mime_type)
+ #define xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal)
++#define _xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal_p)
+ #define xdg_mime_media_type_equal XDG_ENTRY(media_type_equal)
+ #define xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass)
++#define _xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass_p)
+ #define xdg_mime_get_mime_parents XDG_ENTRY(get_mime_parents)
+ #define xdg_mime_list_mime_parents XDG_ENTRY(list_mime_parents)
+ #define xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type)
++#define _xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type_p)
+ #define xdg_mime_get_max_buffer_extents XDG_ENTRY(get_max_buffer_extents)
+ #define xdg_mime_shutdown XDG_ENTRY(shutdown)
+ #define xdg_mime_dump XDG_ENTRY(dump)
diff --git a/devel/gnome-vfs/files/patch-modules_file-method-acl.c b/devel/gnome-vfs/files/patch-modules_file-method-acl.c
new file mode 100644
index 000000000000..7ec9a33b8f5f
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-modules_file-method-acl.c
@@ -0,0 +1,11 @@
+--- modules/file-method-acl.c.orig Mon Jul 24 18:47:12 2006
++++ modules/file-method-acl.c Mon Jul 24 22:01:34 2006
+@@ -45,7 +45,7 @@
+ #endif
+
+ #ifdef HAVE_POSIX_ACL
+-# include <acl/libacl.h>
++# include <sys/acl.h>
+ #define HAVE_ACL 1
+ #endif
+
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
index f1b405661c94..d1783a46cd02 100644
--- a/devel/gnome-vfs/pkg-deinstall.in
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnomevfs2/pkg-deinstall.in,v 1.7 2005/11/15 06:12:28 marcus Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.10 2006/07/22 20:45:37 mezz Exp $
#
# Restore gconf keys of libgnome.
@@ -9,11 +9,11 @@ if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
fi
-SCHEMAS=%%X11BASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
+SCHEMAS=%%LOCALBASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
if [ -f ${SCHEMAS} ]; then
- env GCONF_CONFIG_SOURCE=xml::%%X11BASE%%/etc/gconf/gconf.xml.defaults \
- %%X11BASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
+ env GCONF_CONFIG_SOURCE=xml::%%LOCALBASE%%/etc/gconf/gconf.xml.defaults \
+ %%LOCALBASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
> /dev/null || /usr/bin/true
fi
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
index 0b792521a116..98e90d3db5f0 100644
--- a/devel/gnome-vfs/pkg-install.in
+++ b/devel/gnome-vfs/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnomevfs2/pkg-install.in,v 1.7 2005/11/15 06:12:28 marcus Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.10 2006/07/22 20:45:37 mezz Exp $
#
# Restore gconf keys of libgnome.
@@ -9,11 +9,11 @@ if [ "$2" != "POST-INSTALL" ]; then
exit 0
fi
-SCHEMAS=%%X11BASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
+SCHEMAS=%%LOCALBASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
if [ -f ${SCHEMAS} ]; then
- env GCONF_CONFIG_SOURCE=xml::%%X11BASE%%/etc/gconf/gconf.xml.defaults \
- %%X11BASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
+ env GCONF_CONFIG_SOURCE=xml::%%LOCALBASE%%/etc/gconf/gconf.xml.defaults \
+ %%LOCALBASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
> /dev/null || /usr/bin/true
fi
diff --git a/devel/gnome-vfs/pkg-plist b/devel/gnome-vfs/pkg-plist
index 5e66ee7b8f29..1e606b847900 100644
--- a/devel/gnome-vfs/pkg-plist
+++ b/devel/gnome-vfs/pkg-plist
@@ -11,6 +11,8 @@ etc/gnome-vfs-2.0/modules/default-modules.conf
%%SAMBA%%etc/gnome-vfs-2.0/modules/smb-module.conf
etc/gnome-vfs-2.0/modules/ssl-modules.conf
include/gnome-vfs-2.0/include/gnome-vfs-file-size.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-ace.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-acl.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-address.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-application-registry.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-async-ops.h
@@ -26,6 +28,7 @@ include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-find-directory.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-handle.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-init.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-job-limit.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-deprecated.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-handlers.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-info-cache.h
@@ -40,6 +43,7 @@ include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-standard-callbacks.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-types.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-uri.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-utils.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-version.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-volume-monitor.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-volume.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-xfer.h
@@ -48,7 +52,6 @@ include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-cancellable-ops.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-inet-connection.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-method.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-mime-info.h
-include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-mime.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module-callback-module-api.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module-shared.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module.h
@@ -58,9 +61,6 @@ include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-socket-buffer.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-socket.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-ssl.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-transform.h
-lib/bonobo/monikers/libmoniker_gnome_vfs_std.a
-lib/bonobo/monikers/libmoniker_gnome_vfs_std.la
-lib/bonobo/monikers/libmoniker_gnome_vfs_std.so
lib/gnome-vfs-2.0/modules/libbzip2.a
lib/gnome-vfs-2.0/modules/libbzip2.la
lib/gnome-vfs-2.0/modules/libbzip2.so
@@ -104,11 +104,10 @@ lib/libgnomevfs-2.a
lib/libgnomevfs-2.la
lib/libgnomevfs-2.so
lib/libgnomevfs-2.so.0
-libdata/bonobo/servers/GNOME_VFS_Daemon.server
-libdata/bonobo/servers/GNOME_VFS_Moniker_std.server
libdata/pkgconfig/gnome-vfs-2.0.pc
libdata/pkgconfig/gnome-vfs-module-2.0.pc
libexec/gnome-vfs-daemon
+share/dbus-1/services/gnome-vfs-daemon.service
share/locale/af/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/am/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ar/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -116,6 +115,7 @@ share/locale/az/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/be/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/bg/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/bn/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/bs/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ca/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/cs/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -192,9 +192,57 @@ share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrm include/gnome-vfs-2.0
@dirrmtry share/locale/zu/LC_MESSAGES
@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/yi/LC_MESSAGES
+@dirrmtry share/locale/yi
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr@ije/LC_MESSAGES
+@dirrmtry share/locale/sr@ije
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/li/LC_MESSAGES
+@dirrmtry share/locale/li
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be