aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /devel/gnome-vfs
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Notes
Notes: svn path=/head/; revision=225629
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnome-vfs/distinfo6
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmimecache.h31
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in2
-rw-r--r--devel/gnome-vfs/pkg-install.in2
-rw-r--r--devel/gnome-vfs/pkg-plist7
6 files changed, 23 insertions, 31 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 5ec27ed4142f..cee963b7593c 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -3,12 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/Makefile,v 1.182 2008/03/10 23:08:21 ahze Exp $
+# $MCom: ports/devel/gnome-vfs/Makefile,v 1.185 2008/09/22 10:26:54 kwm Exp $
#
PORTNAME= gnome-vfs
-PORTVERSION= 2.22.0
-PORTREVISION?= 2
+PORTVERSION= 2.24.0
+PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index 71b68d87f596..0b2dc3c17e30 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-vfs-2.22.0.tar.bz2) = 369105fd82cb99e69e63acab8f3b89b7
-SHA256 (gnome2/gnome-vfs-2.22.0.tar.bz2) = 622cf50cefa2c4187e0a23f29d665f010f7a0815864fc35a61caefd5a7d4ebb1
-SIZE (gnome2/gnome-vfs-2.22.0.tar.bz2) = 1939765
+MD5 (gnome2/gnome-vfs-2.24.0.tar.bz2) = 870ee8861bfcaeb852934e95657ef83e
+SHA256 (gnome2/gnome-vfs-2.24.0.tar.bz2) = b8ae3c81a2d6a3798534e72216899021013b47bc012e405fa00167d190559d94
+SIZE (gnome2/gnome-vfs-2.24.0.tar.bz2) = 1935735
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmimecache.h b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmimecache.h
index 69292f2f1a16..7d987f400d90 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmimecache.h
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmimecache.h
@@ -1,25 +1,12 @@
---- libgnomevfs/xdgmimecache.h.orig Mon May 29 20:04:24 2006
-+++ libgnomevfs/xdgmimecache.h Mon May 29 20:11:42 2006
-@@ -32,9 +32,19 @@
- typedef struct _XdgMimeCache XdgMimeCache;
-
- #ifdef XDG_PREFIX
--#define _xdg_mime_cache_new_from_file XDG_ENTRY(cache_new_from_file)
--#define _xdg_mime_cache_ref XDG_ENTRY(cache_ref)
--#define _xdg_mime_cache_unref XDG_ENTRY(cache_unref)
-+#define _xdg_mime_cache_new_from_file XDG_ENTRY(cache_new_from_file)
-+#define _xdg_mime_cache_ref XDG_ENTRY(cache_ref)
-+#define _xdg_mime_cache_unref XDG_ENTRY(cache_unref)
-+#define _xdg_mime_cache_get_mime_type_for_data XDG_ENTRY(cache_get_mime_type_for_data)
-+#define _xdg_mime_cache_get_mime_type_for_file XDG_ENTRY(cache_get_mime_type_for_file)
-+#define _xdg_mime_cache_get_mime_type_from_file_name XDG_ENTRY(cache_get_mime_type_from_file_name)
-+#define _xdg_mime_cache_is_valid_mime_type XDG_ENTRY(cache_is_valid_mime_type)
-+#define _xdg_mime_cache_mime_type_equal XDG_ENTRY(cache_mime_type_equal)
-+#define _xdg_mime_cache_media_type_equal XDG_ENTRY(cache_media_type_equal)
-+#define _xdg_mime_cache_mime_type_subclass XDG_ENTRY(cache_mime_type_subclass)
-+#define _xdg_mime_cache_list_mime_parents XDG_ENTRY(cache_list_mime_parents)
-+#define _xdg_mime_cache_unalias_mime_type XDG_ENTRY(cache_unalias_mime_type)
-+#define _xdg_mime_cache_get_max_buffer_extents XDG_ENTRY(cache_get_max_buffer_extents)
+--- libgnomevfs/xdgmimecache.h.orig 2008-06-12 10:25:40.000000000 -0400
++++ libgnomevfs/xdgmimecache.h 2008-06-14 00:49:59.000000000 -0400
+@@ -46,6 +46,9 @@ typedef struct _XdgMimeCache XdgMimeCach
+ #define _xdg_mime_cache_get_icon XDG_RESERVED_ENTRY(cache_get_icon)
+ #define _xdg_mime_cache_get_generic_icon XDG_RESERVED_ENTRY(cache_get_generic_icon)
+ #define _xdg_mime_cache_glob_dump XDG_RESERVED_ENTRY(cache_glob_dump)
++#define _xdg_mime_cache_is_valid_mime_type XDG_RESERVED_ENTRY(cache_is_valid_mime_type)
++#define _xdg_mime_cache_mime_type_equal XDG_RESERVED_ENTRY(cache_mime_type_equal)
++#define _xdg_mime_cache_media_type_equal XDG_RESERVED_ENTRY(cache_media_type_equal)
#endif
extern XdgMimeCache **_caches;
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
index f8b22aaaf1b4..402f3449c6f9 100644
--- a/devel/gnome-vfs/pkg-deinstall.in
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.17 2008/01/30 17:29:15 mezz Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.20 2008/08/06 04:22:49 mezz Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
index 72da3bf8ba79..19bf94479dab 100644
--- a/devel/gnome-vfs/pkg-install.in
+++ b/devel/gnome-vfs/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.17 2008/01/30 17:29:15 mezz Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.20 2008/08/06 04:22:49 mezz Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-plist b/devel/gnome-vfs/pkg-plist
index d1e23ffc8251..6625cbfc171a 100644
--- a/devel/gnome-vfs/pkg-plist
+++ b/devel/gnome-vfs/pkg-plist
@@ -151,6 +151,7 @@ share/locale/ku/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/li/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/lt/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/lv/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/mai/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/mg/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/mk/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ml/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -175,7 +176,7 @@ share/locale/sk/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sl/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sq/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sr/LC_MESSAGES/gnome-vfs-2.0.mo
-share/locale/sr@Latn/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sr@ije/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sv/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ta/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -206,6 +207,8 @@ share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/sr@ije/LC_MESSAGES
@dirrmtry share/locale/sr@ije
@dirrmtry share/locale/rw/LC_MESSAGES
@@ -218,6 +221,8 @@ share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
@dirrmtry share/locale/bn_IN/LC_MESSAGES