aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-01-27 15:55:15 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-01-27 15:55:15 +0000
commitc94e79c67643d97eda0152582d8eecb20cbf81b7 (patch)
tree783788ee68a82d108bc8485a91ff4a5ac651cafc /devel/gnome-vfs
parent9e2ee8db3fe59f7e8f9fc1d97fd1545442dc17af (diff)
downloadports-c94e79c67643d97eda0152582d8eecb20cbf81b7.tar.gz
ports-c94e79c67643d97eda0152582d8eecb20cbf81b7.zip
Update to 2.4.2
Notes
Notes: svn path=/head/; revision=99274
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile5
-rw-r--r--devel/gnome-vfs/distinfo2
-rw-r--r--devel/gnome-vfs/files/patch-modules_cdda-method.c10
3 files changed, 8 insertions, 9 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 9161cb4b2e46..363a003fcfa8 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomevfs2
-PORTVERSION= 2.4.1
-PORTREVISION= 1
+PORTVERSION= 2.4.2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/2.4
@@ -25,7 +24,7 @@ USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
.if !defined(WITHOUT_KDE_MENUS)
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index 6d9fb761b6f9..b8991ecf22b2 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gnome-vfs-2.4.1.tar.bz2) = cb7a36076f6a65e40c7f540be3057310
+MD5 (gnome2/gnome-vfs-2.4.2.tar.bz2) = a0f0e40739214143bbf3050311ff10cd
diff --git a/devel/gnome-vfs/files/patch-modules_cdda-method.c b/devel/gnome-vfs/files/patch-modules_cdda-method.c
index d1692cc03e47..97250842b916 100644
--- a/devel/gnome-vfs/files/patch-modules_cdda-method.c
+++ b/devel/gnome-vfs/files/patch-modules_cdda-method.c
@@ -1,7 +1,7 @@
---- modules/cdda-method.c.orig Wed Jan 22 13:54:31 2003
-+++ modules/cdda-method.c Wed Jan 22 13:54:33 2003
+--- modules/cdda-method.c.orig Tue Jan 27 06:19:01 2004
++++ modules/cdda-method.c Wed Jan 28 00:21:01 2004
@@ -623,7 +623,11 @@
- // Check and see if we already have opened and stashed this drive
+ /* Check and see if we already have opened and stashed this drive */
if (!use_base) {
if (global_context != NULL) {
+#ifdef Linux
@@ -14,13 +14,13 @@
gnome_vfs_file_info_copy (file_info, global_context->file_info);
@@ -709,7 +713,11 @@
if (!use_base) {
- // Check for cache
+ /* Check for cache */
if (global_context != NULL) {
+#ifdef Linux
if (strcmp (drive->cdda_device_name, global_context->drive->cdda_device_name) != 0) {
+#elif defined(__FreeBSD__)
+ if (strcmp (drive->dev->device_path, global_context->drive->dev->device_path) != 0) {
+#endif
- // Clear old cache
+ /* Clear old cache */
cdda_context_free (global_context);
global_context = cdda_context_new (drive, uri);