aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomebuild/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-08-06 19:06:30 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-08-06 19:06:30 +0000
commitc0633510da317c661ae44bc821eb97649ae74106 (patch)
tree7ef93f9f261eb1db468322db19874df79369ff2e /devel/gnomebuild/Makefile
parent19efd8ae750737b6ea17c74e1c680e35597d984a (diff)
downloadports-c0633510da317c661ae44bc821eb97649ae74106.tar.gz
ports-c0633510da317c661ae44bc821eb97649ae74106.zip
Use USE_GNOMENG.
Notes
Notes: svn path=/head/; revision=64115
Diffstat (limited to 'devel/gnomebuild/Makefile')
-rw-r--r--devel/gnomebuild/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 0505ea17116f..d8280e1edbc5 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -18,17 +18,15 @@ LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomevfs bonobo libglade gal gtkhtml
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>