aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 09:46:41 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 09:46:41 +0000
commit6d95a1bf14a28ded2212f1922201a0a27183385d (patch)
treecebfaa43bbf438cec1dc01b20111af2d01acd0f1 /devel/gnomevfs2
parent03043505eac4ed10e9e1e68c707a9c8376653b6c (diff)
downloadports-6d95a1bf14a28ded2212f1922201a0a27183385d.tar.gz
ports-6d95a1bf14a28ded2212f1922201a0a27183385d.zip
- Update to 1.9.12 (version found in the GNOME2 beta4);
- use USE_LIBTOOL.
Notes
Notes: svn path=/head/; revision=58157
Diffstat (limited to 'devel/gnomevfs2')
-rw-r--r--devel/gnomevfs2/Makefile7
-rw-r--r--devel/gnomevfs2/distinfo2
-rw-r--r--devel/gnomevfs2/files/patch-aa85
-rw-r--r--devel/gnomevfs2/files/patch-ltmain.sh45
-rw-r--r--devel/gnomevfs2/pkg-plist43
5 files changed, 93 insertions, 89 deletions
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 32454ea04638..a868e48ca3ad 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomevfs2
-PORTVERSION= 1.9.11
-PORTREVISION= 1
+PORTVERSION= 1.9.12
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DISTNAME= gnome-vfs-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,7 +23,7 @@ RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/mis
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
diff --git a/devel/gnomevfs2/distinfo b/devel/gnomevfs2/distinfo
index 255faa7eff36..7618a2780d61 100644
--- a/devel/gnomevfs2/distinfo
+++ b/devel/gnomevfs2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gnome-vfs-1.9.11.tar.bz2) = 51ddc69ecaf25366a1aa7eed5f5c8a53
+MD5 (gnome2/gnome-vfs-1.9.12.tar.bz2) = 83bd2b8f31ddb32fe4d81aa8c6038148
diff --git a/devel/gnomevfs2/files/patch-aa b/devel/gnomevfs2/files/patch-aa
index bd10b13e7ff5..f4c57afc835c 100644
--- a/devel/gnomevfs2/files/patch-aa
+++ b/devel/gnomevfs2/files/patch-aa
@@ -1,43 +1,50 @@
$FreeBSD$
---- configure.orig Mon Mar 11 21:42:05 2002
-+++ configure Mon Mar 11 21:42:37 2002
-@@ -11993,8 +11993,8 @@
+--- configure.orig Fri Apr 26 12:27:40 2002
++++ configure Fri Apr 26 12:30:02 2002
+@@ -5586,6 +5586,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -9131,8 +9132,8 @@
done
fi
--echo "$as_me:11996: checking for bzCompressInit in -lbz2" >&5
--echo $ECHO_N "checking for bzCompressInit in -lbz2... $ECHO_C" >&6
-+echo "$as_me:11996: checking for BZ2_bzCompressInit in -lbz2" >&5
-+echo $ECHO_N "checking for BZ2_bzCompressInit in -lbz2... $ECHO_C" >&6
- if test "${ac_cv_lib_bz2_bzCompressInit+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-@@ -12010,11 +12010,11 @@
- #endif
+-echo $ac_n "checking for bzCompressInit in -lbz2""... $ac_c" 1>&6
+-echo "configure:9136: checking for bzCompressInit in -lbz2" >&5
++echo $ac_n "checking for BZ2_bzCompressInit in -lbz2""... $ac_c" 1>&6
++echo "configure:9136: checking for BZ2_bzCompressInit in -lbz2" >&5
+ ac_lib_var=`echo bz2'_'bzCompressInit | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+@@ -9145,10 +9146,10 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char bzCompressInit ();
-+char BZ2_bzCompressInit ();
- int
- main ()
- {
--bzCompressInit ();
-+BZ2_bzCompressInit ();
- ;
- return 0;
- }
-@@ -12326,7 +12326,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
+ builtin and then its argument prototype would still apply. */
+-char bzCompressInit();
++char BZ2_bzCompressInit();
+ int main() {
+-bzCompressInit()
++BZ2_bzCompressInit()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:9155: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -9421,7 +9422,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+
- LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcrypto -ldl"
+ LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcryptofoo -ldl"
- cat >conftest.$ac_ext <<_ACEOF
- #line 12331 "configure"
+ cat > conftest.$ac_ext <<EOF
+ #line 9427 "configure"
#include "confdefs.h"
-@@ -12377,9 +12377,9 @@
+@@ -9456,9 +9457,9 @@
msg_openssl="yes"
if test x$with_openssl_libs != x/usr/lib; then
@@ -47,14 +54,14 @@ $FreeBSD$
- OPENSSL_LIBS="-lssl -lcrypto"
+ OPENSSL_LIBS="-lssl -lcryptofoo"
fi
+
- if true; then
-@@ -13259,7 +13259,7 @@
- s,@ORBIT_IDL@,$ORBIT_IDL,;t t
- s,@BONOBO_IDLDIR@,$BONOBO_IDLDIR,;t t
- s,@WARN_CFLAGS@,$WARN_CFLAGS,;t t
--s,@PTHREAD_LIB@,$PTHREAD_LIB,;t t
-+s,@PTHREAD_LIB@,$BSD_PTHREAD_LIB,;t t
- s,@GETTEXT_PACKAGE@,$GETTEXT_PACKAGE,;t t
- s,@ALLOCA@,$ALLOCA,;t t
- s,@USE_NLS@,$USE_NLS,;t t
+@@ -10059,7 +10060,7 @@
+ s%@ORBIT_IDL@%$ORBIT_IDL%g
+ s%@BONOBO_IDLDIR@%$BONOBO_IDLDIR%g
+ s%@WARN_CFLAGS@%$WARN_CFLAGS%g
+-s%@PTHREAD_LIB@%$PTHREAD_LIB%g
++s%@PTHREAD_LIB@%$BSD_PTHREAD_LIB%g
+ s%@GETTEXT_PACKAGE@%$GETTEXT_PACKAGE%g
+ s%@ALLOCA@%$ALLOCA%g
+ s%@USE_NLS@%$USE_NLS%g
diff --git a/devel/gnomevfs2/files/patch-ltmain.sh b/devel/gnomevfs2/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/devel/gnomevfs2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/gnomevfs2/pkg-plist b/devel/gnomevfs2/pkg-plist
index 3982c8b2d25d..21490f936de6 100644
--- a/devel/gnomevfs2/pkg-plist
+++ b/devel/gnomevfs2/pkg-plist
@@ -78,6 +78,49 @@ lib/vfs/2.0/extfs/zoo
libdata/bonobo/servers/GNOME_VFS_Moniker_std.server
libdata/pkgconfig/gnome-vfs-2.0.pc
libdata/pkgconfig/gnome-vfs-module-2.0.pc
+share/doc/gnome-vfs/about.html
+share/doc/gnome-vfs/data-types.html
+share/doc/gnome-vfs/everything-else.html
+share/doc/gnome-vfs/file-operations.html
+share/doc/gnome-vfs/gnome-vfs-application-registry.html
+share/doc/gnome-vfs/gnome-vfs-asynchronous-operations.html
+share/doc/gnome-vfs/gnome-vfs-cancellation.html
+share/doc/gnome-vfs/gnome-vfs-configuration.html
+share/doc/gnome-vfs/gnome-vfs-context.html
+share/doc/gnome-vfs/gnome-vfs-directory.html
+share/doc/gnome-vfs/gnome-vfs-file-info.html
+share/doc/gnome-vfs/gnome-vfs-file-size.html
+share/doc/gnome-vfs/gnome-vfs-finding-special-directories.html
+share/doc/gnome-vfs/gnome-vfs-inet-connection.html
+share/doc/gnome-vfs/gnome-vfs-initialization.html
+share/doc/gnome-vfs/gnome-vfs-iobuf.html
+share/doc/gnome-vfs/gnome-vfs-method.html
+share/doc/gnome-vfs/gnome-vfs-mime-handlers.html
+share/doc/gnome-vfs/gnome-vfs-mime-info.html
+share/doc/gnome-vfs/gnome-vfs-mime-magic.html
+share/doc/gnome-vfs/gnome-vfs-mime-monitor.html
+share/doc/gnome-vfs/gnome-vfs-mime-sniff-buffer.html
+share/doc/gnome-vfs/gnome-vfs-mime.html
+share/doc/gnome-vfs/gnome-vfs-module-callback-module-api.html
+share/doc/gnome-vfs/gnome-vfs-module-callbacks.html
+share/doc/gnome-vfs/gnome-vfs-module-shared.html
+share/doc/gnome-vfs/gnome-vfs-module.html
+share/doc/gnome-vfs/gnome-vfs-ops.html
+share/doc/gnome-vfs/gnome-vfs-parse-ls.html
+share/doc/gnome-vfs/gnome-vfs-process.html
+share/doc/gnome-vfs/gnome-vfs-result.html
+share/doc/gnome-vfs/gnome-vfs-ssl.html
+share/doc/gnome-vfs/gnome-vfs-standard-callbacks.html
+share/doc/gnome-vfs/gnome-vfs-types.html
+share/doc/gnome-vfs/gnome-vfs-uri.html
+share/doc/gnome-vfs/gnome-vfs-utils.html
+share/doc/gnome-vfs/gnome-vfs-xfer.html
+share/doc/gnome-vfs/index.html
+share/doc/gnome-vfs/index.sgml
+share/doc/gnome-vfs/mime-registry.html
+share/doc/gnome-vfs/modules.html
+share/doc/gnome-vfs/writing-modules.html
+share/doc/gnome-vfs/x27.html
share/locale/az/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ca/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/da/LC_MESSAGES/gnome-vfs-2.0.mo