aboutsummaryrefslogtreecommitdiff
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-12-14 05:16:10 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-12-14 05:16:10 +0000
commit17a05ac8c02dfe347d1213c742b0186620139f16 (patch)
treeaeadeb9e4e20cbe01a98e7d1a5d41c096445bc8f /devel/gnustep-make
parent39a413d6b9a7cc3ecdfb4135af2645bf67d7f357 (diff)
downloadports-17a05ac8c02dfe347d1213c742b0186620139f16.tar.gz
ports-17a05ac8c02dfe347d1213c742b0186620139f16.zip
- handle stale shared libs from gcc-objc installs
- force ldconfig when needed PR: 74940
Notes
Notes: svn path=/head/; revision=123988
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 8fe7964ab0b9..4cb4276d6fff 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -35,4 +35,20 @@ CONFIGURE_ARGS+= --with-thread-lib="${PTHREAD_LIBS}"
GNUSTEP_WITHOUT_LIBOBJC= yes
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ @if test ! -f "${TARGLIB}/libobjc.so"; then \
+ ${ECHO_MSG} "libobjc.so not found, please update your gcc"; \
+ ${FALSE}; \
+ fi; \
+ if test `${LDCONFIG} -r | grep libobjc.so | wc -l` -eq 0; then \
+ ${ECHO_MSG} "trying to fix ldconfig.hints"; \
+ ${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -m "${TARGLIB}";\
+ if test `${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -r | grep libobjc.so | wc -l` -eq 0; then \
+ ${ECHO_MSG} "libobjc.so not in path"; \
+ ${FALSE}; \
+ fi; \
+ fi; \
+
+.include <bsd.port.post.mk>