aboutsummaryrefslogtreecommitdiff
path: root/devel/goffice
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2011-06-04 22:36:54 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2011-06-04 22:36:54 +0000
commitfd48ccbc42485bc10f91f3efbb2594c70bf6c15e (patch)
treecc20eb7bbae00f3bee18d6ffc67c03d51ea6e39b /devel/goffice
parent7f658f9b3906fd9d867870cef10bd0809f372810 (diff)
downloadports-fd48ccbc42485bc10f91f3efbb2594c70bf6c15e.tar.gz
ports-fd48ccbc42485bc10f91f3efbb2594c70bf6c15e.zip
- Make gconf optional.
- Mark MAKE_JOBS_SAFE. - Move CPPFLAGS outside the CONFIGURE_ENV. PR: ports/156708 Submitted by: Zhihao Yuan <lichray@gmail.com>
Notes
Notes: svn path=/head/; revision=275073
Diffstat (limited to 'devel/goffice')
-rw-r--r--devel/goffice/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
index 949090cafdd3..d30f69b4f963 100644
--- a/devel/goffice/Makefile
+++ b/devel/goffice/Makefile
@@ -22,15 +22,21 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgsf gconf2 \
- ltverhack
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 libgsf ltverhack
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
+CPPFLAGS= "-I${LOCALBASE}/include"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
PLIST_SUB= VERSION=${PORTVERSION} \
SHORT_VER=0.8
+MAKE_JOBS_SAFE= yes
+
+.if !defined(WITHOUT_GCONF)
+USE_GNOME+= gconf2
+.else
+CONFIGURE_ARGS+=--with-config-backend=keyfile
+.endif
+
.include <bsd.port.mk>