aboutsummaryrefslogtreecommitdiff
path: root/devel/gprbuild/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-16 15:11:40 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-16 15:11:40 +0000
commitbee4622fe3268a1fca36af1e82e2c34ba9739497 (patch)
tree95ebe1309939f38eabd4f0469b5c79d936ac4932 /devel/gprbuild/Makefile
parentd2fd619340975e436f216d4c07194c3bef7ef55c (diff)
downloadports-bee4622fe3268a1fca36af1e82e2c34ba9739497.tar.gz
ports-bee4622fe3268a1fca36af1e82e2c34ba9739497.zip
lang/gnat_util, devel/gprbuild: Support gcc5-aux
GPRBuild is too highly tethered to the compiler -- in practical terms each version of GPRBuild is meant to be built by a specific GPL GNAT, but we're trying to build it with multiple FSF GNATS that are out of sync. This patch set does allow GPRBuild to build and apparently work with both gcc-aux and gcc5-aux. There is no real change for gcc-aux (OpenVMS is removed from the code but it should be same difference) ang for gcc5-aux, the previous patches aren't needed but new ones are. Thus, EXTRA_PATCHES had to be set for each of the two supported compilers. lang/gnat_utils had to be modified to stop packaging OpenVMS target files as apparently this target has been removed from gcc5-aux.
Notes
Notes: svn path=/head/; revision=381407
Diffstat (limited to 'devel/gprbuild/Makefile')
-rw-r--r--devel/gprbuild/Makefile29
1 files changed, 26 insertions, 3 deletions
diff --git a/devel/gprbuild/Makefile b/devel/gprbuild/Makefile
index 0a310eba36c1..b8bf4de26407 100644
--- a/devel/gprbuild/Makefile
+++ b/devel/gprbuild/Makefile
@@ -26,7 +26,19 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ADAXX:Mgcc}
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-protocol.adb \
+ ${FILESDIR}/extrapatch-src_gprbuild-main.adb \
+ ${FILESDIR}/extrapatch-src_gprslave.adb \
+ ${FILESDIR}/extrapatch-src_rewrite__data.ada
+.else
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-5-gprbuild-main.adb \
+ ${FILESDIR}/extrapatch-5-gprbuild-slave.adb \
+ ${FILESDIR}/extrapatch-5-gprbuild-post.adb \
+ ${FILESDIR}/extrapatch-5-gprlib.adb
+.endif
do-build:
# Recreate the do-build target without -j parameter
@@ -37,10 +49,21 @@ do-build:
post-patch:
@${REINPLACE_CMD} -e "s,@AUXPREFIX@,${PREFIX}/gcc-aux," \
${WRKSRC}/share/gprconfig/compilers.xml
+ # OpenVMS was removed from GCC 5, and it obviously isn't used
+ # here so replace boolean check to False so it builds on both
+.if ${ADAXX:Mgcc}
# Try_Help is part of GNAT Pro, but it's not in GCC 4.9 yet
# It's not strictly needed. Before it just repeated usage.
# There are other messages; just suppress Try_Help on 4 files
- ${REINPLACE_CMD} -e '/Try_Help;/d' ${WRKSRC}/src/*-main.adb
+ ${REINPLACE_CMD} -e '/Try_Help;/d' \
+ -e 's|Hostparm.OpenVMS|False|' ${WRKSRC}/src/*-main.adb \
+ ${WRKSRC}/src/gprbind.adb ${WRKSRC}/src/gprlib.adb
+.else # gcc5-aux
+ ${REINPLACE_CMD} -e 's|Hostparm.OpenVMS|False|' \
+ ${WRKSRC}/src/*-main.adb \
+ ${WRKSRC}/src/gprbind.adb \
+ ${WRKSRC}/src/gprlib.adb
+.endif
post-install:
.if !${PORT_OPTIONS:MDOCS}
@@ -52,4 +75,4 @@ post-install:
(cd ${STAGEDIR}${PREFIX} && ${FIND} share/examples -type d -empty | \
${SORT} -dr | ${XARGS} ${RMDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>