aboutsummaryrefslogtreecommitdiff
path: root/devel/guichan
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-13 18:24:53 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-13 18:24:53 +0000
commit0bee0c95d2341cfb6ff25504bd33cf8b00d67319 (patch)
tree3750be7ecf5430375a81012750318195c1a8589c /devel/guichan
parent375ffad719e64c8a00fe816bb29d0efad30d8010 (diff)
downloadports-0bee0c95d2341cfb6ff25504bd33cf8b00d67319.tar.gz
ports-0bee0c95d2341cfb6ff25504bd33cf8b00d67319.zip
Fix configure to detect SDL
Bump PORTREVISION Submitted by: maintainer via email
Notes
Notes: svn path=/head/; revision=145291
Diffstat (limited to 'devel/guichan')
-rw-r--r--devel/guichan/Makefile11
-rw-r--r--devel/guichan/files/patch-configure40
-rw-r--r--devel/guichan/files/patch-configure.in20
-rw-r--r--devel/guichan/pkg-plist7
4 files changed, 53 insertions, 25 deletions
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index 8a4e4713dfea..228c971a2fa4 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -7,6 +7,7 @@
PORTNAME= guichan
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= devel games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= freebsd@gionet.de
COMMENT= A small, efficient C++ GUI library designed for games
-LIB_DEPENDS= SDL-1.1.7:${PORTSDIR}/devel/sdl12 \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
+USE_SDL= sdl image
USE_GMAKE= yes
USE_GCC= 3.2+
USE_LIBTOOL_VER=15
@@ -32,7 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/SDL11 \
-I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib \
${PTHREAD_LIBS}"
-pre-configure:
- @(cd ${WRKSRC} && ./autogen.sh)
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%SDL_CONFIG_ONLY%%|${SDL_CONFIG:S/${PREFIX}\/bin\///}|g" \
+ -e "s|%%SDL_CONFIG%%|${SDL_CONFIG}|g" ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/devel/guichan/files/patch-configure b/devel/guichan/files/patch-configure
new file mode 100644
index 000000000000..84cbf8615b5a
--- /dev/null
+++ b/devel/guichan/files/patch-configure
@@ -0,0 +1,40 @@
+--- configure.orig Tue May 17 16:23:18 2005
++++ configure Thu Oct 13 14:33:11 2005
+@@ -20037,7 +20037,7 @@
+ {
+ SDLIMAGE="yes"
+ SDL_LIBS="$SDL_LIBS -lSDL_image"
+- CPPFLAGS="$CPPFLAGS `sdl-config --cflags`"
++ CPPFLAGS="$CPPFLAGS `%%SDL_CONFIG%% --cflags`"
+ }
+
+ ForceSDLImage()
+@@ -20338,7 +20338,7 @@
+ if test x$enable_sdlimage = xyes; then
+ if test x$enable_force_sdlimage = xno; then
+
+-for ac_header in SDL/SDL_image.h
++for ac_header in SDL_image.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+@@ -20790,7 +20790,7 @@
+ if test x$enable_sdl = xyes; then
+ if test x$enable_force_sdl = xno; then
+
+-for ac_header in SDL/SDL.h
++for ac_header in SDL.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+@@ -20939,8 +20939,8 @@
+
+ done
+
+- # Extract the first word of "sdl-config", so it can be a program name with args.
+-set dummy sdl-config; ac_word=$2
++ # Extract the first word of "%%SDL_CONFIG_ONLY%%", so it can be a program name with args.
++set dummy %%SDL_CONFIG_ONLY%%; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+ echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+ if test "${ac_cv_prog_HAVE_SDL+set}" = set; then
diff --git a/devel/guichan/files/patch-configure.in b/devel/guichan/files/patch-configure.in
deleted file mode 100644
index 017d91725e1d..000000000000
--- a/devel/guichan/files/patch-configure.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.in.orig Tue Oct 11 21:57:06 2005
-+++ configure.in Tue Oct 11 21:57:33 2005
-@@ -170,7 +170,7 @@
- , enable_force_sdlimage=no)
- if test x$enable_sdlimage = xyes; then
- if test x$enable_force_sdlimage = xno; then
-- AC_CHECK_HEADERS([SDL/SDL_image.h])
-+ AC_CHECK_HEADERS([SDL_image.h])
- AC_CHECK_LIB([SDL_image], [IMG_Load], HaveSDLImage, NoSDLImage)
- else
- ForceSDLImage
-@@ -205,7 +205,7 @@
- , enable_force_sdl=no)
- if test x$enable_sdl = xyes; then
- if test x$enable_force_sdl = xno; then
-- AC_CHECK_HEADERS(SDL/SDL.h)
-+ AC_CHECK_HEADERS(SDL.h)
- AC_CHECK_PROG(HAVE_SDL, sdl-config, yes)
- if test "x$HAVE_SDL" != "xyes"; then
- SDL="no"
diff --git a/devel/guichan/pkg-plist b/devel/guichan/pkg-plist
index 14ce71365fe2..bd33c65f72bc 100644
--- a/devel/guichan/pkg-plist
+++ b/devel/guichan/pkg-plist
@@ -26,6 +26,9 @@ include/guichan/opengl/openglimageloader.hpp
include/guichan/platform.hpp
include/guichan/rectangle.hpp
include/guichan/sdl.hpp
+include/guichan/sdl/sdlgraphics.hpp
+include/guichan/sdl/sdlimageloader.hpp
+include/guichan/sdl/sdlinput.hpp
include/guichan/widget.hpp
include/guichan/widgets/button.hpp
include/guichan/widgets/checkbox.hpp
@@ -47,6 +50,10 @@ lib/libguichan.so.0
lib/libguichan_opengl.a
lib/libguichan_opengl.so
lib/libguichan_opengl.so.0
+lib/libguichan_sdl.a
+lib/libguichan_sdl.so
+lib/libguichan_sdl.so.0
@dirrm include/guichan/widgets
+@dirrm include/guichan/sdl
@dirrm include/guichan/opengl
@dirrm include/guichan