aboutsummaryrefslogtreecommitdiff
path: root/devel/gvfs
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-03-21 17:26:06 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-03-21 17:26:06 +0000
commite649fa82486dc8ea6d06fcc10b223c4170c364f9 (patch)
tree429c37e117fd474adb16cfda736e59b3891fbb4d /devel/gvfs
parent68b1216c61fdcf9ec8c83133bf5a56de668cc42c (diff)
downloadports-e649fa82486dc8ea6d06fcc10b223c4170c364f9.tar.gz
ports-e649fa82486dc8ea6d06fcc10b223c4170c364f9.zip
devel/gvfs: drop dependency upon libgnome-keyring
1. gvfs switched from libgnome-keyring to libsecret since 1.13.7, so update our port accordingly. Also enable build with keyring support (it was unconditionally disabled with --disable-keyring) 2. HAL tweaks were released upstream since version 1.25.x or earlier, so remove it from our port too. See bug [1] and commit [2] for the reference. [1] https://bugzilla.gnome.org/show_bug.cgi?id=722411 [2] https://git.gnome.org/browse/gvfs/commit/?id=32377d1 Differential Revision: https://reviews.freebsd.org/D5694 Reviewed by: kwm With hat: gnome
Notes
Notes: svn path=/head/; revision=411573
Diffstat (limited to 'devel/gvfs')
-rw-r--r--devel/gvfs/Makefile8
-rw-r--r--devel/gvfs/files/common_Makefile.am18
-rw-r--r--devel/gvfs/files/monitor_hal_Makefile.am10
3 files changed, 2 insertions, 34 deletions
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
index c794eaa32677..7dd6922bee4c 100644
--- a/devel/gvfs/Makefile
+++ b/devel/gvfs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gvfs
PORTVERSION= 1.26.3
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -15,7 +16,7 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgcr-base-3.so:${PORTSDIR}/security/gcr \
- libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
+ libsecret-1.so:${PORTSDIR}/security/libsecret
PORTSCOUT= limitw:1,even
@@ -33,7 +34,6 @@ CONFIGURE_ARGS+=\
--disable-gdu \
--disable-udev \
--disable-goa \
- --disable-keyring \
--disable-libmtp \
--disable-gtk
@@ -92,10 +92,6 @@ CONFIGURE_ARGS+=--disable-hal
PLIST_SUB+= HAL="@comment "
.endif
-# https://bugzilla.gnome.org/show_bug.cgi?id=722411
-post-patch:
- @${RM} ${WRKSRC}/monitor/hal/gvfsdbusutils.[ch]
-
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/remote-volume-monitors
@${RM} -rf ${STAGEDIR}${PREFIX}/lib/systemd
diff --git a/devel/gvfs/files/common_Makefile.am b/devel/gvfs/files/common_Makefile.am
deleted file mode 100644
index 5cd673a4c1dc..000000000000
--- a/devel/gvfs/files/common_Makefile.am
+++ /dev/null
@@ -1,18 +0,0 @@
---- common/Makefile.am.orig 2015-02-13 07:19:44 UTC
-+++ common/Makefile.am
-@@ -43,6 +43,15 @@ libgvfscommon_la_LIBADD = \
- $(GLIB_LIBS) \
- $(BLURAY_LIBS)
-
-+if USE_HAL
-+libgvfscommon_la_SOURCES += \
-+ gvfsdbusutils.c gvfsdbusutils.h
-+libgvfscommon_la_CFLAGS += \
-+ $(DBUS_CFLAGS)
-+libgvfscommon_la_LIBADD = \
-+ $(DBUS_LIBS)
-+endif
-+
- libgvfscommon_monitor_la_SOURCES = \
- gvfsmountinfo.h gvfsmountinfo.c \
- $(NULL)
diff --git a/devel/gvfs/files/monitor_hal_Makefile.am b/devel/gvfs/files/monitor_hal_Makefile.am
deleted file mode 100644
index f6f626b4bc83..000000000000
--- a/devel/gvfs/files/monitor_hal_Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- monitor/hal/Makefile.am.orig 2015-02-03 15:52:20 UTC
-+++ monitor/hal/Makefile.am
-@@ -23,7 +23,6 @@ gvfs_hal_volume_monitor_SOURCES = \
- ghalvolume.c ghalvolume.h \
- ghalmount.c ghalmount.h \
- ghalvolumemonitor.c ghalvolumemonitor.h \
-- gvfsdbusutils.c gvfsdbusutils.h \
- $(NULL)
-
- gvfs_hal_volume_monitor_CFLAGS = \