aboutsummaryrefslogtreecommitdiff
path: root/devel/hachoir-core/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-25 04:41:13 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-25 04:41:13 +0000
commitae2ce33730857dda77cc70d9c89beedddc26d5f3 (patch)
tree66f8eb08972cf951d276eacc3f424c87ddbbdf15 /devel/hachoir-core/Makefile
parentb7bd2982800fb8c226457a7c7af10a774aaf50ff (diff)
downloadports-ae2ce33730857dda77cc70d9c89beedddc26d5f3.tar.gz
ports-ae2ce33730857dda77cc70d9c89beedddc26d5f3.zip
Add ports devel/hachoir-core and devel/hachoir-parser:
Hachoir is the french name for a mincer: a tool used by butchers to cut meat. Hachoir is also a tool written for hackers to cut file or any binary stream. A file is splitted in a tree of fields where the smallest field can be just a bit. There are various field types: integer, string, bits, padding, sub file, etc. hachoir-parser is a package of most common file format parsers written using hachoir-core. Not all parsers are complete, some are very good and other are poor: only parse first level of the tree for example. WWW: http://hachoir.org/wiki/hachoir-core WWW: http://hachoir.org/wiki/hachoir-parser
Notes
Notes: svn path=/head/; revision=183230
Diffstat (limited to 'devel/hachoir-core/Makefile')
-rw-r--r--devel/hachoir-core/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/hachoir-core/Makefile b/devel/hachoir-core/Makefile
new file mode 100644
index 000000000000..d230e9564bbd
--- /dev/null
+++ b/devel/hachoir-core/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: hachoir-core
+# Date created: 25 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hachoir-core
+PORTVERSION= 0.7.2
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/h/${PORTNAME}/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Hachoir core parser
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>