aboutsummaryrefslogtreecommitdiff
path: root/devel/hgsvn/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-12-13 01:32:50 +0000
committerXin LI <delphij@FreeBSD.org>2007-12-13 01:32:50 +0000
commitfd3cd7d7cda51c8bc6398aeef742c0e2d4a9e976 (patch)
tree086552ad991439023e16a9f1bcf2b7bcb8a4be12 /devel/hgsvn/Makefile
parent2e1f858ad99fab02d8720b85b3f1187048fe7e29 (diff)
downloadports-fd3cd7d7cda51c8bc6398aeef742c0e2d4a9e976.tar.gz
ports-fd3cd7d7cda51c8bc6398aeef742c0e2d4a9e976.zip
Add hgsvn:
This set of scripts allows to work locally on Subversion-managed projects using the Mercurial distributed version control system. Why use Mercurial? You can do local (disconnected) work, pull the latest changes from the SVN server, manage private branches, submit patches to project maintainers, etc. And of course you have fast local operations like "hg log", "hg annotate"... Currenly two scripts are provided: * hgimportsvn initializes an SVN checkout which is also a Mercurial repository. * hgpullsvn pulls the latest changes from the SVN repository, and updates the Mercurial repository accordingly. It can be run multiple times. WWW: http://cheeseshop.python.org/pypi/hgsvn
Notes
Notes: svn path=/head/; revision=203432
Diffstat (limited to 'devel/hgsvn/Makefile')
-rw-r--r--devel/hgsvn/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/hgsvn/Makefile b/devel/hgsvn/Makefile
new file mode 100644
index 000000000000..7f3d8fb5cd3d
--- /dev/null
+++ b/devel/hgsvn/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-hgsvn
+# Date created: 2007-12-12
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hgsvn
+PORTVERSION= 0.1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= A set of scripts to work locally on Subversion checkouts using Mercurial
+
+DIST_SUBDIR= python
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=yes
+PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>