aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-BNFC
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
commit46e9ab0ca5e504d3509678b4d43a41d938650e75 (patch)
treea34afe36b374e7894e236fb8cee020928d36c967 /devel/hs-BNFC
parentbe44ec14c77de91f8ac86e25372545e0e39e9bcb (diff)
downloadports-46e9ab0ca5e504d3509678b4d43a41d938650e75.tar.gz
ports-46e9ab0ca5e504d3509678b4d43a41d938650e75.zip
- Update The Glorious Glasgow Haskell Compiler to version 7.4.1
Please note that port revision for all the Haskell ports without version changes are also bumped. Other per-port updates are coming soon (in separate commits)! In addition to that, separate -docs ports are no longer needed so they are now removed. Thanks ashish@ for the assistance. Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=298155
Diffstat (limited to 'devel/hs-BNFC')
-rw-r--r--devel/hs-BNFC/Makefile4
-rw-r--r--devel/hs-BNFC/files/patch-Main.hs13
-rw-r--r--devel/hs-BNFC/files/patch-MultiView.hs11
-rw-r--r--devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs15
-rw-r--r--devel/hs-BNFC/files/patch-formats__c__CTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs14
-rw-r--r--devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs29
-rw-r--r--devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs31
-rw-r--r--devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs20
-rw-r--r--devel/hs-BNFC/files/patch-formats__java__JavaTop.hs20
-rw-r--r--devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs11
-rw-r--r--devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs22
14 files changed, 231 insertions, 1 deletions
diff --git a/devel/hs-BNFC/Makefile b/devel/hs-BNFC/Makefile
index 53e2538f4d8b..f966141724d2 100644
--- a/devel/hs-BNFC/Makefile
+++ b/devel/hs-BNFC/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BNFC
PORTVERSION= 2.4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MAINTAINER= kaiw27@gmail.com
@@ -21,5 +21,7 @@ USE_CABAL= mtl
STANDALONE= yes
EXECUTABLE= bnfc
+HASKELL98= yes
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-BNFC/files/patch-Main.hs b/devel/hs-BNFC/files/patch-Main.hs
new file mode 100644
index 000000000000..cf13337bafea
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-Main.hs
@@ -0,0 +1,13 @@
+--- Main.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ Main.hs 2012-05-13 12:32:42.198463500 +0200
+@@ -41,8 +41,9 @@
+
+ import MultiView (preprocessMCF, mkTestMulti, mkMakefileMulti)
+
+-import System
+ import System.Exit
++import System.Environment
++import System.Process
+ import Char
+ import Data.List (elemIndex)
+
diff --git a/devel/hs-BNFC/files/patch-MultiView.hs b/devel/hs-BNFC/files/patch-MultiView.hs
new file mode 100644
index 000000000000..75b3553e4268
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-MultiView.hs
@@ -0,0 +1,11 @@
+--- ./MultiView.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./MultiView.hs 2012-05-12 22:16:41.000000000 +0200
+@@ -109,7 +109,7 @@
+ ["import qualified Print" ++ cnc | cnc <- cncs] ++
+ ["import Abs" ++ abs,
+ "import ErrM",
+- "import System (getArgs)",
++ "import System.Environment (getArgs)",
+ "",
+ "main :: IO ()",
+ "main = do",
diff --git a/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs b/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs
new file mode 100644
index 000000000000..f2b9c8a8a692
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__c-sharp__CSharpTop.hs
@@ -0,0 +1,15 @@
+--- ./formats/c-sharp/CSharpTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/c-sharp/CSharpTop.hs 2012-05-13 12:13:16.373594632 +0200
+@@ -48,10 +48,10 @@
+ import CFtoCSharpPrinter
+ import CFtoLatex
+ import CSharpUtils
+-import System
+ import GetCF
+ import Char
+-import System
++import System.Exit
++import System.Environment
+ import System.Directory
+ import System.IO
+ import System.Process
diff --git a/devel/hs-BNFC/files/patch-formats__c__CTop.hs b/devel/hs-BNFC/files/patch-formats__c__CTop.hs
new file mode 100644
index 000000000000..f982833d911b
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__c__CTop.hs
@@ -0,0 +1,14 @@
+--- ./formats/c/CTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/c/CTop.hs 2012-05-13 12:06:24.160466196 +0200
+@@ -26,10 +26,9 @@
+ import CFtoCSkel
+ import CFtoCPrinter
+ import CFtoLatex
+--- import System
+ import GetCF
+ import Char
+-import System
++import System.Exit
+
+ makeC :: Bool -> String -> FilePath -> IO ()
+ makeC make name file = do
diff --git a/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs b/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs
new file mode 100644
index 000000000000..9dc51c894329
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__cpp__CPPTop.hs
@@ -0,0 +1,14 @@
+--- ./formats/cpp/CPPTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/cpp/CPPTop.hs 2012-05-13 12:14:55.788469382 +0200
+@@ -27,10 +27,9 @@
+ import CFtoCVisitSkel
+ import CFtoCPPPrinter
+ import CFtoLatex
+-import System
+ import GetCF
+ import Char
+-import System
++import System.Exit
+
+ makeCPP :: Bool -> String -> FilePath -> IO ()
+ makeCPP make name file = do
diff --git a/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs b/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs
new file mode 100644
index 000000000000..a8f030e9385b
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__cpp_stl__STLTop.hs
@@ -0,0 +1,14 @@
+--- ./formats/cpp_stl/STLTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/cpp_stl/STLTop.hs 2012-05-13 12:10:03.269465642 +0200
+@@ -29,10 +29,9 @@
+ import CFtoCVisitSkelSTL
+ import CFtoSTLPrinter
+ import CFtoLatex
+-import System
+ import GetCF
+ import Char
+-import System
++import System.Exit
+ import STLUtils
+
+ makeSTL :: Bool -> Bool -> Maybe String -> String -> FilePath -> IO ()
diff --git a/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs b/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs
new file mode 100644
index 000000000000..f9bbbea1fb25
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__f-sharp__FSharpTop.hs
@@ -0,0 +1,14 @@
+--- ./formats/f-sharp/FSharpTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/f-sharp/FSharpTop.hs 2012-05-12 23:50:50.000000000 +0200
+@@ -35,10 +35,9 @@
+ import CFtoXML
+ import GetCF
+ import Utils
+-
++import System.Exit
+ import Char
+ import Data.Maybe (fromMaybe,maybe)
+-import System
+ import Monad(when)
+
+ -- naming conventions
diff --git a/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs b/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs
new file mode 100644
index 000000000000..44716c8c428c
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__haskell-gadt__HaskellTopGADT.hs
@@ -0,0 +1,29 @@
+--- ./formats/haskell-gadt/HaskellTopGADT.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/haskell-gadt/HaskellTopGADT.hs 2012-05-13 12:27:10.838459849 +0200
+@@ -42,7 +42,7 @@
+
+ import Char
+ import Data.Maybe (fromMaybe,maybe)
+-import System
++import System.Exit
+ import Monad(when)
+
+ -- naming conventions
+@@ -231,7 +231,7 @@
+ ["-- automatically generated by BNF Converter",
+ "module Main where\n",
+ "",
+- "import IO ( stdin, hGetContents )",
++ "import System.IO.Error ( stdin, hGetContents )",
+ "import System ( getArgs, getProgName )",
+ "",
+ "import " ++ alexFileM opts,
+@@ -242,7 +242,7 @@
+ if lay then ("import " ++ layoutFileM opts) else "",
+ if use_xml then ("import " ++ xmlFileM opts) else "",
+ if_glr "import Data.FiniteMap(FiniteMap, lookupFM, fmToList)",
+- if_glr "import Maybe(fromJust)",
++ if_glr "import Data.Maybe(fromJust)",
+ "import " ++ errFileM opts,
+ "",
+ if use_glr
diff --git a/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs b/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs
new file mode 100644
index 000000000000..612fdf92a196
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__haskell2__HaskellTop.hs
@@ -0,0 +1,31 @@
+--- ./formats/haskell2/HaskellTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/haskell2/HaskellTop.hs 2012-05-13 12:29:09.892465893 +0200
+@@ -42,7 +42,7 @@
+
+ import Char
+ import Data.Maybe (fromMaybe,maybe)
+-import System
++import System.Exit
+ import Monad(when)
+
+ -- naming conventions
+@@ -235,8 +235,8 @@
+ ["-- automatically generated by BNF Converter",
+ "module Main where\n",
+ "",
+- "import IO ( stdin, hGetContents )",
+- "import System ( getArgs, getProgName )",
++ "import System.IO ( stdin, hGetContents )",
++ "import System.Environment ( getArgs, getProgName )",
+ "",
+ "import " ++ alexFileM opts,
+ "import " ++ happyFileM opts,
+@@ -246,7 +246,7 @@
+ if lay then ("import " ++ layoutFileM opts) else "",
+ if use_xml then ("import " ++ xmlFileM opts) else "",
+ if_glr "import Data.FiniteMap(FiniteMap, lookupFM, fmToList)",
+- if_glr "import Maybe(fromJust)",
++ if_glr "import Data.Maybe(fromJust)",
+ "import " ++ errFileM opts,
+ "",
+ if use_glr
diff --git a/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs b/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs
new file mode 100644
index 000000000000..9876a272e7ae
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__java1.5__JavaTop15.hs
@@ -0,0 +1,20 @@
+--- ./formats/java1.5/JavaTop15.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/java1.5/JavaTop15.hs 2012-05-13 12:20:30.194507156 +0200
+@@ -39,7 +39,7 @@
+ -- Dependencies.
+ -------------------------------------------------------------------
+ import Directory ( createDirectory )
+-import IO ( try, isAlreadyExistsError )
++import System.IO.Error ( try, isAlreadyExistsError )
+
+ import Utils
+ import CF
+@@ -54,7 +54,7 @@
+ import CFtoFoldVisitor
+ import CFtoAllVisitor
+ import CFtoLatex
+-import System
++import System.Exit
+ import GetCF ( tryReadCF, writeFileRep )
+ import Char
+ import List(intersperse)
diff --git a/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs b/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs
new file mode 100644
index 000000000000..7bcf7de66d57
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__java__JavaTop.hs
@@ -0,0 +1,20 @@
+--- ./formats/java/JavaTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/java/JavaTop.hs 2012-05-13 12:22:38.512466534 +0200
+@@ -38,7 +38,7 @@
+ -- Dependencies.
+ -------------------------------------------------------------------
+ import Directory ( createDirectory )
+-import IO ( try, isAlreadyExistsError )
++import System.IO.Error ( try, isAlreadyExistsError )
+
+ import Utils
+ import CF
+@@ -49,7 +49,7 @@
+ import CFtoJavaSkeleton
+ import CFtoVisitSkel
+ import CFtoLatex
+-import System
++import System.Exit
+ import GetCF ( tryReadCF, writeFileRep )
+ import Char
+ import List(intersperse)
diff --git a/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs b/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs
new file mode 100644
index 000000000000..bfa4c9c7adaa
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__ocaml__OCamlTop.hs
@@ -0,0 +1,11 @@
+--- ./formats/ocaml/OCamlTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/ocaml/OCamlTop.hs 2012-05-13 12:04:23.291467169 +0200
+@@ -37,7 +37,7 @@
+
+ import Char
+ import Data.Maybe (fromMaybe,maybe)
+-import System
++import System.Exit
+ import Monad(when)
+
+ -- naming conventions
diff --git a/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs b/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs
new file mode 100644
index 000000000000..56003177cc93
--- /dev/null
+++ b/devel/hs-BNFC/files/patch-formats__profile__ProfileTop.hs
@@ -0,0 +1,22 @@
+--- ./formats/profile/ProfileTop.hs.orig 2010-09-15 16:26:38.000000000 +0200
++++ ./formats/profile/ProfileTop.hs 2012-05-13 12:25:17.510460618 +0200
+@@ -37,7 +37,7 @@
+ import Utils
+
+ import Char
+-import System
++import System.Exit
+ import Monad(when)
+
+ -- naming conventions
+@@ -184,8 +184,8 @@
+ "",
+ "import Trees",
+ "import Profile",
+- "import IO ( stdin, hGetContents )",
+- "import System ( getArgs, getProgName )",
++ "import System.IO ( stdin, hGetContents )",
++ "import System.Environment ( getArgs, getProgName )",
+ "",
+ "import " ++ alexFileM inDir name,
+ "import " ++ happyFileM inDir name,