aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-Stream
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:02:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:02:00 +0000
commit1efa109fa97ddeb35ec6fe03d77832ff4a6bdfeb (patch)
treee626e0c52fe3b38985463c4c36861a1958d5c1c2 /devel/hs-Stream
parentdf6f6cc586b1b3e4fa74a73ebe70973abcb79db5 (diff)
downloadports-1efa109fa97ddeb35ec6fe03d77832ff4a6bdfeb.tar.gz
ports-1efa109fa97ddeb35ec6fe03d77832ff4a6bdfeb.zip
This package implements functions, analogous to those from Data.List, to
create and manipulate infinite lists: data Stream a = Cons a (Stream a). It provides alternative definitions for those Prelude functions that make sense on such streams. WWW: http://www.cs.nott.ac.uk/~wss/repos/Stream/dist/doc/html/ PR: ports/129215 Submitted by: Samy Al Bahra <sbahra at kerneled.org>
Notes
Notes: svn path=/head/; revision=223582
Diffstat (limited to 'devel/hs-Stream')
-rw-r--r--devel/hs-Stream/Makefile37
-rw-r--r--devel/hs-Stream/distinfo3
-rw-r--r--devel/hs-Stream/pkg-descr6
-rw-r--r--devel/hs-Stream/pkg-plist13
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/hs-Stream/Makefile b/devel/hs-Stream/Makefile
new file mode 100644
index 000000000000..039799b83089
--- /dev/null
+++ b/devel/hs-Stream/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Stream
+# Date created: November 26, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= Stream
+PORTVERSION= 0.2.6
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= A Haskell library for manipulating infinite lists
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/devel/hs-Stream/distinfo b/devel/hs-Stream/distinfo
new file mode 100644
index 000000000000..b0a810ee98de
--- /dev/null
+++ b/devel/hs-Stream/distinfo
@@ -0,0 +1,3 @@
+MD5 (Stream-0.2.6.tar.gz) = 04a52fe84381c60c8830dac83915ae83
+SHA256 (Stream-0.2.6.tar.gz) = ce2b94a81a91497d024177654521d219aaab4462a381eb70c8199fefbb52edde
+SIZE (Stream-0.2.6.tar.gz) = 4885
diff --git a/devel/hs-Stream/pkg-descr b/devel/hs-Stream/pkg-descr
new file mode 100644
index 000000000000..4418b830261e
--- /dev/null
+++ b/devel/hs-Stream/pkg-descr
@@ -0,0 +1,6 @@
+This package implements functions, analogous to those from Data.List, to
+create and manipulate infinite lists: data Stream a = Cons a (Stream a).
+It provides alternative definitions for those Prelude functions that make
+sense on such streams.
+
+WWW: http://www.cs.nott.ac.uk/~wss/repos/Stream/dist/doc/html/
diff --git a/devel/hs-Stream/pkg-plist b/devel/hs-Stream/pkg-plist
new file mode 100644
index 000000000000..374bf4bba375
--- /dev/null
+++ b/devel/hs-Stream/pkg-plist
@@ -0,0 +1,13 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSStream-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSStream-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/Stream.hi
+%%SUBDIR%%/register.sh
+share/doc/Stream-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/Stream-%%PORTVERSION%%
+@dirrm lib/Stream-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data
+@dirrm lib/Stream-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/Stream-%%PORTVERSION%%
+@exec /bin/sh %D/%%SUBDIR%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister Stream
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old