aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hat
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-02-24 11:07:43 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-02-24 11:07:43 +0000
commit2e2c5217629dd92d626775d5d50279c1d09eea2e (patch)
treea22808f2a4ebfc2f1a288245033479304efaf3b6 /devel/hs-hat
parent30cd26bcb15aba11e667eec1fa878f5782195b76 (diff)
downloadports-2e2c5217629dd92d626775d5d50279c1d09eea2e.tar.gz
ports-2e2c5217629dd92d626775d5d50279c1d09eea2e.zip
- pass missing packages (post-patch)
- WITH_NHC98 is an OPTION - use PKGNAMESUFFIX (-ghc5/-nhc98) - remove BROKEN-tag PR: ports/63299 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
Notes
Notes: svn path=/head/; revision=101966
Diffstat (limited to 'devel/hs-hat')
-rw-r--r--devel/hs-hat/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 2b318a712315..5627d439d890 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -21,9 +21,7 @@ HAS_CONFIGURE= yes
USE_REINPLACE= yes
USE_GNOME= glib12
-BROKEN= "Does not compile"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-19
+OPTIONS= NHC98 "Build with nhc98" off
.include <bsd.port.pre.mk>
@@ -34,10 +32,12 @@ BROKEN= "does not build with nhc98 on this platform"
.if defined(WITH_NHC98)
BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
RUN_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+PKGNAMESUFFIX= -nhc98
.else
BUILD_DEPENDS= hmake:${PORTSDIR}/devel/hs-hmake \
ghc-5.04.3:${PORTSDIR}/lang/ghc5
RUN_DEPENDS+= ghc-5.04.3:${PORTSDIR}/lang/ghc5
+PKGNAMESUFFIX= -ghc5
.endif
ALL_TARGET= hat
@@ -83,6 +83,12 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e "s|glib-config|${GLIB_CONFIG}|" \
${WRKSRC}/configure ${WRKSRC}/src/hattools/Makefile
+.if !(defined(WITH_NHC98))
+.for f in hattrans/Makefile hatlib/Makefile
+ @${REINPLACE_CMD} -e "s/package lang/package lang -package haskell98/" ${WRKSRC}/src/${f}
+.endfor
+ @${REINPLACE_CMD} -e "s/package lang/package lang -package base -package haskell98/" ${WRKSRC}/src/hattools/Makefile
+.endif
post-install:
.if !defined(WITH_NHC98)