aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-pcre-light
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
commit7d5781e5ab3aa2c4d9f46985acec697caae1c173 (patch)
treefb0e55efa60858746649977ee5813f549bfbad04 /devel/hs-pcre-light
parent9acc5ac910695e85c7d24401bfecd5d6e6da0d7f (diff)
downloadports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.tar.gz
ports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.zip
- Update GHC and Haskell ports to 6.10.4 (for both i386 and amd64), bump
port revision where appropriate - Add devel/hs-ghc-paths - Add devel/hs-QuickCheck - Add devel/hs-readline - Add devel/hs-haskeline - Add devel/hs-mmap - Remove lang/ghc-doc - Mark devel/lhs2TeX broken as it does not compile with GHC 6.10.4 - Set NHC98 as default compiler for devel/hs-hat as it does not compile with GHC 6.10.4 PR: ports/137055, ports/137058, ports/137059, ports/137060, ports/137061, ports/137062, ports/137063, ports/137063, ports/137064, ports/137065, ports/137066, ports/137067, ports/137068, ports/137069, ports/137070, ports/137071, ports/137072, ports/137074, ports/137075, ports/137076, ports/137077, ports/137078, ports/137079, ports/137080, ports/137081, ports/137082, ports/137083, ports/137084, ports/137085, ports/137086, ports/137087, ports/137088, ports/137090, ports/137091, ports/137092, ports/137093, ports/137094, ports/137095, ports/137096, ports/137097, ports/137098, ports/137099, ports/137102, ports/137103, ports/137104, ports/137107, ports/137108, ports/137109, ports/137110, ports/137111 Submitted by: Jacula Modyun (jacula (at) gmail (dot) com), Ashish Shukla (wahjava (at) gmail (dot) com) (amd64 support) Supported by: wxs (review, amd64 testing), tabthorpe (8.x testing) Approved by: tabthorpe (mentor), respective maintainers
Notes
Notes: svn path=/head/; revision=240717
Diffstat (limited to 'devel/hs-pcre-light')
-rw-r--r--devel/hs-pcre-light/Makefile63
-rw-r--r--devel/hs-pcre-light/pkg-descr4
-rw-r--r--devel/hs-pcre-light/pkg-plist33
3 files changed, 64 insertions, 36 deletions
diff --git a/devel/hs-pcre-light/Makefile b/devel/hs-pcre-light/Makefile
index 1b80dc3662ca..db219098037e 100644
--- a/devel/hs-pcre-light/Makefile
+++ b/devel/hs-pcre-light/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pcre-light
PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -20,38 +20,61 @@ BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
-GHC_VERSION= 6.8.3
-CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
-CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+GHC_VERSION= 6.10.4
+PCRELIGHT_VERSION= ${PORTVERSION}
-SUBDIR= lib/${PORTNAME}-${PORTVERSION}
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- PORTNAME=${PORTNAME} \
- PORTVERSION=${PORTVERSION} \
- SUBDIR=${CABALDIR}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-PORTDOCS= LICENSE html
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
-CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+PCRELIGHT_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PCRELIGHT_VERSION=${PCRELIGHT_VERSION} \
+ PCRELIGHT_LIBDIR_REL=${PCRELIGHT_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.else
-PLIST_DIRS+= %%DOCSDIR%%
-PLIST_FILES+= %%DOCSDIR%%/LICENSE
.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w \
+ --extra-include-dirs=${LOCALBASE}/include \
+ --extra-lib-dirs=${LOCALBASE}/lib --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${CABALCMD} haddock
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
.endif
do-install:
- cd ${WRKSRC} && ${CABALCMD} install
- ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${PCRELIGHT_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.include <bsd.port.mk>
diff --git a/devel/hs-pcre-light/pkg-descr b/devel/hs-pcre-light/pkg-descr
index 7018663a7db1..b4cc9d1c14dc 100644
--- a/devel/hs-pcre-light/pkg-descr
+++ b/devel/hs-pcre-light/pkg-descr
@@ -1,5 +1,5 @@
-A small, efficient and portable Haskell regex library for Perl 5
-compatible regular expressions.
+A small, efficient and portable Haskell regex library for Perl 5 compatible
+regular expressions.
The PCRE library is a set of functions that implement regular expression
pattern matching using the same syntax and semantics as Perl 5.
diff --git a/devel/hs-pcre-light/pkg-plist b/devel/hs-pcre-light/pkg-plist
index 655486b56580..77c2f52f2ba0 100644
--- a/devel/hs-pcre-light/pkg-plist
+++ b/devel/hs-pcre-light/pkg-plist
@@ -1,14 +1,19 @@
-%%SUBDIR%%/Text/Regex/PCRE/Light.hi
-%%SUBDIR%%/Text/Regex/PCRE/Light/Base.hi
-%%SUBDIR%%/Text/Regex/PCRE/Light/Char8.hi
-%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%SUBDIR%%/%%PORTNAME%%-register.sh
-@dirrmtry %%SUBDIR%%/Text/Regex/PCRE/Light
-@dirrmtry %%SUBDIR%%/Text/Regex/PCRE
-@dirrmtry %%SUBDIR%%/Text/Regex
-@dirrmtry %%SUBDIR%%/Text
-@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
-@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec ghc-pkg unregister %%PORTNAME%%
-@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@comment $FreeBSD$
+%%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSpcre-light-%%PCRELIGHT_VERSION%%.o
+%%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex/PCRE/Light.hi
+%%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex/PCRE/Light/Base.hi
+%%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex/PCRE/Light/Char8.hi
+%%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSpcre-light-%%PCRELIGHT_VERSION%%.a
+%%PCRELIGHT_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex/PCRE/Light
+@dirrm %%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex/PCRE
+@dirrm %%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Regex
+@dirrm %%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
+@dirrm %%PCRELIGHT_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%PCRELIGHT_LIBDIR_REL%%
+@exec /bin/sh %D/%%PCRELIGHT_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister pcre-light
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old