aboutsummaryrefslogtreecommitdiff
path: root/devel/i386-rtems-objc
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2004-01-22 12:12:48 +0000
committerJames E. Housley <jeh@FreeBSD.org>2004-01-22 12:12:48 +0000
commit1464e9906bf82f06cca041f9d9908706774932ff (patch)
tree9af1f58826a9dc02024aa1ab566785d5bf71d5f0 /devel/i386-rtems-objc
parentf23ad694cc4e8560284bd83ac7bbe958f151bb71 (diff)
downloadports-1464e9906bf82f06cca041f9d9908706774932ff.tar.gz
ports-1464e9906bf82f06cca041f9d9908706774932ff.zip
Revert back to previous method to remove the CPU related entries from
CFLAGS. At least on 4.9, the new changes to bsd.port.mk don't like if _CPUCFLAGS is empty.
Notes
Notes: svn path=/head/; revision=98791
Diffstat (limited to 'devel/i386-rtems-objc')
-rw-r--r--devel/i386-rtems-objc/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index ef068265da54..7362a7cd0abe 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -56,9 +56,14 @@ CONFIGURE_SCRIPT?= ../${OBJCNAME}/configure
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p
-WITHOUT_CPU_CFLAGS= true
-MAKE_FLAGS= LANGUAGES="objc"
-MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH}
+NO_CPU_FLAGS= true
+MAKE_FLAGS= LANGUAGES="objc"
+MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH} NO_CPU_CFLAGS=true
+# Since once mk/bsd.cpu.mk adds the _CPUCFLAGS they can't be removed
+# by NO_CPU_FLAGS, and since they are added long before here we are
+# stuck with this hack.
+CFLAGS:= ${CFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
+CXXFLAGS:= ${CXXFLAGS:C/-mcpu=[^ ]*//:C/-march=[^ ]*//:C/-mtune=[^ ]*//}
pre-configure:
@(cd ${WRKDIR} ; \